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Introduction

Welcome to Maya, the world’s leading software application for
3D digital animation and visual effects. Maya provides a
comprehensive suite of tools for your 3D content creation work
ranging from modeling, animation, and dynamics through to
painting and rendering to name but a few.

With Maya, you can create and edit 3D models in a variety of
modeling formats and animate your models using Maya’s suite of
animation tools. You can create convincing visual simulations of
rigid and soft body objects interacting in the physical world using
the computational dynamics and particles tools. Maya also
provides a range of tools to allow you to render your animated 3D
scenes to achieve photo realistic imagery and animated visual
effects

The Maya software interface is fully customizable for those users
who require the ability to maximize their productivity. Maya
allows users to extend their functionality within Maya by
providing access to MEL (Maya Embedded Language). With
MEL, you can customize the user interface and write scripts and
macros. In addition, a full Application Programmers Interface
(API) is available to enhance the power and functionality of Maya.

The content creation power of Maya is provided to users in an
integrated software application that is designed to enhance user
productivity and ease of use.

The goal of this manual is to assist you in getting started with
Maya as you embark upon your learning path.

This chapter provides the following information:

e About Getting Started with Maya—Contents of the Getting
Started with Maya manual.

Getting Started with Maya
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> About the Getting Started tutorials

*  Prerequisites—-What you should know before using Getting
Started with Maya.

* Installing Maya-Information on installing Maya.

*  Using the Getting Started with Maya files—How to copy the
files provided on CD-ROM for the Getting Started with Maya
lessons.

*  Maya Help—Outlines the help resources provided with your
Maya software.

* Additional Resources—Outlines resources beyond what is
included with your Maya software.

About the Getting Started tutorials

Getting Started with Maya introduces the different areas of Maya in
a set of brief tutorials. The tutorials are designed to let you learn
these modules at your own pace.

If you are new to Maya, this manual gets you started on your
learning path. If you are an existing user or are transitioning from
another 3D software application, Getting Started with Maya
provides a starting point for understanding features you haven’t
yet had time to learn.

If you are a user of Maya Unlimited you can learn about the
features of your software by going through the lessons in Getting
Started with Maya Unlimited which accompanies your software
package. If you are new to Maya, we recommend that you begin
with the tutorials contained within Getting Started with Maya.

Getting Started with Maya is not meant to replace the
documentation that comes with the Maya software. Only the
commands and options used in the lessons are explained in this
manual. You will find the Maya Help provides an excellent
companion reference to the lessons and much more.

Getting Started with Maya
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> Additional lessons in the Maya Help

Many of the tutorials in Getting Started with Maya contain one or
more separate lessons that provide step-by-step instructions for
creating or accomplishing specific tasks within Maya. You can
follow the tutorials in this book from start to finish or complete
only the tutorials that correspond to your interests and needs.

We recommend that any new Maya user begin by completing the
following:

* Viewing the Essential Skills Movies that are available when
you first start Maya.

*  Completing the Maya Basics tutorial (Chapter 2) which
introduces many fundamental concepts and skills related to
the Maya user interface.

Getting Started with Maya is also available for use within the
Maya Help. This version of Getting Started with Maya contains
mpeg movies for some of the lessons that supplement the printed
version of the manual.

To use the tutorials from the Maya Help

1 In Maya, select Help > Tutorials.

The Maya Help window displays the Getting Started with
Maya tutorials.

2 Click the tutorial you want to work through.

The Maya Help displays the associated lessons for that
tutorial.

Additional lessons in the Maya Help

The Maya Help version of Getting Started with Maya includes
two additional lesson chapters that are not available in the printed
version of this manual. The two additional lesson chapters are:
Expressions and MEL. You can view them in the Maya Help; for

Getting Started with Maya
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more information, see “Maya Help” on page 23. Any data files
required for these lessons are included with the Maya
Documentation, Lessons, and Extras CD.

Before you begin

Before beginning Getting Started with Maya, you should have a
working knowledge of your computer’s operating system. You
should know how to use a mouse, select menus, and enter text
and commands from your keyboard. You should also know how
to open and save files, copy files from a CD-ROM to your hard
drive, and be able to navigate your computer operating system’s
file browser.

If you require an overview or review of these techniques, we
recommend that you refer to the documentation that came with
your particular computer and operating system.

If you are new to 3D computer graphics and animation, you may
want to obtain The Art of Maya (ISBN: 1-894893-13-1, available
from the Alias online store). It explains many concepts and
techniques that are unique to the world of 3D computer graphics
as they relate to Maya.

Installing Maya

You must have Maya installed and licensed on your computer
system to successfully complete the lessons in this manual. To
operate Maya on your computer you must be running a qualified
Windows, Mac OS X, IRIX, or Linux operating system with the
recommended minimum memory and storage requirements.
Maya requires a three button mouse to access its full functionality
for menus, commands, and 3D viewing.

Getting Started with Maya
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> Conventions used in this book

For complete instructions on qualified hardware and operating
systems, as well as installation and licensing of the Maya
software, please refer to the Installation and Licensing manual that
came with your Maya software or see the Support section of our
Web site at www.alias.com.

Conventions used in this book

Some important conventions used throughout Getting Started
with Maya are explained here.

Maya is available for use on a wide range of operating systems.
Any differences between operating systems when operating Maya
are identified in the following ways:

(Windows), (Mac OS X), (IRIX), (Linux)

The screen illustrations and examples within Getting Started with
Maya vary among the Windows, Mac OS X, IRIX, and Linux
operating systems. Maya’s interface is generally consistent across
these systems.

When instructed to select a menu within Maya we use the
following convention:

*  Menu > Command (For example, File > New Scene)

File Edit Modify Create Display ‘Window Edit Curves

MNew Scene k Ckel+n
CIpen SCene. .. Ckrl+o m |
Coua Srana Thel e [ |

When you are instructed to select the option box for a particular
menu item within Maya, we use the following convention:

*  Menu > Command > Option (For example, Create > NURBS >
Primitives > Sphere > 0.

Getting Started with Maya
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File Edit Modify | Create Display ‘Window Edit Curves Surfaces
|

MURES Primitives o
Polygon Primitives  # RIS E

Stibidive Primibives k

Using the lesson files

Some of the Getting Started with Maya lessons have
accompanying Maya files that were created for use with the
lessons. These files are contained on the Maya Documentation,
Lessons, and Extras CD-ROM which is included with your Maya
software package. To use the lesson files, do one of the following:

Open the Getting Started with Maya lesson files directly from
the Maya Documentation, Lessons, and Extras CD-ROM.

Copy the Getting Started with Maya lesson files to your
computer’s hard drive and then open them from your hard
drive.

To open the lesson files from your CD-ROM drive

1

Getting Started with Maya
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Insert the Maya Documentation, Lessons, and Extras CD-ROM
into your drive.

Within Maya, select File > Open Scene.

Navigate to the CD-ROM drive, locate the Getting Started
with Maya folder, and select it.

Double-click on the Getting Started with Maya lessons folder
to view its contents.

Double-click the specific lesson and tutorial file to open it in
Maya.
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> Maya Help

To copy the lesson files from the Maya
Documentation, Lessons, and Extras CD-ROM

1

Insert the Maya Documentation, Lessons, and Extras CD-ROM
into your drive.

From the CD-ROM, copy the Getting Started with Maya
folder to your computer into the following directory:

(Windows) drive: \Documents and Settings\username\
My Documents\maya\projects

(Mac OS X) users/username/Library/Preferences/Alias/
maya/projects

(IRIX & Linux) ~username/maya/projects

When you are asked to open specific lesson files, open the

Getting Started with Maya lessons that you have copied to the
projects directory.

Maya Help

Your Maya software application comes with a comprehensive set
of documentation resources.

Essential Skills Movies

The first time you start Maya, the Essential skills movies window
displays in Maya. Watch these movies to learn about the skills
you need to master when you first use Maya.

Getting Started with Maya
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{yl Learning Movies =101 x|

Essential skills movies
J
< &‘ Zoom, pan and roll: Navigation essentials

Move, rotate, scale Discover secret menus

@

Create & view objects Keyframe animation

e

Component gelection Preview render

R @

I Do not show this at startup - QuickTime 6.5 or reater recommended  pownload now

To play the Essential Skills Movies

1 In the Essential Skills Movies window, click the buttons to
play the movie.

Your computer launches its default multimedia player and
your chosen movie begins to play.

2 Click your multimedia player’s controls to start, stop, and
pause the movie.

3 To view the online help of your multimedia player, select its
help menu.

To close the Essential Skills Movies window or the
multimedia player

1 To close the Essential Skills Movies window, click the close
box in the upper right corner of the window.

Getting Started with Maya
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If you do not want to have this dialog box automatically
display when you start Maya, turn on the Don't show this at
startup check box.

2 To close the multimedia player, select File > Exit or click the
close box in the upper right corner of the window. (This
instruction may vary depending upon which multimedia
player is used)

If you want to watch the movies in the future

* In Maya, select Help > Learning Movies.

The Essential Skills Movie window appears.

Maya Help

Your Maya software application comes installed with Maya
technical documentation that assists you in learning the Maya
software. The Maya Help is HTML-based, structured by module,
fully searchable, and is displayed using your computer’s web
browser.

The Maya Help is topic based and displays the major functionality
categories for Maya. The Maya Help can assist you in finding
reference information about particular topics, how to perform
specific tasks, and MEL command references.

To launch the Maya Help

*  Select Help > Maya Help.

The Maya Help appears in a separate browser (depending on
your user preference settings)

To obtain help on a particular Maya topic

e Inthe Maya Help window, click the name of the Maya topic
you want information about (for example, Animation,
Dynamics, MEL commands, etc.).

Getting Started with Maya
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The Maya Help displays the associated sub-topics and
categories associated with the name you selected.

Maya Index and search

You can search the Maya Help directly using the index and search
capabilities. With these tools you find the Maya topic you're
looking for by searching the topic word in an alphabetic list or by
directly typing the topic word(s) into the search field and having
the search tool find the documentation entries associated with it.

To use the Maya Index

1

In Maya, select Help > Maya Help.

The Maya index appears near the top of the Help window as a
an alphabetic set of icons.

To view an index entry by alphabetic listing, click the letter
icon that is associated with the first letter of your desired topic
(for example: Click on D for Dynamics).

The Maya index displays all entries in the Maya Help that
begin with the letter D in the left navigation pane.

Scroll through the alphabetic listing until you find the entry
you are looking for using the scroll bar on the right side of the
pane.

In the left navigation pane, click the entry you want.

The information related to that topic appears in the right
pane.

To use the Maya Search

1
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Select Help > Maya Help.

The Maya Help appears in a separate window (depending on
your user preferences). You search for your topic by typing in
a specific word that best represents the information you
require.
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2 In the Search text box at the top of the Maya Help window,
type a word that best represents your search topic.

3 C(lick the magnifying glass icon to begin your search.

The search results appear in the left navigation pane, sorted
by relevancy.

4 Click the appropriate search result in the left window.

The information related to that entry appears in the right
window. By default, the search will find both topic related
information as well as task based and related tutorials.

Popup Help

Popup Help provides you with a quick method of identifying a
particular tool or icon in the Maya user interface.

iMaya
File Edit Modify Create Display ‘Window Edit Curves  Sorfaces

;IMadeling "I| ~ | EIDbiects | mﬁ

a Generall Cuirvs nsl Sul:u:livsl Defu:urmatiu:un|
Create a new scene
2 e X R}

To use Popup Help

*  Move your mouse cursor over an icon or button.
The name or description of it appears in a popup window
directly over it.

To enable Popup Help if it does not appear

1 Select Help.
The Help menu appears.

Getting Started with Maya
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2 If a check mark is displayed beside the word Popup it
indicates that the Popup Help is enabled. If a check mark is
not displayed beside the word Popup, follow the next step:

3 In the Help menu, select Popup.

The next time you access the Help menu, a check mark
appears beside the Popup menu item, indicating that Popup
Help is enabled.

Help Line

The Help Line at the bottom of Maya's window shows
information about tools, menus, and objects. Like the Popup help,
it displays descriptions when you move the mouse over icons and
menu items. It also displays instructions when you select a tool.
This is useful if you don’t know or forget how to use a particular
tool.

'I 2 4

'|1nn 1.00 B

TI Move Tool: Select an object ta move — Help Line

To use the Help Line

*  Move your mouse cursor over an icon or button.
The icon or button name and instructions about how to use
that tool appear in the Help Line.

Find Menu

The Find Menu allows you to find the location of a particular
menu. Find Menu works only on the main menu items.

Getting Started with Maya
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Enter a string to zearch far:

[~ Use Case Sensitive Search

Create->*NURES Primitives-»Sphere

Create-*Polygon Primitiwves-—-=>S8phere
Create-*>Subdiv Primitiwves—=>S8phere
Create->Volume Primitiwves—->Sphere

No more matches found. I

To find the location of a main menu item

1 Select Help > Find Menu.
The Find Menu window appears.

2 Type the menu item you want to locate in the text field, and
press Enter (Windows, IRIX, and Linux), Return (Mac OS X).

The possible locations for the main menu display in the
results field of the Find Menu window.
Maya Quick Reference

Maya Quick Reference is a printed reference that came with your
Maya software package. It contains keyboard shortcut
information that you will want to keep handy for quick reference.

Additional learning resources

Beyond the Maya help resources within your Maya software, you
can access the following resources to learn more about Maya or
obtain technical assistance.

The Alias Web site

The Alias Web site contains a wealth of resources related to your
Maya software and related products and services.

Getting Started with Maya
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You can view the Alias Web site by selecting
Help > Alias on the Web in Maya or by entering www.alias.com in
your web browser.

Alias Education

Alias provides a range of products and services to help you get
the most from your Maya software. You can purchase additional
self-study learning materials or attend certified instructor led
training courses at our Alias training facilities. Alias also runs
Maya seminars at major computing trade shows and events. For
more information, select the Education link on the Alias web site.

Alias Support

Alias Support delivers technical support services globally through
telephone and email Hotline services, as well as online eSupport
services. For more information, click the Maya Support Center
link from the Maya Help menu or click the Support link on the
Alias web site.

Restoring default user settings

If you have already used Maya or have a prior version of Maya
installed, you should restore the default settings for Maya before
you begin the lessons. This ensures that Maya appears and
operates exactly as the lessons describe.

If you are an existing user of Maya we recommend that you save
your existing preferences for later use prior to restoring the
default user settings.

To save your existing custom user preferences

1 Ensure Maya is not running.

Each time you exit Maya it saves the configuration of most
components of your user interface so it appears the same
when you start it the next time. It writes the preferences to a

Getting Started with Maya
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directory called prefs. If you rename the prefs directory, your
original preferences will be maintained and Maya will create a
new prefs directory the next time it is run.

2 Rename your existing user preferences file to a name, for
example, myprefs. The prefs directory path is:

(Windows) drive: \Documents and Settings\username\
My Documents\maya\6.0\prefs

(Mac OS X) users/username/Library/Preferences/Alias/
maya/6.0/prefs

(IRIX & Linux) ~username/maya/6.0/prefs

If you have a previous version of Maya installed, also rename
that prefs directory to a new name such as myprefs. Maya will
load older preferences if they exist from a previous version.

3 Start Maya and begin the Getting Started with Maya lessons.
To restore your custom user preferences after doing
the lessons

1 Ensure Maya is not running.

2 Rename the previously changed preferences back to prefs.
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Maya Basics

Critical to learning any
software program is some
initial understanding of the
basic concepts: how that
software’s world works and
the fundamental skills you
need to work in that world. If
you have never used a three
dimensional (3D) software
application before, you may
initially find Maya different
compared to 2D applications.

If you are wondering “where
do I begin?”, this chapter is
the best place to start. We
recommend that you
complete the lessons in this

Image created by: David Atkinson

chapter so the essential concepts and skills presented become

familiar to you.

This chapter covers some of the fundamental concepts and skills

for Maya in four lessons:

*  “Lesson 1: An overview of Maya’s user interface” on page 35

e “Lesson 2: Creating, manipulating, and viewing objects” on

page 50

*  “Lesson 3: Viewing the Maya 3D scene” on page 67

*  “Lesson 4: Components and Attributes” on page 90

Getting Started with Maya
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Preparing for the lessons

To ensure the lessons work as described:

Getting Started with Maya
34

Ensure Maya is installed and licensed on your computer.

If you have not installed Maya yet, refer to the Installation and
Licensing manual that accompanies your Maya software
package. It outlines the requirements for installing Maya and
procedures for installation and licensing Maya on supported
hardware platforms.

If you have never started Maya on your computer before, it
will start for the first time using the default preference
settings.

If you have run Maya before, you should ensure that your
Maya user preferences are reset to their default setting. This
ensures that the lessons appear and work as described.

Refer to Before you begin the lessons section in the Introduction
of this book for instructions on resetting user preferences to
the default setting.
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An overview of Maya’s user
interface

Just as the driver of an automobile is familiar with the dashboard
of their vehicle, it is important for you to become familiar with the
Maya “dashboard.”

The Maya user interface refers to everything that the Maya user
sees and operates within Maya. The menus, icons, scene views,
windows, and panels comprise the user interface.

Through the Maya user interface you access the features and
operate the tools and editors that allow you to create, animate,
and render your three dimensional objects, scenes, and effects
within Maya.

As you spend time learning and working with Maya, your
knowledge of and familiarity with the user interface will increase
until it becomes second nature.

In this lesson you learn how to:

e Start Maya on your computer.

*  Use the Maya interface so that you can begin to understand
where and how to access the critical tools to get started with
Maya.

*  Select the menu and icon sets within Maya.
* Learn the names of tools related to the icons in Maya.

° Create a new scene view.

This first lesson contains additional explanations of the tools and
concepts compared to many of the lessons later in this manual.
We suggest you take some time to review these explanations as
they lay the foundation for understanding where things are in
Maya.

Getting Started with Maya
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Starting Maya

To start Maya on Windows
Do one of the following:

*  Double-click the Maya icon on your desktop.

e (Windows 2000 Professional) From the Windows Start
menu, select Programs > Alias > Maya 6.0 > Maya
(Complete or Unlimited)

*  (Windows XP Professional) From the Windows Start
menu, select All Programs > Alias > Maya 6.0 > Maya
(Complete or Unlimited)

To start Maya on Mac OS X

Do one of the following:

*  Double-click the Maya icon on your desktop.
*  Click the Maya icon in the Dock.

*  From the Apple Finder menu, select Go > Applications
and then browse for the Maya icon and double-click it to
start Maya.

To start Maya on IRIX or Linux

Do one of the following:

*  Double-click the Maya icon on your desktop.

* In ashell window, type: maya.

The Maya interface

Now that Maya is running, you first need to understand what you
are seeing. There are a lot of items displayed in the Maya user
interface.

Getting Started with Maya
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The best way to begin is to learn the fundamental tools and then
learn additional tools as you need them. Begin by learning some
of the main tools.

Menu Bar Status Line Shelf  Workspace  Channel Box
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The Maya workspace

The Maya workspace is where you conduct most of your work
within Maya. The workspace is the central window where your
objects and most editor panels appear.
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Panel Menu Grid Origin
|

View Shading _Lighting _Show _Pandis

z-X

|
Axis Direction Indicator Camera View Type

When you start Maya for the first time, the workspace displays by
default in a perspective window, or panel. There are the other
components of the default perspective view panel:

*  The panel is labeled persp at the bottom to indicate that you
are viewing the Maya scene from a perspective camera view.

e The panel has its own menu bar at the top left corner of the
panel. These menus allow you to access tools and functions
related to that specific panel.

e The grid is displayed with two heavy lines intersecting at the
center of the Maya scene. This central location is called the
origin. The origin is the center of Maya’s 3D world, and with
all object’s directional values measured from this location.
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X, Y, Z Origin

In Maya, like many other 3D applications, the three dimensions
are labeled as the X, Y, and Z axes. The origin is located at X, Y, Z
position of 0, 0, 0. The grid also lies along the X, Z plane. We refer
to this as a plane because you might visualize an imaginary, flat,
two-dimensional square laying along this 3D position.

Maya labels the X, Y, and Z axes with a color scheme: red for X,
green for Y, and blue for Z. Many tools that you use in Maya use
this color scheme to indicate that you are accessing a particular
item that relates to X, Y, and Z in some way.

Move Rotate Scale

Color-coded
transformation
manipulators

1 ‘
/\\\j‘ .

The axis indicator shows in which direction, X, Y, or Z, you are
viewing the Maya scene. The axis indicator is color coded in the
red, green, and blue color scheme and appears in the lower left
corner of a view panel.
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This is extremely useful if you are new to 3D, as many of the
instructions in this manual and the Maya Help assume you know
where you are viewing the scene in relation to the X, Y, Z axes.

Main Menu Bar

Tools and items are accessible from pull down menus located at
the top of the user interface. In Maya, menus are grouped into
menu sets. These menu sets are accessible from the Main Menu
Bar.

The Main Menu bar appears at the top of the Maya interface
directly below the Maya title bar and displays the chosen menu
set. Each menu set corresponds to a module within Maya:
Animation, Modeling, Dynamics, and Rendering. Modules are a
method for grouping related features and tools. (Maya Unlimited
has additional menu sets: Cloth, Fur, and Live.)

Menu Selector

u-- Create Display Wlndow E

@z P

WM Curves  Surfaces | Polygonsl Si
I I“"‘ i
= ddbee,

lading Lighting Show  Panels

You switch between menu sets by choosing the appropriate
module from the menu selector on the Status Line (located
directly below the File and Edit menus). As you switch between
menu sets, the right-hand portion of the menus change, but the
left-hand portion remains the same; the left-hand menus are
common menus to all menu sets. The left-hand menus contain
File, Edit, Modify, Create, Display, and Window.
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Common menus Animation specific menus
[ 11 1
File Edit Modify Create Display Window Animate Deform  Skeleton  Skin Constrain  Character  Help
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To select a specific menu set

Al

1 On the Status line, select Animation from the drop-down
menu.

The Main Menu changes to display the menu set that relates
to the Animation module. In particular, menu titles such as
Animate, Deform, Skeleton, Skin, and so on, appear.

2 Using the menu selector, choose Modeling from the drop-
down menu.

The main menu changes to display the menu set for
Modeling. Menu titles such as Edit Curves, Surfaces, Edit
NURBS, and so on, appear.

For now, leave the menu set at Modeling. You will use this set
in the next step.

To create a primitive 3D object from the Modeling
menu set

1 From the Main Menu Bar, select Create > Polygon Primitives
> Cube.

Maya creates a 3D cube primitive object and places it at the
center (origin) of the Maya workspace.
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View shading _Lighting_Show _Panels

Status Line

The Status Line, located directly below the Main Menu bar,
contains a variety of items, most of which are used while
modeling or working with objects within Maya. Many of the
Status Line items are represented by a graphical icon. The icons
save space in the Maya interface and allow for quick access to
tools used most often.

In this lesson, you learn about some of the Status Line areas.

Menu Selector Scene icons  Selection Mode Selection Masks

iyl Maya

You've already learned the first item on the Status line: the Menu
Selector used to select between menu sets.

The second group of circled icons relate to the scene and are used
to create, open, and save your Maya scenes.

The third and fourth group of buttons are used to control how
you can select objects and components of objects. You will learn
more about selection of objects in later lessons.

Getting Started with Maya
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The fifth group of icons are used to control the Snap Mode for
objects and components. You will begin to use these tools in a
later lesson in this chapter.

The last section comprise three buttons that are used to show or
hide editors, including the Attribute Editor, Channel Box, Layer
Editor, and Tool Settings. The default display shows the Channel
Box and the Layer Editor. When you create an object, like the cube
for example, information about that object displays in these
editors. You will learn how to use these editors later in this
chapter.

Snap Mode icons Show/Hide Editor icons

srfaces  Help

7A@ S| Oy EEE|

1 I Fur I Eustoml

For better organization on the Status Line, all of the icon buttons
are broken into groups that you can expand and collapse, as
shown.

Collapse icon groups by clicking on vertical bars

File Edit Modify Create Display  Wipdow Edit O 5 Edit WURES Polygons  Edit Polygons  Sub

O e e Ha a0 e

Expand icon groups by clicking on vertical arrow bars

File Edit Modify Create [ Window Edit Curves  Surfaces  Edit NURES  Polygons  Edit Polygons  Su
(e
Shelf

The Shelf is located directly below the Status line. The Maya Shelf
is useful for storing tools and items that you use frequently or
have customized for your own use. You can keep the tools and
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items you use most frequently in a location that provides handy
access. Maya has some of the Shelf items pre-configured for your
use.

File Edit Modify Create Display Window Edit Curves Surfaces

Shelf

m Wiews Shading Lighting Show Panels

To create an object using a tool from the Shelf

1 From the Shelf, select the Surfaces tab in order to view the
tools located on that shelf.

File Edit Modify Create Display Window Edit Curves Surfaces

General | Curdgs Surfacesl Iygonsl Subdivsl Deformationl

Surfaces Tab

m Wiews Shading Lighting Show Panels

2 From the shelf, select the NURBS sphere icon located on the
left end of the shelf by clicking on it.

Maya creates a sphere primitive object and places it at the
center of the Maya workspace in the same position as the
cube.
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Tip You can determine if this is the correct tool prior to
choosing it by first placing your mouse cursor over the
icon, the name or description of it appears in a popup
window directly over it.

File Edit Modify Create Display Window Edit Curves

EIModeIing vl| - | EIDbiects |

Generall Curves  Surfaces | Polygonsl Subdivsl Deh

fox

Tool Popup ¥ HURES Sphere: Create a NURES sphere on the grid

In your scene view the wireframe outline of the cube you created
earlier in the lesson has changed color to navy blue, and the
sphere is displayed in a bright green color. The sphere is now the
selected object and the cube is no longer selected. In Maya, when
the object displays like this, we refer to it as being selected or active.

Selected Deselected

Selection of objects and components is a way of indicating to
Maya that this particular item is to be affected by the tool or
action you will subsequently choose. As you work with Maya,
you will be selecting and deselecting items a lot. You will learn
how to select and deselect objects later in this chapter.
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Some numerical information appears in the Channel Box editor on
the right hand side of the user interface. This information relates
to X, Y, and Z, translation, rotation, and scaling for the active
object. The X, Y, and Z Translate numerical values are currently
set to 0. This indicates that the sphere’s location is at the origin.
The Channel Box is useful for viewing and editing this type of
basic information. You will use the Channel Box later in this
chapter.
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To hide or show the Channel Box

1 To hide the Channel Box, click the Show/Hide Channel Box
icon from the right end of the Status line.

The Channel Box disappears, and the perspective scene view
expands slightly. With the Channel Box hidden, you have
more working area in your scene view.

Show/Hide
Channel Box

I Show or hide the Channel Layer Editor

b & =

sed Focus  Attributes  Help
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2 To show the Channel Box, click the Show /Hide Channel Box
icon on the Status line. The Channel Box appears in the scene
view.

Save your work

Make it a habit to save your work often when working on your
Maya projects. In that way, you can always open an earlier
version of your work should you make a mistake.

Maya refers to everything you've created in your workspace as
the scene. This includes any objects, lights, cameras and materials
associated with your working session.

To save your Maya scene

1 Select File > Save Scene.

A file browser appears, listing the default directory where you
can save your scene.

Type: Lessonl in the file name text box.
Click Save.

Maya saves your file to the scene directory within your Maya
default project directory. Maya automatically saves the file
with a .mb file extension. The .mb file extension indicates that
the scene was saved as a Maya binary file: the default file type
for a Maya scene.

Exit Maya
Before you exit Maya, ensure you save any work that you want to
retrieve and continue with at a later time.

To exit Maya

1 Select File > Exit from the main menu.

Maya does one of the two following actions:
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If you have saved your scene immediately preceding the Exit
command, Maya exits.

If you have not recently saved your scene, a message prompt
appears on the screen asking if you want to save your
changes. Click either Yes, No, or Cancel.

WARNING: Scene not saved.

Save changes to untitled scene?

( Yes ) ( No } {_ Cancel )

Beyond the lesson

In this lesson you began your orientation to Maya by learning:

How to start Maya on your computer.

The Maya workspace, and how it shows three dimensional
space (X, Y, Z).

How Maya color-codes items and tools related to X, Y, Z.

The location of the main menus for the various modules
within Maya.

How to create a three-dimensional object from the Modeling
menu.

The location of the Status Line and how items are displayed
as icons.

About the Shelf how to create a three dimensional object from
the Shelf.

How to hide and show the Channel Box and that basic
transformation, scaling, and rotational information for an
object can viewed in the Channel Box.

How to save your work.

How to exit Maya.
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As you proceed through Getting Started with Maya you should be
familiar with the fundamental concepts and skills covered in this
first chapter.

If you want to learn more about a particular tool or feature that
has been presented in this lesson, refer to the Maya Help.
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Lesson 2 Creating, manipulating, and
viewing objects

Using primitive objects to model 3D forms is a great place to
continue learning about Maya. You can create many types of 3D
objects using Maya and then move, scale, and rotate them to
create more complex forms in your scene.

In this lesson, you begin to construct a classic temple using the
primitive object creation tools in Maya. The project is not very
complex and provides you with experience in using some of the
important object manipulation and viewing tools.

As you continue to work with Maya, you'll learn how to visualize
more complex forms using these basic objects. Maya has many
advanced tools and options for modeling complex forms, as you
will learn in later chapters.

In this lesson, you learn how to:

*  Create 3D primitive objects.

e Select objects for manipulation and editing purposes.
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Move and rotate objects using your mouse.
Move, rotate, and scale objects using numeric input.
Duplicate objects.

Change the viewing panels in Maya using a variety of
methods so you can view your objects from different points of
view.

Undo actions when you need to undo a particular task or
step.

Creating a new scene

You begin your temple project by creating a new empty scene.

To create a new scene

1

Start Maya (if it is not already running).

When Maya starts, it automatically creates a new scene.
If Maya was previously running, follow steps 2 and 3.
From the main menu, select File > New Scene.

Maya displays the following prompt.

WARNING: Scene not saved.

Save changes to untitled scene?

( Yes ) Cancel

Click No.

Maya creates a new scene and delete everything that was in
the previous scene.

Primitive Objects

Maya provides many types of primitive types and shapes such
cubes, spheres, cylinders, and planes.
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@D
Primitive objects can be used as a starting point for a wide variety

of shapes and forms. The most common workflow when using
primitive objects is:

*  Set the construction options for the primitive when you
initially create it so that it appears in the Maya scene roughly
in the size and shape that you require.

*  Move, scale, and rotate the primitive object into its final
position either by direct manipulation (the move, scale, and
rotate tools), or by entering numeric values through an editor.

*  Duplicate the primitive objects to create multiple copies of the
original or create different variations from your original
primitive object.

In this section, you construct the base for the temple using a
polygonal cylinder primitive. The octagonal shape is created by
modifying the creation options for the cylinder tool before you
create the object. If you did not modify the cylinder options you
would create a round cylinder.

To create a polygonal cylinder for the base

1 Select the Modeling menu set.

Note Unless otherwise indicated, the directions in this lesson
for making menu selections assume you’ve already
selected the Modeling menu set.

2 From the main menu, select Create > Polygon Primitives >
Cylinder > 3.
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An option window appears.

In the Polygon Cylinder Options window, select Edit > Reset

settings and then set the following options:

3

Radius: 10

Height: 1

Subdivisions Around Axis: 8

Subdivisions Along Height: 1

Subdivisions on Caps: 1

Axis: Y
In the Polygon Cylinder Options window, click Create.

4

Maya creates a cylinder primitive object that is octagonal in

shape and positioned at the center of the Maya workspace.

This cylinder is 20 units wide by one unit high, and has eight

faceted sides.
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Note You were instructed to reset the option settings as a
precaution in case they had been set differently. This is a
good habit to practice when working with tool options
to avoid getting a result that was different from what
you expected.

The Toolbox: Layout shortcuts

The Tool Box is located on the left hand side of the Maya user
interface. It contains icons that open tools for transforming your
objects within Maya (selection, move, rotate, scale) as well as
layout shortcuts for changing the views and panel layouts.

The Quick Layout buttons shortcuts allow you to select a different
panel or switch to another layout.

Layout Shortcuts

ool ]
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F-|
[

T
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4

You need to finish positioning the cylinder. To do this you need to
see the object from a side view to make sure it is sitting exactly on
the ground plane.
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To change the panel layout to view the base from a
side view

1 From the Toolbox, click the Four View layout shortcut.

Four View Shortcut

The workspace changes to a four-view layout. The perspective
view is located in the top right corner and the other views
show the object from the top, front and side. The layout
shortcuts have other options that you will learn later in this

tutorial.
View Shading Lighting Show Panels View Shading Lighting Show Panels
<>
;_x z4hy
—
Wiew Shading Lighting Show Panels Wiew Shading Lighting Show Panels
| P e P | [ I I I 1
r S 4 zx
front side
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It is now possible to see the base from the side view, but it
would be easier to determine the position of the base if the
side view were enlarged to a full view.

2 To enlarge the side view, position the mouse cursor in the side
view, and tap the spacebar of your keyboard.

The workspace changes to a single view layout with the side
view in an enlarged view. It is easier to view the position of
the base from this side view. Notice that the base lies slightly
above and below the ground plane (X, Z).

Tip You can position your mouse cursor in any modeling
view and click the spacebar once to toggle the view. If
the view is a full panel view, it will change to a four
panel view and vice versa.

The Tool Box: Transformation tools

You need to move the base slightly upwards in the Y direction so
it is positioned on the X, Z plane. To do this you use the Move
transformation tool located in the Tool Box.

The upper half of the Tool Box contains the tools for transforming
objects (selection, move, rotate, scale) within Maya. When you
move your mouse cursor over any transformation tool icon you
see the name of the tool appear next to the mouse cursor.
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Toolbox
Transformation
Tools

—— Move
—— Rotate

—— Scale

The tool’s name also appears in the Help Line at the bottom of the
Maya window. The Help Line has an additional purpose: it
displays summary instructions as you use tools that require

several steps.

vI Move Tool: Use manipulator to move object(s). Use edit mode to change pivot (IMSERT). Chil+LME to move perpendicular.

Selection and de-selection of objects

Before you can transform an object, you must ensure it is
selected. You can select objects by clicking them directly, or by
dragging a rectangular bounding box around some portion of
the object to indicate what you want selected. To deselect an
object, you simply click somewhere off of the selected object.

Click on wireframe object to select

Bounding box selection
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To select the base primitive object in the scene view
Do one of the following:

*  With your left mouse button, click the object’s wireframe
outline in the scene view.

*  With your left mouse button, drag a bounding box around
one corner or edge of the object’s wireframe.

The object is selected when its wireframe outline color
displays in a bright green color. If it is not selected, its display
color is navy blue.

To use the Move Tool to adjust the position of the
base

1 Select the Move Tool from the Toolbox.

A move manipulator icon appears over the primitive cylinder
in the scene view.

The Move Tool Manipulator has handles that point in the
direction of the three fundamental axis directions of 3D space:
X, Y, Z. The handles are colored red, green, and blue based on
their function related to the X, Y, Z axes and control the
direction of the movement along an axis.

When you click a specific handle, it indicates that the move is
constrained to that particular axis direction.

2 In the side view, drag the green Y manipulator handle to
move the primitive cylinder upwards in the Y direction. Move
it upwards enough so that the bottom of the base cylinder is
aligned with the X axis (the thick dark line of the grid)

N
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The base cylinder now needs to be rotated slightly so the front of
the base is parallel to a grid line. Since each facet of the octagon
represents 45 degrees of a circle, you need to rotate the object
approximately half of that amount or 22.5 degrees.

To use the Rotate Tool to adjust the position of the
base

1

Display all four views by positioning the mouse cursor in the
view and tapping the spacebar of your keyboard.

The four view panel appears.

Position the mouse cursor in the top view and tap the
spacebar once.

The top view appears in the workspace.

With the base cylinder selected, choose the Rotate tool from
the Tool Box.

A rotate manipulator icon appears over the primitive cylinder
in the scene view.

Rotate
manipulator

e
3 2

The Rotate Tool Manipulator consists of three rings (handles),
plus a virtual sphere enclosed by the rings. The colors of the
handles correspond to the X, Y, and Z axes. The handles are
colored red, green, and blue based on their function related to
the X, Y, Z axes and control the direction of the rotation
around an axis.
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4 In the top view, drag the green Y manipulator ring to rotate
the primitive cylinder so that one of the facets of the base
cylinder is aligned with the grid as shown in the image below.

You are rotating the cylinder around its Y axis.

You may be asking yourself the question “How do I know if I've
rotated the base exactly 22.5 degrees?” You can check the accuracy
of the rotation by viewing the Channel Box. Rotate Y should be
close to 22.5 degrees.

Tip You can undo and redo the last action you performed.
Undo reverses the last action you performed on a
selected object. It also reverses any action you
performed from the Edit Menu.

To undo an action select, Edit > Undo. Maya allows you
to perform multiple undos.

The Channel Box

The Channel Box is an editing panel that provides you access to
an object’s transformation information and much more. It
provides information on three distinct areas for any type of object:
The transform node, shape node, and input node.

Nodes are where information about object types are kept track of
within Maya. Nodes are comprised of attributes. Attributes refer to
information related to what the node is designed to accomplish. In
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this case, information about the primitive cylinder’s Y axis
rotation is referred to as the Rotate Y attribute. You will learn more
about nodes later in this tutorial.

When you moved and rotated the cylinder primitive using the
Move Tool, you were doing this by your own visual judgement.
This will usually be sufficient for many of your creative
applications.

If you need to control the attribute of an object with more
accuracy you can do this by entering the precise values into the
appropriate attribute field of the Channel Box.

To move and rotate the base using the Channel Box

1 With the base cylinder selected, view the Transformation
attributes in the Channel Box. Specifically, view the values for
Translate Y, and Rotate Y.

EEE 4“0 7
Channels  Object
pCylinderl
Translate X o
Translate Y 0.5 L Translate Y
Translate Z o
Rotate X o
Rotate Y 225 — Rotate Y
Rotate Z o
Scale X 1
Scale Y 1
Scale Z 1
Visibility on

2 In the Channel Box, adjust the attribute values so they match
the above image by clicking in the field and entering the
correct numerical values.

This accurately positions the base in your Maya scene.

Maya named the cylinder primitive when it was first created.
Rename the cylinder to something more meaningful to your
project.
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To rename the cylinder primitive using the Channel

Box

1 In the Channel Box, click in the field with the name

pCylinderl.

2 Rename the primitive object by typing the new name:
templeBase and then pressing Enter.

= 5= [

‘ pCylinderl

Translate ¥
Translate Z
Rotate X
Rotate Y
Rotate Z

N S

Object

= = [ZF

Channels

N S

Object

templeBase
Translate X
Translate ¥
Translate Z
Rotate X
Rotate Y
Rotate Z

Duplicating objects

Duplicating an existing object is a useful way to make an exact
copy of it without having to start over. When you duplicate an
item the copy takes on the characteristics of the original. Using the
Duplicate Tool you can additionally apply transformations to the
copy (move, rotate, scale).

Return to a four view layout to view what you’ve accomplished to
this point.

To change the panel layout to a four view layout

*  From the Toolbox, click the Four View layout shortcut.

The workspace changes to a four view layout. It is easier to
view the work from this four view layout.

The base for the temple is constructed of two levels and
appears stepped. You duplicate and scale the templeBase
object using the duplicate tool.
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To duplicate the temple base

1

Display all four views by positioning the mouse cursor in the
view and tapping the spacebar. Then click in the perspective
view to display the base in this view.

With templeBase selected, choose Edit > Duplicate > O from
the main menu.

The Duplicate Options window appears.

In the Duplicate Options window, select Edit > Reset settings
and then set the following options:

*  Translate: 0.00 1.00 0.00

*  Rotate: 0.00 0.00 0.00

*  Scale: 0.90 1.00 0.90

*  Geometry Type: Copy

*  Group under: Parent

In the Duplicate Options window, click Duplicate.

Maya creates a duplicate of the templeBase object that is
scaled to 0.9 of the original in the X, Z axes, and is one unit
above templeBase. As a result of the scale operation, the base
for the temple now appears stepped.

Maya keeps track of the name of the duplicated object based
on the name of original and renames the duplicated object
templeBasel.

persp
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Creating a project

A project is a file directory that stores and organizes all of the files
(scenes, images, materials, textures, etc.) related to a particular
scene. In Maya, you create and work with a variety of file types
and formats. The project directory allows you to keep these
different file types in their unique subdirectory locations within
the project directory.

To create a project

1 From the main menu, select File > Project > New.
The New Project window opens.

2 Enter the name MayaBasics for the new project in the Name
text box, and then click Use Defaults.

Clicking Use Defaults will assign a default directory and
name to the various subdirectories associated with the project.

3 Click Accept to create the new project with subdirectories.

When you next save your work for this lesson it will
automatically default to the MayaBasics project directory.

Save your work

In the last lesson we recommended that you save your work at
regular intervals. An example of this is when you have just
completed a major task such as constructing the base for the
temple. With this strategy, if you ever make a mistake, you can
always open the previously saved version of your work and begin
from there.
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To save your Maya scene

1

Select File > Save Scene.

A file browser appears showing the default project scene
directory where you can save your scene.

Type Lesson2Base in the file name text box.
Click Save.

Beyond the lesson

In this lesson you continued with the fundamental tools and skills
to successfully learn:

An overall workflow for constructing forms using primitive
objects.

Where the primitive object tools are located in the main menu.

How to create a primitive object as well as reset and edit its
creation options.

How to change between a single view and four view panel
layout using layout shortcuts and by tapping the spacebar of
your keyboard.

How to select objects by clicking them with your mouse.

How to move and rotate objects using the transformation
tools in the Tool Box.

That tool manipulators can constrain a transformation to the
X, Y, or Z axes.

How to edit an object’s transformation node attributes (move,
rotate, scale) accurately using the Channel Box.

How to rename objects using the Channel Box.

How to duplicate objects and apply transformations while
doing so.

How to create a project directory.
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We suggest you additionally practice the following tasks on your
own:
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Creating other primitive object types, with various options so
that you can understand the variations that are possible.

Practice moving, rotating, and scaling objects, and changing
between the various scene views (single perspective, four
view, single side, single top etc.)
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Lesson 3 Viewing the Maya 3D scene

In the previous lesson you learned how to view your 3D scene by
changing between single and four view layouts. It is important for
you to learn how to change your views in a more interactive
manner so that you can: view your objects close up or far away,
select objects more accurately, or view objects from different
angles in your perspective view.

In this lesson you learn how to:

*  Understand the difference between moving objects in the
scene and moving the point of view on the scene.

*  Use the dolly, track, and tumble camera tools to change the
view of your scene in both the orthographic and perspective
views.

* Rotate objects using the transformation tools in the Tool Box.
*  Select objects using a variety of techniques.

*  Group objects together so they can be transformed as a unit.
* Display objects in both wireframe and shaded modes.

*  Use additional primitive objects and options.
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Camera Tools

In the lessons so far, when you looked at an object from the top,
front, or side views you have been viewing the scene through an
orthographic view. Orthographic views appear two-dimensional
because the object is displayed using parallel projections of only
two axes at a time. (Scooter images courtesy of The Art of Maya)

Front orthographic view Side orthographic view

When you view the scene through the perspective view, you are
viewing the scene in a three-dimensional manner. The perspective
view simulates what your scene would look like from a camera’s
point of view.

Perspective View
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In Maya, you view the scene through a set of virtual cameras.
These cameras are either orthographic or perspective in nature.
You can adjust how these cameras view the scene using the
Camera Tools.

The three primary methods for manipulating the camera view are
dolly, tumble, and track.

Dolly Tool

The Dolly Tool gets its name from filmmaking where a camera,
mounted on a wheeled tripod, is moved towards or away from
the scene. In Maya, dollying allows you to view the items in your
scene either close up or from further back.

2 o

To dolly the perspective view

1 Enlarge the scene view to a single perspective view.
2 Do one of the following;:

*  (Windows) Press the Alt key and drag the mouse to the
right while holding down the right button on your mouse.

*  (Mac OS X) Press the Option key and drag the mouse to
the right while holding down the right button on your
mouse.

*  (IRIX & Linux) Press the Alt key and drag the mouse to
the right while holding down the left and middle buttons
on your mouse.
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Alt
3 pﬁq
option

Windows & Macintosh

e =
4'__ -—_-—~>\ Lo
B |
Dollying the view Alt )

IRIX & Linux

3 To dolly the camera outwards from the subject in the scene
you can perform the same key and mouse combinations as
described above but drag the mouse to the left.

Dolly works in both the perspective and orthographic views.

Tip If you make an error when adjusting your camera view
of the scene, you can reset the camera to its default
home setting.

To reset the camera view for a particular orthographic
or perspective view:

From the panel menu, select View > Default Home.

Tumble Tool

The Tumble Tool allows you to tumble or rotate the camera’s
view around a particular center of interest to achieve either a
higher or lower vantage point, or a different side angle.
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To tumble the perspective view

*  Press the Alt key (Windows, IRIX, & Linux) or the Option key
(Mac OS X) and drag the mouse either left or right, or up or
down, while holding down the left button on your mouse.

Tumbling the view revolves the camera around the center of
the scene view, in whichever direction you drag (left, right, up
or down). The Tumble Tool does not work in the orthographic
views.

Tumbling the view

Track Tool

The Track Tool allows you to move the camera up, down, or
sideways in relation to the scene.
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To track the perspective view

*  Press the Alt key (Windows, IRIX, & Linux) or the Option key
(Mac OS X) and drag the mouse in any direction, while
holding down the middle button on your mouse.

The Tracking Tool works for both orthographic and
perspective views.

Tracking the view

Note Even though the objects appear to move across the
screen when operating any of the camera tools, it is the
viewing camera that is actually moved in relation to the
scene, not the objects.
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Workflow overview

The columns are made up of multiple primitives that are moved,

scaled, and rotated into position. Once the first column is created,
with each component named and accurately positioned, you will

group and duplicate it to create others.

Capital (Cube)

Shaft (Cylinder)

Base (Sphere)

Pedestal (Cube)

To create a polygonal cube for the pedestal

1

From the Main Menu, select Create > Polygon Primitives >
Cube > 0.

In the Polygon Cube Options window, select Edit > Reset
settings and then set the following options:

*  Width: 1.75
* Height: 0.6
*  Depth: 1.75

Leave the other options at their default settings.
In the Polygon Cube Options window, click Create.
Maya creates a cube primitive and positions it at the origin.

In the side view, move the cube upwards (Y axis) so it rests on
the top surface of the temple base.

Getting Started with Maya
73



2 | Maya Basics

Lesson 3 > Workflow overview

5

You can do this using the Move Tool or with the Channel Box.
If you use the Channel Box, enter a Translate Y value of 2.3.

You may find it useful to dolly or tumble the scene view to
obtain a better viewpoint.

In the Channel Box, rename the cube columnPedestal.

To create a polygonal cylinder for the shaft

1
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From the main menu, select Create > Polygon Primitives >
Cylinder > 3.

In the Polygon Cylinder Options window, select Edit > Reset
settings and then set the following options:

* Radius: 0.5

* Height: 6

* Subdivisions Around Axis: 12

Leave the other options at their default settings

In the Polygon Cylinder Options window, click Create.
Maya creates the cylinder primitive at the origin.

In side view, move the cylinder upwards (Y axis) so it rests on
the top surface of columnPedestal.

You can do this using the Move Tool or with the Channel Box.
If you use the Channel Box, enter a Translate Y value of 5.6.
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5 In the Channel Box, rename the cube columnShaft.

The capital for the column rests on top of the column and is very
similar to the pedestal. You duplicate the pedestal and position
the duplicate at the top of the column.

To duplicate the pedestal to create the capital

1 With only columnPedestal selected, select Edit > Duplicate > O
from the main menu.

The Duplicate Options window appears.

2 In the Duplicate Options window, select Edit > Reset settings
and then set the following options:

* Translate:06.6 0
e Scale:0.81.00.8
Leave the other options at their default settings.

3 In the Duplicate Options window, click Duplicate.
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Maya creates a duplicate of the columnPedestal object and
moves and scales it based on the options you set.

Note If you positioned the geometry for the column using the
Transform Tools and your mouse, the Y translate values
may be incorrect for your particular model. You may
want to continue positioning the objects by visual
reference using your mouse.

Using the duplicate options is an alternate method for
positioning and scaling duplicated objects when you can
anticipate its final location.

Capital

4 In the Channel Box, rename the duplicated cube
columnCapital.

The base for the column rests on top of the pedestal. You will
create the base using one half of a NURBS sphere primitive and
then move and rotate it into position. You will do this by
modifying the creation options for the sphere primitive.

To create a NURBS sphere for the column base

1 Select Create > NURBS Primitives > Sphere > 0.

2 In the NURBS Sphere Options window, select Edit > Reset
settings and then set the following options:
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*  Start Sweep Angle: 0

* End Sweep Angle: 180

* Radius: 0.75

*  Number of Sections: 8

*  Number of Spans: 4

Leave the other options at their default settings.

In the NURBS Sphere Options window, click Create.

Maya creates a half-sphere primitive at the origin.

To rotate and position the sphere on the pedestal

The sphere needs to be rotated 90 degrees and then positioned on
top of the pedestal.

1

In side view, rotate the sphere so that the dome part is
pointing up.
This is accomplished by either of the following methods:

* Rotating the sphere about the X axis using the Rotate
Tool’s manipulator handle.

*  Using the Channel Box to change the Rotate X value to
-90.

Move the sphere so it rests on the top surface of
columnPedestal (Translate Y = 2.6, if you have been inputting
values into the Channel Box).

Using the Scale Tool, scale the sphere along its Z axis (blue
manipulator handle) so that the sphere becomes slightly
squashed in appearance.
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v

|

When you scale an object non-uniformly along one of its axes,
you are scaling it non-proportionally.

front front

4 In the Channel Box, rename the sphere columnBase.

Viewing objects in shaded mode

Up to this point, you have been viewing your objects in the
default wireframe mode. In wireframe mode, objects appear
transparent except for the simple wire outline that indicates their
position and general shape. Maya provides several options for
displaying objects in a shaded manner.
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Change the display of your scene so that the objects display as
shaded objects.

To display the objects in smooth shaded mode

1 Enlarge your perspective view, and dolly and tumble the
scene so you can easily view what you’ve completed so far.

2 From the panel menu, select Shading > Smooth Shade All.

The objects in your scene display in an opaque dark gray
color. You can work with objects in either shaded or
unshaded mode for the balance of this lesson.

Grouping objects

When you need to move, scale or rotate multiple objects as one
unit it is easier if they have been grouped together so that they
transform as one unit.

Many of primitive objects in Maya are grouped objects. For
example, the NURBS cube primitive is comprised of 6 flat squares
or planes that have been grouped together as one unit. When the
plane objects are grouped together they create a hierarchy.

Getting Started with Maya
79



2 | Maya Basics

Lesson 3 > The Hypergraph

A hierarchy is a collection of nodes or objects that are connected
together to form a unit for some purpose. Hierarchies are useful
for describing how the objects within them share similar
characteristics or attributes; move, scale, rotate for example.

To group the objects for the column

1 Select the four objects that comprise the column
simultaneously by doing one of the following:

*  With your left mouse button, shift-click each object in
turn until the four objects are selected in the scene view.

*  With your left mouse button, drag one large bounding
box around the column objects in an orthographic view.

It is important that you do not select any of the templeBase
objects as part of your selection. If you accidentally select any
of the base objects, deselect them.

From the main menu, select Edit > Group > 0.

3 In the Group Options window, select Edit > Reset settings and
then set the following options:

*  Group Under: Parent
Leave the other options at their default settings
4 In the Group Options window, click Group.

Maya groups the objects together in a hierarchy. You will learn
more about hierarchies in the steps that follow.

The Hypergraph

The Hypergraph is a window that shows how the nodes and their
connections are organized in your scene. You view object
hierarchies and dependencies in the Hypergraph. Use the
Hypergraph to view what happens when you group an object.
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To view the Hypergraph

1 From the view menu, select Panels > Layouts > Two Panes
Stacked.

The scene view splits into two viewing panels - each has their
own separate view menu. You will set these to view the scene
in the upper view and the Hypergraph in the other.

2 From the lower pane menu, select Panels > Panel >
Hypergraph.
The Hypergraph panel will display below the scene view
panel.

3 At the top of the Hypergraph panel, select the Scene
Hierarchy icon.

Edit Yiew Bookmarks Graph Rendering ©Options Show P ...

] EEEER|%:

~w

4 In the Hypergraph panel, select View > Frame AlL

The Hypergraph displays the hierarchy for all of the objects in
the scene. This approach to viewing the entities in the scene
provides a very graphical approach to viewing all of the
various nodes in your scene.

2 templeBasze % templeBase1 {7 groupl
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In the Hypergraph, each node is represented as a rectangle
labelled with an icon that denotes the type of information it
represents (for example, surface, shading, and so on). Each
node has a unique name assigned to it when it is first created.
When you rename your objects, you are actually renaming the
node associated with that object.

Some nodes display with a line connecting them. This denotes
that they are in a hierarchy and have a dependency structure
based on how they were originally grouped.

For the temple’s column objects, the hierarchy displays each
of the named objects under a node labelled groupl. Groupl is
the parent node for this hierarchy of objects.

In Maya, when the parent node (sometimes referred to as the
root node) is moved, rotated, or scaled in any way, the child
nodes (sometimes referred to as the leaf nodes) underneath

are also affected.

When you select objects at the top level of a hierarchy and
move them, the objects within the hierarchy or group follow.

Note This system of nodes, attributes, and hierarchies may

initially appear somewhat complex, but it is one of the
most powerful features of Maya. The node based
architecture provides flexibility and power to create
complex models, shaders, and animations.

To rename the parent node in the Hypergraph

1
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In the Hypergraph, click on the groupl node so it becomes
active.

In the scene view, all of the objects in the column group
become selected as a result of selecting the group at the top
(parent) level of the hierarchy.
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In the Hypergraph, right-click the top node representing
groupl and select Rename from the pop-up menu.

A small text box appears in the node.

Enter column as the new name.

Now that the column is grouped, you need to position it at one
corner of the temple base.

To
1

position the column on the temple base

Change the display of objects to wireframe mode by tapping
the 4 key on your keyboard.

This is a keyboard shortcut. Instead of selecting the item from
the menu you can use a single key to implement the
command.

Tip

Many of the tools and features in Maya can be accessed
using keyboard shortcuts. In Maya, these shortcuts are
called Hotkeys. Some Hotkeys are displayed directly
beside the menu item, others are listed in the Hotkey
editor. For a complete listing of available hotkeys, go to
Window > Settings/Preferences > Hotkeys.

In the Hypergraph, select the Column at the top node so that
Column becomes active in the scene view.

In the scene view, use the Move Tool to position Column at the
front corner of the temple base as shown below.
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Column positioned
at corner of base

top

With your first column in position, you can now create a copy of
the column and position it on the adjacent corner of the base.

To create a duplicate copy of the column

1

With Column still selected in the Hypergraph, select Edit >
Duplicate > O from the main menu.

The Duplicate Options window appears.

In the Duplicate Options window, select Edit > Reset settings
and then set the following options:

*  Number of Copies: 1
Leave the other options at their default settings.
In the Duplicate Options window, click Duplicate.

The Hypergraph view updates to show an additional column
object in the scene. The copy also takes on the prefix name of
the original group and is now labelled Column1.

In the scene view it appears that nothing was actually
duplicated. When an object is duplicated without any
transformations the copy is positioned in the same position as
the original. The two objects are on top of each other.

You need to move the column into position on the adjacent corner
of the temple base.
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To move the duplicate column into position on the
base

1 In the Hypergraph, ensure Columnl is selected by clicking on
its top node so it becomes selected in the scene view.

2 In the scene view, use the Move Tool to position Columnl on
the adjacent corner of the temple base as shown below.

Two columns in
position

top

3 From the Toolbox, click the Four View layout shortcut.

The workspace changes to a four view layout and the
Hypergraph is no longer displayed.

Selection Modes and Masks

It isn’t always efficient to have the Hypergraph window open
when you want to select an object at a particular level within its
hierarchy. Maya allows you to select items in different selection
modes depending upon your specific needs.

There are three main types of selection modes: Hierarchy, Object
and Component. You use these modes in order to mask or limit
the selection of other objects in order to select only the types of
items you want. When you use a selection mask you are filtering
out or masking items you don’t want to be chosen as part of the
selection.

The icons for the three modes appear on the Status Line.
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Hierarchy Object Component Masks
File Edit Modify Create Disphay

el 1Y OOD)

General | Curves Sufaces I Falygon:

When you first start Maya, the default selection mode is set to
Objects. This is useful for much of your selection work with Maya,
with a few exceptions. When you want to select items that have
been grouped, set the selection mode to Hierarchy.

Tip

If you set the selection mask, it will remain that way
until you change it again. If an item won't select for you
in Maya, you should check the selection mask setting to
see if it is set correctly.

To
1
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use the Hierarchy selection mask

On the Status Line, choose the Select by Hierarchy and
Combinations icon

The Selection Mask icons update to display the three selection
choices.

On the Status Line, choose the Select by hierarchy icon.

Hierarchy and Combinations Select by hierarchy

it FIURES  Polygon

Zaly nsI Subdivsl Deformationl Animationl Dynamics|

Select by hierarchy ensures that when you select items they
are selected at their parent or root node.

In the scene view, shift-click Column and Column1 so they are
selected simultaneously. (Do not be concerned that they
highlight in different colors.)
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Pivot points

A pivot point is a specific position in 3D space that is used as a
reference for the transformations of objects. All objects (curves,
surfaces, groups) have pivot points.

When you group objects in Maya, a new node called a parent node
is created for the group of objects. The pivot point for the group’s
parent node is placed at the origin (0, 0, 0). This is useful if you
later want to duplicate and rotate the objects radially (that is, in a
circular fashion around the pivot).

To group the two columns

1 Ensure Column and Column1 are selected.
2 From the main menu, select Edit > Group > 0.

3 In the Group Options window, select Edit > Reset settings. Set
the following options:

*  Group Under: Parent
4 In the Group Options window, click Group.

Maya groups the objects together in a hierarchy and the pivot
point is positioned at the origin. (When the pivot point is
relocated to the origin the Move Tool manipulator for the
selected group appears at the origin)

With the two columns grouped, you then duplicate the columns
with a rotation option, the groups will duplicate and rotate
around the pivot point at the origin (0, 0, 0).

To duplicate and rotate the group

1 With column group selected, select Edit > Duplicate > O from
the main menu.
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In the Duplicate Options window, select Edit > Reset settings
and then set the following options:

*  Rotate: 0.000 90.000 0.000
*  Number of Copies: 3
In the Duplicate Options window, click Duplicate.

The columns are duplicated and rotated by 90 degrees with
each copy.

Each column group
is duplicated and
copied 90 degrees

Save your work

Your temple is taking shape! Save your work before proceeding to
the next lesson.

To save your Maya scene

1
2
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To save your Maya scene, select File > Save Scene As.

Type Lesson3Columns in the file browser area reserved for
file names.

Click Save.
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Beyond the lesson

In this lesson, you explored additional tools and skills within
Maya as you continued with the construction of the classic
temple. In this lesson you learned how to:

Use your mouse to change the view of your scene using the
dolly, track, and tumble camera tools in both the orthographic
and perspective views.

Rotate objects using the transformation tools in the Tool Box
and the Channel Box.

Group objects so they can be transformed as a unit.
Display objects in both wire frame and shaded modes.

Access the Hypergraph to view nodes and hierarchies. You
are also learning that many tasks in Maya can be completed or
approached using multiple techniques.

Rename nodes within the Hypergraph.
Select objects in your scene using the Hypergraph.

Use the group pivot point to your advantage when
duplicating objects.

Before proceeding with the next lesson you may want to review
the material presented in this lesson so you are familiar with the
concepts and skills associated with them. Some suggested tasks

you can try on your own include:

Practice using the view camera tools (dolly, track, and tumble)
so you can navigate within the scene views efficiently.

Practice moving and rotating objects, and changing between
the various scene views (single perspective, four view, single
side, single top, and so on).

View objects in the Hypergraph so you can understand their
relationships and hierarchy.
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Lesson 4

Components and Attributes

Working with components is an important part of the workflow
when working in Maya. Components describe objects at a more
detailed level. As you edit the components of your classic temple,
you will learn more about what is possible in Maya.

In this lesson you learn how to:

e Template objects in the scene.

*  Understand the difference between objects and components.
» Edit objects at their component level.

e Assign surface material attributes

e Access the Attribute editor

Template Display

When your scene becomes complex, templating the display of
some of the objects in your scene allows you to more easily select
only the objects you want. When you template the display of an
object, its wireframe changes to a gray color. The object(s) can still
be seen, but not easily selected. This helps to prevent you from
selecting or modifying it accidentally. You can change the display
of objects to a template and use them as a modeling reference (the
way a grid is used).

You need to change the display of the base and columns to
template mode so that you can more easily work on the temple
roof.

To template the base and columns

1 In the side view, with the Selection Mask set to Hierarchy,
select all the objects in your scene.

2 From the main menu, select Display > Object Display >
Template.
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The selected objects become templated.
ﬂ 'Mi
|

side

WEI

For your classic temple, you need to create the entablature using a
torus primitive. An entablature is a structure that lies horizontally
upon the columns of a temple and supports the roof.

To create and position a torus primitive for the

entablature
1 From the main menu, select Create > NURBS Primitives >
Torus > 3.
2 In the NURBS Torus Options window, select Edit > Reset
settings and then set the following options:
* Radius: 8.5
e Minor Radius: 0.5
e Number of Sections: 24
3 Inthe NURBS Torus option window, click Create.
In the Channel Box, rename the torus primitive Entablature.
5 Move the entablature vertically in the scene so it rests on top

of the columns (Translate Y =9.7).
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side

Components

All objects in Maya have a transform and a shape node. Geometric
shapes, like the primitives in this tutorial, have smaller parts
called components. A few examples of components in Maya are
control vertices, faces and hulls. Components allow you to work
with objects at a finer level and allow you to edit them in creative
ways.

In order to change the shape of the entablature beyond the basic
scale transformations, you need to modify its component
information.

To select components of the entablature
1 In the side view, dolly in for a closer view of Entablature.

2 GSet the Selection Mode to Components.

3 Right-click the wireframe of Entablature and select Control
Vertex from the pop-up menu.
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Surface Patch I

Surface Point I
nurbsTorusl...

The menu that pops up is a marking menu for quickly selecting

operations relevant to the object where you right-click the

mouse. In this case, the choices pertain to the display of the

entablature’s components.

Select

Inputs
Cutputs
Actions

v v v

Materials

A set of small blue squares appear on Entablature called
control vertices. Control Vertices (CVs) describe the shape of
an object based on their position in space. If you move any
combination of these vertices, you change the shape of the
object.

Drag a selection box around the top row of vertices so they
become selected.

Using the Move Tool, move the vertices up vertically as
shown below to change the shape of Entablature.

moved upwards

Control Vertices ?
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6

To cancel the display of the CVs, right-click the wireframe of
Entablature once again and select Object Mode from the pop-
up menu.

The roof for the temple rests on top of the entablature. The roof
for the temple is created using one half of a sphere primitive.

To create a roof for the temple

1
2

3

Select Create > NURBS Primitives > Sphere > .

In the NURBS Sphere Options window, select Edit > Reset
settings and then set the following options:

* Start Sweep Angle: 0

* End Sweep Angle: 180

* Radius: 8.75

*  Number of Sections: 8

*  Number of Spans: 4

In the NURBS Sphere Options window, click Create.
Rename the half-sphere templeRoof.

The roof needs to be rotated 90 degrees and positioned on top of
the entablature.

To rotate and position the roof on the entablature

1
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In side view, rotate the roof so that the dome part is pointing
up.

Move the roof so it is positioned close to the top edge of
Entablature.

Scale the roof along its Z axis (blue manipulator handle) so
that the sphere becomes slightly squashed in appearance.
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front

Now that the roof is complete, you can untemplate the templated
objects.

To untemplate objects

1

On the Status Line, choose the Select by Hierarchy and
Combinations button.

On the Status Line, choose the Select by hierarchy: template
button.

Hierarchy and Combinations Hierarchy:Template

Zaly nsI Subdivsl Deformtionl Anlmationl Dynamics

Hierarchy:Root

Select by hierarchy: template ensures that only templated
objects will be affected by a selection.

In the scene view, drag a selection box around all the objects
in the scene so that the templated objects are selected
simultaneously.

From the main menu, select Display > Object Display >
Untemplate.

On the Status Line, choose the Select by hierarchy: root
button.
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The Attribute Editor

The Attribute Editor provides information about the various
nodes and attributes for the objects and materials in your scene.
Like the Channel Box, you can view and edit the basic transform
information and many other keyable attributes. However, the
Attribute Editor provides a more detailed display of all attributes
for a selected object.

To view object attributes using the Attribute Editor

1 In the scene view, select templeRoof so it becomes the selected
object.
2 To view the Attribute Editor, click the Show /Hide icon on the
Status Line.
Show/Hide Attribute Editor
=10l x|
(e (B)EE
L |
The Attribute Editor displays the attributes for templeRoof.
The various attributes for the templeRoof object appear under
various tabs. Each tab represents a node.
List Selected Focus  Attributes  Help
'ternplekaof templeRoofShape makeNurbSphere2 _Display
[ arrow
Attribute ransform: pp———— ] Focus
tabs -4 . = Presets
¥ Transform Attributes
Translate ' g.goo 10.297 0.000
Rotate _gg.ooo 0.000 0.000
scale 1000 1.000 0510
Shear g.ooo 0.000 0.000
Ratate Order = D
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Click on the templeRoof tab to see its attributes.

This tab is known as the transform node, because the most
important attributes on this tab control templeRoof’s
transformation. Every visible object in Maya has a transform
node, including cameras and lights.

Click on the templeRoofShape tab to see its attributes.

This tab is called the shape node because the attributes
establish the object’s geometric shape or physical properties
when the object is first created. Most objects have shape
nodes, some do not, such as the group for the column objects.
The shape node also includes other types of attributes, such as
object display attributes.

Click on the makeNurbSphere tab to see its attributes.

This is an input node that includes attributes related to the
object’s construction history. The attributes of an input node
are passed to another node subsequent in the construction
history for the object—in this case, to the templeRoofShape
node.

The last two nodes are initialShadingGroup and lambert1. If
you can’t see them, click the display arrow.

The initialShadingGroup and lambert] nodes are default
nodes that relate to the default shading material for an object.
Maya uses them to establish the initial color of objects and
other settings related to shading. If you create your own
shading materials for the temple, as you will in the following
steps, these nodes are replaced by the new shading nodes you
create.
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Surface Materials

The color, shininess, and reflectivity attributes of an object are
controlled by its surface material (sometimes referred to as a
shader, or shading material). Material attributes relate to how the
object simulates a natural reaction to light in Maya’s 3D computer

world.

Maya assigns a default shading material to all objects when they
are first created. In this section, you learn how to assign a new

material to your objects.

To assign a new material to the temple objects

1 Right-click the wireframe of Entablature and select Object
Mode from the pop-up menu.

1

| Isoparm

I 1 I

L
11 {1 Obje
I

1
_l Control Vertex

:| Hull

Surface Patch

T
Surface Point

Entablature...

Select

Inputs
Outputs
Actions

vy vYwvwy

Materials

!

This changes the selection mask back to objects so you can
select objects in the scene. It is a shortcut to access this feature.

2 Drag a selection box around all the objects in your scene to

select them.

Tip If objects won't select in the Maya scene, check that your
selection mask is set correctly on the Status Line.
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From the Status Line, select the Rendering menu set using the
menu selector.

The main menu changes to display the menu set for
Rendering.

From the main menu, select Lighting/Shading > Assign New
Material > Blinn.

A Blinn shading material is assigned to all the objects in the
scene and the Attribute Editor updates. Blinn shading
materials (named after the inventor of this shading algorithm)
provide for high-quality specular highlights on surfaces.

In the Attribute Editor, rename the blinnl shading material to
templeShader.

With a shading material assigned to all the objects, you need to
edit the color attributes of the templeShader material.

To edit the shading material’'s attributes

1

In the Attribute Editor, click in the gray box to the right of the
word Color.

L Focus
blinn: ItempIeShaded LI _|
[ Fresets |
b aterial Sample .
Type I Blinn j -

LI Common M ategalbtisbubes
(o) -
Tranzparerey I ﬂ

The Color Chooser appears.

Getting Started with Maya
99



2 | Maya Basics
Lesson 4 > Surface Materials
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Click in color wheel |—i‘ (R W
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| 7 [Wheel

|~ |sliders
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Accept | Reset I Cancel |

2 C(lick inside the color wheel (hexagon) and drag the pointer to
achieve a sand color.

The exact color is unimportant for this lesson. As you adjust
the color wheel indicator, the temple objects become the same
color you select in the Chooser.

3 Click Accept to close the chooser.

You will learn more about Maya’s shading and texturing
capabilities in future lessons.
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In the Attribute Editor menu, choose the Selected menu item,
and select templeBase from the list.

Focus  Attributes  Help

templeBase
templeBasel

temr

The attributes for templeBase display in the Attribute Editor.
Click on the templeShader node tab to see its attributes.

If you can'’t see this tab, click the display arrow to the right of
the tabs.

These are the same attributes you edited when you assigned
the templeShader shader to all the objects in the scene. When
you first create an object, you see two default nodes for
shading, initialShadingGroup and lambertl. When you assign
a shading material, the two default nodes are replaced by the
attribute node for the assigned shading material.

You will encounter transform, shape, input, and shading
nodes throughout your work with Maya. There are other
types of nodes that you'll learn about as you continue
learning about Maya.

Close the Attribute Editor using the Show /Hide icon.

Save your work

You have completed this lesson. Save your work before
proceeding.

To save your Maya scene

1
2

Select File > Save Scene As.

Type Lesson4Final in the file browser area reserved for file
names, and then click Save.
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Beyond the lesson

In this lesson, you completed the construction of the classic
temple and learned how to:

Display objects in template mode.

Select objects at their component level using selection masks
and the right mouse button.

Assign and edit shading materials for your objects in the
scene.

Access the Attribute editor and view the various node types
for objects

As you proceed through Getting Started with Maya, we assume
you are familiar with the fundamental concepts and skills covered
in this first chapter.

Before proceeding to the next chapter you may want to review the
material presented in this lesson so you are familiar with the
concepts and skills associated with them. Some suggested tasks
you may want to do on your own:
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Practice construction of additional forms using primitive
shapes by creating. additional details for your temple scene
(stairs, roof details, etc.)

Learn more about the tools and options that have been
presented in this lesson, by referring to the Maya Help. To
view the Maya Help, select Help > Maya Help.



Polygonal
Modeling

In Maya, modeling refers to the process of creating virtual 3D
surfaces for the characters and objects in the Maya scene. Surfaces
play an important role in the overall Maya workflow as they are
the items upon which shading and texture attributes will be
assigned. It is these attributes that assist in the creation of a
convincing 3D image. The more accurate you are when modeling
your forms in terms of size, shape, detail, and proportion, the
more convincing your final scene will become.

There are three modeling surface types in Maya:

* Polygons

*  NURBS

e Subdivision surfaces.

Each surface type has particular characteristics and benefits, and

requires specific modeling techniques. Maya groups the surface
modeling tools in a menu set specific to modeling.
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Polygon surfaces are a surface type comprised of flat surfaces
called faces. You can create a single polygonal face or a network of
polygonal faces called a poly mesh. A poly mesh is comprised of
many faceted three-or-more flat sided polygon faces. When a poly
mesh is rendered, it is shaded smoothly so that the facets are not
as apparent in the final image.

Polygonal surfaces can be used to create virtually any type of
surface shape and are particularly useful when simple forms are
required. Polygonal surfaces have a wide range of applications
and are the preferred surface type for interactive games and web
development applications. Polygonal surfaces are described with
the smallest amount of data, and therefore, can be rendered more
quickly, delivering increased speed and interactive performance
to the end user.

Preparing for the lesson

To ensure the lesson works as described, do these steps before
beginning:

1 Select File > New Scene to create a new scene.

2 Make sure the Construction History icon (below the menu

bar) is on: . (If it is turned off, it has a large X across it.)

3 Select the Modeling menu set. Unless otherwise noted, the
directions in this chapter for making menu selections assume
you've already selected the Modeling menu set.

4 Make sure Display > Ul Elements > Help Line is turned on.
You will use the Help Line while modeling.

Getting Started with Maya
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Modeling a polygonal surface

In this lesson, you model a simple hammer, starting from a cube
primitive, using polygonal surface modeling techniques.

In this lesson you learn how to:

Differentiate the basic components of polygonal surfaces.

Use primitive objects as the basis for more complex polygonal
models.

Select the faces, edges, and vertices of polygonal meshes using
your right mouse button.

Extrude faces from an existing poly model to add detail.

Move and rotate extruded polygonal meshes using the
polygonal transformation manipulator.

Split vertices and subdivide polygonal faces.
Smooth polygons to make the model appear less faceted.

Use the grid magnet feature.

Creating a foundation shape from a primitive

You begin the lesson by creating and scaling a cube into the rough
shape of a hammer handle. You'll extrude a face of the handle to
create a small box shape that you will use as the foundation for
the head of the hammer.

To create a foundation shape

1

Select Create > Polygon Primitives > Cube > 0. In the options
window, select Edit > Reset Settings and click the Create
button.

With the pointer in the perspective view, press 5 (for
Shading > Smooth Shade All).

Scale the cube into the general shape of a hammer handle.
You'll enhance the shape later.
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Move the cube so that its bottom lies on the grid (see
illustration).

Right-click the cube and select Face from the marking menu.

Maya displays small squares at the centers of the faces. To
select a face, you select the small square.

Select the face center at the top of the cube. Whenever you
select a face, tumble the view in several directions to check
that you've selected only the desired face.

Select Edit Polygons > Extrude Face.

Maya creates a new face in the same position as the
previously selected one. The extrusion manipulator works like
a combined Move, Rotate, and Scale Tool, but it modifies the
new face rather than the whole object.
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8 Drag the blue arrow up a little to extrude the face (see the
following figure). The blue arrow turns yellow when selected.
The resulting extension to the surface will become the middle
section of the hammerhead between the claw end and the
pounding end.

9 Examine the parts of this manipulator, as shown in the
following illustration. It is called the Show Manipulator Tool
and appears for various operations throughout Maya.
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Move handle

L

Scale handle

If you cancel the selection of the face, the manipulator
disappears from the face. To display the manipulator again,
select the face, select Modify > Transformation Tools > Show
Manipulator Tool, then click the polyExtrudeFace# in the
Channel Box.

Splitting polygons

Now you'll split one of the faces of the extruded shape into two
parts. From these two parts, you'll create the claw end of the
hammerhead.

To split polygons and manipulate the foundation shape

1 Select Edit Polygons > Split Polygon Tool.

2 Click one of the top, narrow edges as shown.
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3 Middle-drag the point roughly to the edge’s midpoint. If you
are a perfectionist, examine the Help Line as you drag the
point. When you see Percentage: 50%, the point is at the
midpoint.

4 Click the bottom edge of the face and similarly drag the
pointer to its midpoint. Press Enter (Windows, IRIX, and
Linux) or Return (Mac OS X) to divide the face into two.

A single face split
into 2 faces

Right-click the cube and select Vertex from the marking menu.

6 Select the vertices at the top and bottom of the edge that
divides the two faces. (If the vertices are hard to see, press 4 to
select wireframe display mode.) Examine the object from
several camera views to make sure you haven’t accidentally
selected extra vertices.

Select and split
these vertices

7 Select Edit Polygons > Split Vertex. The reason for splitting
the vertices is explained later.

Getting Started with Maya
109



3 | Polygonal Modeling
Lesson 1 > Splitting polygons

10

1
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Shift-select the two split faces. (To display the face centers,
right-click the cube and select Face from the marking menu.)

Select Edit Polygons > Extrude Face > 0. In the options
window, open the Other Values section and enter 6 for
Divisions, then click the Extrude Face button. You may need
to scroll the option window to access the Divisions option.

A manipulator appears on one of the faces. Because two faces
were selected when you selected Extrude Face, the
manipulator controls the extrusion of both faces.

Drag the blue arrow outward to extrude the faces to a length
appropriate for a hammer claw.

When you extrude the faces, the length of the extruded
surface will have six subdivisions rather than the default
single subdivision. With the extra subdivisions, it will be
easier to modify the extrusion into a claw shape in a later step.

Drag the red scale manipulator (the small cube) inward to
narrow the blades, then drag the green scale manipulator up
to flatten the blades at their tips. (See the next figure.)

This creates the preliminary shape of the hammer’s claw.
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In a prior step, you split the vertices at the top and bottom of
the edge that divided the two faces. This created two
additional, overlapping vertices at each split vertex (a total of
six vertices). The extra vertices were necessary to create a gap
between the blades. Without the extra vertices, the two blades
would be a solid single blade.

If you had extruded each face individually to create the two
blades, you would not have needed to split the vertices to
create the gap. However, it would have been harder to make
the two blades exactly the same length, width, depth, and so
on.

When you extrude two or more faces at the same time, the
manipulators influence both identically. Symmetry is ensured.

Using the poly extrude manipulator

Now you'll enhance the curvature of the claw’s blades and split
the blades apart more. You will use the same extrude
manipulator. If the manipulator is not displayed because you
mistakenly cancelled the selection of the faces, select the extruded
faces of the claw, select Modify > Transformation Tools > Show
Manipulator Tool, and click polyExtrudeFace2 in the Channel
Box.
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To modify the claw’s shape using the manipulator

1

Click the large circle surrounding the manipulator to display
the rotate manipulators. Drag the red circular manipulator
down a bit to rotate the extrusion (see the following figure).

2
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Rotating the angle of extrusion will help you to shape the
claws downward in the next few steps.

Drag down the green and blue arrows a short distance to
begin shaping the claw downward.

R B O
“H@iﬂji
SR b
Right-click any part of the surface and select Vertex from the
marking menu. Each subdivision of the claw has a group of

vertices that separate it from the adjacent subdivision (see the
following figure). Move each of these groups down or up a
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small distance to make the claw arch downward. (Drag one
group of the vertices at a time.) You can shift-drag to
constrain the movement of the vertices to a straight line.

‘ ‘ Move these
; ' groups of vertices

i ’* Q to shape the claw

In the next steps, you'll extrude a face to create the pounding end
of the hammerhead.

To extrude the pounding head for the hammer

1 Select the back face of the polygonal hammerhead.

2 Select Edit Polygons > Extrude Face > 0. In the options
window, set Divisions to 1 and click the Extrude Face button.
Move the face outward a short distance.
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Also scale the extrusion inward along all three axes. To do
this, click any of the scale manipulators to display a general
scale manipulator at the center of the manipulator axes. Drag
the center manipulator left to shrink the overall scale. This
tapers the middle section of the pounding end of the head.

3 Select Edit Polygons > Extrude Face again and move the face
outward again. Scale the extrusion outward along all three
axes.

4  Select Edit Polygons > Extrude Face one more time and move
the face outward. Leave the scale the same as the last
extrusion.
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To create a depression at the top of the head

Now you'll extrude the top of the hammerhead inward and down
to create a pit or depression. Hammers often have such pits where
the handle is fastened to the head.

1 Select the face at the center top of the hammerhead.

2 GSelect Edit Polygons > Extrude Face and scale the extrusion
inward along all three axes.

3 Select Edit Polygons > Extrude Face and drag the extrusion
down. This creates the pit in the hammerhead.
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Subdividing polygon faces

A real hammer handle is narrower near the head than at the base.
In the next steps, you'll adjust the width of the handle. First, you
need to subdivide the faces of the handle to add extra vertices.

Currently the handle has only four vertices, one at each corner.
With vertices only at the corners, you can taper the ends of the
handle but not other regions. By creating extra vertices
throughout the handle, you can tune the shape wherever you
choose.

To subdivide the handle
1 Shift-select the faces of the handle, including the bottom face.

Dolly and tumble the view to see all the faces to select them.
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Select Edit Polygons > Subdivide > 0. In the options window,
enter 2 for Subdivision Levels, then click the Subdivide
button.

This divides the selected faces into multiple faces with
corresponding extra vertices. You can then make fine
alterations to the handle’s shape.

You could have subdivided the handle faces using the Split
Polygons Tool described earlier in the lesson. Subdivide is
easier to use because you merely select the face you wish to
subdivide. You don’t need to select exact positions on the
faces. The disadvantage is that you might end up with more
faces and vertices than you want to work with.

The advantage of the Split Polygons Tool is that you create
only the number of faces and vertices you want, which makes
the surface simpler to edit and faster for Maya to process.

To see the vertices, right-click the hammer and select Vertex
from the marking menu. Display the hammer in wireframe
mode by clicking the 4 hotkey.

Scale each row of vertices on the handle inward as desired. A
row refers to the vertices that are at the same height along the
edges of the handle. If a few vertices lie at an odd location,
that is, they lie a little above or below a row, move them into a
position even with the row.

Besides scaling a row of vertices, you can also move a row of
vertices up or down the handle to alter the contours.
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In the next part of the lesson, you'll smooth the edges of the
hammer so it looks more authentic. Before doing this, you
might want to tune the hammer’s shape by modifying your
prior extrusions or by moving or scaling vertices.

To modify an extrusion, first select the face or faces, and then
select Modify > Transformation Tools > Show Manipulator
Tool. Next, click each polyExtrudeFace# in the Channel Box
until the extrude manipulator appears on the desired
extrusion.

You can move and scale a face with the standard Move Tool
rather than the Show Manipulator Tool. However, the Show
Manipulator Tool moves the face in the direction of the
surface normal rather than in a direction along the View Axis.
This surface normal direction is usually the desired direction.

Smoothing edges

Now you'll smooth the edges of the hammer. Smoothing the
edges adds more vertices, which means it will be harder to select
vertices when you reshape the surface thereafter. Generally it’s
best to hone the shape as much as possible before you smooth
edges.
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To smooth the polygon edges and make final
modifications

1 Decide which edges you want to smooth. For each edge to be
smoothed, select the faces that lie on each side of it. For
example, to smooth all edges except those on the claw, select
the faces as shown in the following illustration.

2 Select Polygons > Smooth. After smoothing, you may see
some vertices at improper positions. For example, you might
see a vertex jutting out at the base of the handle.

Improper vertex position
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Select each improperly positioned vertex and move it to a
position where the surface looks symmetrical. Strive for
uniform, regular vertex and edge positions.

If there are improperly positioned edges or extra edges that
make the hammer lumpy, you can either select them and
move them or delete the unwanted edges by using the

Edit Polygons > Delete Edge tool. If you need to add an edge,
do so with Edit Polygons > Split Polygons Tool as shown
previously in the lesson.

Notice how the pounding end of the hammerhead has a
rounded shape. On a real hammer, this end is flat. To flatten
the end, select the vertices there. It’s easiest to do this in a
front view by dragging a selection box around the vertices.

In the Toolbar double-click the Move Tool so the tool settings
window is displayed.

Turn off Retain Component Spacing under the Move Snap
Settings section. This will ensure that the following steps work
as described.

Turn on Snap to Grids: §g

Move the vertices straight out from the head until they snap
to a position while working in an orthographic view.

This makes the vertices lie on the same plane, though maybe
not the plane you want.
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9 Turn off Snap to Grids, then drag the vertices back toward the
hammerhead to the desired position.

10 Feel free to enhance the positioning of other vertices
anywhere on the hammer. You can smooth edges more than
one time. For example, if you want a more rounded pounding
face, select the faces surrounding the edges of the pounder
and use Polygons > Smooth again.

The hammer will look smoother when you render an image
from the scene as compared to displaying it in the scene view.
Examples of rendered images follow:

Beyond the lesson

In this lesson you were introduced to some fundamental facts and
techniques of polygonal modeling;:
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*  You can create complex polygonal models with surprisingly
few techniques.

*  Starting from a primitive surface such as a cube, you extrude,
split, scale, move, and rotate faces of the primitive to create a
rough likeness of the object.

*  You then adjust vertices to tune the shape, and finally smooth
the edges between faces where desired.

Polygonal modeling has many timesaving features not covered in
this lesson. For example, Boolean operations (union, intersection,
and so on) are a common way to create a new object from the
interaction of two existing objects.

If you're planning to use your polygonal surfaces where the poly
count is constrained, such as with computer games, Maya has a
number of tools for minimizing the number of polygonal faces of
an object such as the Reduce Tool. Fewer faces means simpler
geometry—This is critical when fewer polygons means increased
interactive performance.

“Lesson 2: Sculpting a surface” on page 131 describes how to use
the Sculpt Surfaces Tool. With this tool, you can drag your mouse
to push, pull, and smooth a surface without first selecting vertices.
Though that lesson shows how to shape a NURBS surface, you
can apply most of the same techniques to polygonal surfaces with
its polygonal counterpart, the Polygons > Sculpt Polygons

Tool > 3.

If you want to learn more about a particular tool or feature that
has been presented in this lesson, refer to the Maya Help.
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NURBS Modeling

NURBS (Non-Uniform Rational B-splines) use a method of
mathematically describing curves and surfaces that are well suited
to 3D applications. NURBS are characterized by the smooth
organic forms they produce.

NURBS surfaces can be quickly modeled and edited using a
variety of techniques. NURBS surfaces are created using one or
more NURBS curves that define the profile of the shape that you
want for a surface, and then using a specific construction method
to create the finished surface.

NURBS curves and surfaces have many applications and are the
preferred surface type for industrial and automotive designers
where smooth forms with minimal data are required to define a
particular form. NURBS curves are ideal for defining a smooth
motion path for an animated object. With NURBS, a surface can be
modeled and then converted to a poly mesh.

In this chapter, you will learn some basic techniques for working
with NURBS curves and surfaces in Maya. This chapter includes
these lessons:

*  “Lesson 1: Revolving a curve to create a surface” on page 125
*  “Lesson 2: Sculpting a surface” on page 131

*  “Lesson 3: Lofting curves to create a surface” on page 149
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Preparing for the lessons

To ensure the lessons work as described, do these steps before

beginning:

1 Select File > New Scene to create a new scene before starting
each lesson.

2 Make sure the Construction History icon (below the menu
bar) is on: =B (If it is turned off, it has a large X across it.)

3 Select the Modeling menu set. Unless otherwise noted, the
directions in this chapter for making menu selections assume
you've already selected the Modeling menu set.
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Revolving a curve to create a
surface

A simple technique for creating NURBS surfaces is to create a
curve for the profile of your desired form and then create a
surface using one of the various NURBS surfacing tools available
in Maya. In this lesson, you create an egg holder using NURBS
curves and the Revolve Tool.

In this lesson you learn how to:

Create a NURBS curve using the control vertice (CV) creation
technique.

Use the grid for visual reference when modeling.

Determine the start and end points for a NURBS curve and its
direction.

Create a revolved NURBS surface using the Revolve tool.
Change the display shading smoothness for a NURBS surface.

Edit a NURBS surface by editing its initial profile curve when
it is linked to the surface by construction history.

Getting Started with Maya
125



4 | NURBS Modeling
Lesson 1 > Creating a profile curve

Creating a profile curve

Revolve is a common modeling technique similar to shaping a
vase on a spinning potter’s wheel. You must first create a profile
curve in an orthographic view and use the Revolve Tool to create

a surface.

To create a profile curve

1 Make sure you've done the steps in “"Preparing for the

lessons” on page 124.

2 Select Panels > Layouts > Four Panes so you can see multiple

views of the scene.
3 Select Create > CV Curve Tool.

This is the most commonly used tool for drawing curves.

4 In the front view, click the
numbered positions as shown
in the figure. Make sure the first
and last positions are on the
grid’s Y-axis (the thickest
vertical line of the front view’s
grid).

Also, click three times in the
same spot for positions 9, 10,
and 11. This is necessary to
create a sharp point or corner in
the curve.

To change the position of the
most recent point clicked, you
can middle-mouse drag it.

5 (Windows, IRIX, Linux) After
you click position 13, press
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Enter to complete the curve’s creation.
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(Mac OS X) Press Return to complete the curve’s creation.

The points you clicked in the scene view become the control
vertices (CVs) of the completed curve. CVs are points you
manipulate to alter the shape of a curve (or surface). These
points often lie away from the curve.

It takes a little practice to be able to predict exactly where a
curve will be positioned when you click CV positions with the
CV Curve Tool. Once you've learned the technique, you'll be
able to create and edit curves with graceful symmetry. By
default, you must click at least four points to create a curve
with the CV Curve Tool.

For some advanced operations in Maya, you need to know the
meaning of the start of a curve and the curve direction. The start
of a curve is the first CV you create when you draw the curve.
It is indicated by a small hollow box at the first CV, visible as
you create the curve. Curve direction is shown on the second
CV after the start of the curve, indicated by a small u icon as
you create the curve.

Creating a revolve surface

With the Revolve surface tool, a curve is rotated about an axis to
create a surface. The user can define the axis of revolution.

To create a revolve surface

1

With the curve selected, select Surfaces > Revolve. This creates
the egg holder surface from the revolved profile curve.
Examine the results in the perspective view.

Maya does not delete the profile curve. In a subsequent step,
you'll edit the profile curve to alter the shape of the surface.

Select the surface and rename it Eggholder in the Channel
Box.
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3 With the pointer in the perspective view, press 5 (for
Shading > Smooth Shade All). This displays the egg holder as
a shaded surface rather than a wireframe in the perspective
view.

4 Press 1,2, and 3 to switch between the different degrees of
display smoothness. (These hotkeys correspond to the menu
items under Display > NURBS Smoothness.)

The finer the smoothness, the greater the impact is on
interactive performance when you work with complex
models.

The smoothness display only affects the scene view. Rendered
images display with high quality smoothness regardless of
this setting.

Editing a revolve surface

After you create a surface from a revolved curve, you can reshape
the original creation curve to reshape the surface. This is possible
because Maya’s Construction History feature was turned on
before you did the revolve operation.

Selecting the original creation curve can be challenging when it is
situated amongst other existing curves and surfaces. The Outliner
is an editor that is useful for quickly examining the structure and
components of a scene. The Outliner is also useful for selecting
objects in situations like this.

To edit a surface with construction history

1 Select Window > Outliner.

The Outliner appears and displays a list of the items in the
scene.
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In the Outliner, select the curve you revolved (curvel) by
clicking on its name in the list.

The curve becomes highlighted in the scene views.

In the front view, right-click in the view and select Control
Vertex from the marking menu.

The CVs for the curve appear.

Select and move one or more CVs to adjust the curve shape as
desired.

If you have trouble selecting one of the CVs in the front view,
select it in the perspective view after dollying and tumbling
the camera as necessary.

This modifies the shape of the egg holder because it is linked
to the shape of the curve by its construction history.

—
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5

If desired, save the scene for future review.

6 Close the Outliner window.

Beyond the lesson

In this lesson you were introduced to a few basic techniques
related to NURBS modeling:

Revolving a curve is the easiest way to create surfaces with
radially symmetrical forms— wheels, vases, glasses, pillars,
and so on.

NURBS surfaces are webs of interconnected curves. The
creation curves are used to create and subsequently modify
the surfaces if required.

Proficiency at drawing and editing curves is an important part
of NURBS modeling.

The grid is a useful aid for constructing and modifying
curves.

Some additional points you should know are:
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You cannot render curves, so your work with them is always
an adjunct to creating and editing surfaces.

Besides moving a curve’s CVs to alter its shape, you can cut,
attach, extend, close, and smooth curves.

After you create a surface from a revolved curve, you can edit
the surface at a component level by moving CVs or scaling
groups of CVs on that surface to customize the shape of the
surface. (You will need to turn off construction history in
order to do this.)
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Sculpting a surface

In addition to creating NURBS surfaces using
curves, you can edit and sculpt surfaces and
primitive objects in Maya using the Sculpt
Surfaces Tool.

The Sculpt Surfaces Tool allows you to
interactively push or pull on the surface
regions to create areas that are embossed or
in relief in relation to the surface.

In this lesson, you learn some of the basic
concepts of these tools by sculpting a cartoon face and head from
a NURBS primitive sphere using the Sculpt Surfaces Tool.

In this lesson you learn:

*  Basic sculpting operations (push, pull, smooth, and erase)
with the Sculpt Surfaces Tool.

*  How the density of isoparametric lines affects the surface
detail possible when sculpting.

e How to increase the surface subdivisions on a NURBS surface
to aid with surface sculpting.

*  How to change the brush radius for the Sculpt Surfaces Tool.

*  How Opacity and Max Displacement affect the sculpting
operations.

*  How to import geometry from a pre-existing file into your
current scene.

Preparing a surface for sculpting

Because a head is roughly spherical, you can create a primitive
sphere as a quick starting point for creating a head and face.
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To prepare a sphere for sculpting

1
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Make sure you've done the steps in ”"Preparing for the
lessons” on page 124.

Select Create > NURBS Primitives > Sphere > 0. In the
options window, select Edit > Reset Settings, enter the
following values, then click the Create button:

e Radius: 6
¢ Number of Sections: 30

*  Number of Spans: 30

||r—!—ﬂ__\ 1o

The Radius sets the sphere’s size in grid units. A value of 6
creates a sphere big enough to use the grid for size
comparison.

The Number of Sections sets the number of vertical curves,
called isoparms, for the sphere. Isoparms show the outline of
the surface shape. The more isoparms a surface has, the more
CVs it has. (By default, CVs are not displayed.) More CVs
means better precision as you edit a surface. The Number of
Spans sets the number of horizontal isoparms.

The drawback to having too many CVs is that you'll have a
harder time making smooth shape changes to broad regions.
Lots of CVs also means slower processing time as you work
with the surface. It’s best to make surfaces with as few CVs as
necessary.
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We chose 30 Sections and Spans for this lesson because
experience has shown that this allows adequate facial subtlety
without slowing Maya operation on a workstation of modest
processing power.

Note In wireframe display mode, if you select

Display > NURBS Smoothness > Fine or Medium, more
isoparms appear than there are actual spans and
sections. The surface is visually displayed with extra
precision, but the extra isoparms have no CVs and
cannot be edited.

Name the sphere Egghead.

Rotate the sphere 90 degrees on its side (Rotate Z: 90). This
positions the sphere’s CVs well for modeling a simple head
and face. You'll learn why later in this lesson.

To give Egghead an oval shape, set
the ScaleX for the sphere to 1.3 or
so. Optionally, you can move
Egghead above the grid so the grid
doesn’t interfere with your view of
Egghead. Also, position the camera
view so the Z-axis of the View Axis points toward you.

Modifying the surface material for easier viewing

Because you will do subtle surface modeling in this lesson, it’s
helpful to display Egghead with bright highlights so you can
clearly see the effects of the changes you make. In the next steps,
you'll assign a Blinn material to Egghead to give its surface bright
highlights. The steps have no explanations, as the shading subject
matter is the focus of a later lesson.
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To assign a Blinn surface material
1 With Egghead selected, press 5 to display the surface with
smooth shading.

2 Right-click Egghead and select Materials > Assign New
Material > Blinn.

The Attribute Editor will immediately be displayed for the
Blinn material.

3 Drag the Color attribute slider roughly 3/4 of the way to the
right, set Eccentricity to 0, and close the window.

Basic sculpting techniques

In the next steps, you'll become familiar with features of the
Sculpt Surfaces Tool. With this tool, you use your mouse or stylus
to push, pull, or smooth a surface’s shape without selecting or
displaying CVs. After you practice sculpting the surface, you'll
erase your practice strokes then begin sculpting Egghead’s
features.

To practice sculpting using basic sculpting operations

1 With Egghead selected, select Edit NURBS > Sculpt Surfaces
Tool > 0. In the Tool Settings window, click Reset Tool, and
make sure the Sculpt tab is displayed.
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In the Sculpt Parameters section, there are four operations for
sculpting a surface. Each affects the region of the surface
where you drag (stroke) your mouse or stylus relative to the
surface normals:

‘ﬂ Sculpt Parameters
Operation € Push & Pul € Smooth ¢ Eraze

Auto Smooth Strength |1 'J—

*  The Push operation depresses the surface in the region of
the stroke.

*  The Pull operation raises the surface in the region of the
stroke.

*  The Smooth operation diminishes bumps or ridges where
you drag.

*  The Erase operation eliminates the effects of the other
three operations. The Erase operation works up to the last
time you saved the scene or clicked the Update button to
the right of Erase Surface.

Experiment with each of the four operations on the surface.
Don’t be concerned with the results. Just become familiar with
the response to your mouse strokes.

By default, Push and Pull strokes deform the surface in a
direction normal (perpendicular) to the surface. To create the
resulting deformation more accurately, use Push and Pull
strokes in a front, side, or top view while examining the
results in a separate perspective view. Tumble the perspective
view regularly for best visual feedback.

When you position the mouse pointer on the surface, it
changes to a red sculpt icon that shows an abbreviation for the
name of the operation you are performing. For instance, Ps
stands for Push.

The red icon also displays the radius of the region affected by
the stroke. The Radius(U) value changes the radius.
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Select the Erase operation and click the Flood button. This
erases all your changes.

Select the Pull operation and enter a
Radius(U) of 0.25, then drag between
a pair of horizontal isoparms without
crossing either.

This has no effect because the stroke
radius didn’t make contact with the
CVs of either isoparm. Regardless of
which operation you use, only CVs
are affected by the strokes.

Change the Radius(U) to 2 and repeat the prior strokes.

The strokes alter the surface because
the radius overlaps the CVs. As this
example shows, you need to make sure
the radius is big enough to influence
the desired CVs. It’s common to
change the radius many times during a
sculpting session.

If you prefer to affect a small region
without increasing the radius, you can &5
add CVs to the region by inserting

more isoparms. You'll do this later in the lesson.

Flood-erase the changes to the surface as you did previously.

Select the Pull operation with a Radius(U) of 0.5. Drag along a
vertical isoparm. For comparison, drag along a horizontal
isoparm.
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Before taking the snapshot for this
figure, we set the Wireframe on
Shaded on the Display tab to None
(Window > Setting/Preferences >
Preferences). This turned off
highlighting of the surface isoparms,
making surface alterations easier to
see. Consider switching between
the off and on settings for Show
Wireframe as you learn the Sculpt
Surfaces Tool.

The vertical stroke creates a thinner ridge than the horizontal
stroke because the density of vertical isoparms is greater. The
number of underlying CVs and their positioning affects the
outcome of your strokes.

Tip

You can alternatively adjust the radius of the sculpting
tool using a Hotkey. Move the tool over the object, press
and hold the b Hotkey and drag left or right. The circle
on the object with numerical radius value represents the
size of your tool. Stroke on the object to try out a new
size

Flood-erase the changes to the surface as you did previously.

Rotate the camera view so the X axis of the View Axis points
toward you. Draw a vertical Pull stroke again.
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As your stroke nears the center of Egghead, a kink occurs. It’s
challenging to alter a surface symmetrically in a region where
many isoparms converge at a single point, called a pole.
Always consider the position of isoparms as you sculpt a
surface. In general, sculpt where isoparms are evenly,
regularly distributed.

10 Erase all changes again, then reposition the camera view so
the Z-axis of the View Axis points toward you.

Tip If the Sculpt Surfaces Tool is selected but not the surface
you want to work on, right-click the surface and select
Select from the marking menu.

Additional sculpting techniques

Now that you've learned the basic features, you'll learn other
useful techniques before starting to model the facial features.
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To practice additional sculpting techniques

© 00 N O O

In the Sculpt Parameter section of the
Sculpt Surfaces Tool, set Max
Displacement to 2.

Draw a vertical Pull stroke.
Change the Max Displacement to 1.
Draw another vertical stroke nearby.

The Max Displacement sets the
maximum distance the surface’s CVs
are pushed (or pulled) with a single
stroke.

Erase the changes to the surface.

Set Max Displacement to 2.

Draw a vertical Pull stroke.

Set the Opacity from the default value of 1 to a value of 0.2.
Draw another vertical stroke nearby.

One ridge is higher than the other. The Opacity value scales
the influence of Max Displacement. For example, with an
Opacity of 0.2, each stroke has only roughly 0.2 times the
effect of the Max Displacement setting.

It’s generally best to use a low Opacity value as you Push or
Pull. You can increase the deformation gradually with
multiple strokes.

If you want to affect only a small region of a surface, use your
mouse to click rather than stroke the region. If the Radius(U)
and Opacity of the brush is small, you might need to click the
nearest intersection point of two isoparms.
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10 With Opacity set to 1, erase all changes to the surface again.

Tip Consider using an electronic tablet with pen stylus. A
pen stylus is more natural for stroking surface changes
as it feels like a pen. With a stylus, you can set an option
that causes the Radius or Opacity to vary with stylus
pressure. For example, you can have heavy strokes
create a bigger Radius than light strokes.

To do this, display the Stroke tab of the Sculpt Surfaces
Tool. For Stylus Pressure, select Opacity, Radius, or
Both. Radius is a common choice. If you select Radius,
the Radius(U) value on the Sculpt tab sets the maximum
radius, while Radius(L) is the minimum. Explore
various settings.

If you use a mouse, set the Stylus Pressure to None. The
Radius(U) sets a fixed radius. Radius(L) is ignored.

Sculpting a nose

Now you'll begin sculpting Egghead’s face, starting with a simple
nose.

To sculpt a nose for the character

1 Position the perspective view so the Z-axis of the View Axis
points toward you.

2 Reset the Sculpt Surfaces tool.
Select the Pull operation and set the following options:

Radius(U): 1
Opacity: 0.2
4  Select this Shape setting so your strokes have a soft, faded

edge: @
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5 Above the midpoint of Egghead, stroke vertically downward
from the top of the nose to the tip—about the distance
between two horizontal isoparms (see the following
illustration). Use several strokes to build up the bridge of the
nose. Create nostrils by stroking horizontally to the right of
the tip of the nose a few times, then to the left of the tip a few
times.

To build up a small area, position the stroke icon there and
click the mouse rather than drag. Tumble the view to examine
your results after each stroke or click.

If the strokes create a bumpy surface,
turn on the Smooth operation and click
Flood once or twice to smooth all strokes
on the surface. Because Opacity is 0.2,
the Smooth operation is subtle.
Alternatively, you can smooth a selected
region by stroking just that area. It’s
common to smooth a surface regularly
while using pull and push strokes.

Because there are relatively few isoparms in the nose area,
you can only create a simple nose that’s broad and rounded. If
you want to create sharper features, for instance, depressed
nostrils or sharp ridges, you'll need to insert isoparms in the
nose region. “Sculpting a mouth” on page 143 describes how
to insert isoparms.

Sculpting eye sockets

Eye sockets provide an inset and backdrop for eyes.

To sculpt eye sockets for the character

1 Select the Push operation.

2 Leave other settings the same as for the nose.
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To make a pair of identical eye sockets, display the Stroke tab
of the Tool Settings window and turn on Reflection. Position
the sculpt icon on Egghead. A pair of identical Push icons
appears on Egghead.

Adjust the positioning as desired for the sockets. Click the
mouse many times in the desired location.

In your future work, keep in mind that on some surfaces, the
position of the mirrored stroke icons might appear vertically
or diagonally opposite one another rather than horizontally.
There’s a simple technique for adjusting the positioning. With
Reflection and U Dir turned on, try various slider positions
for U Dir. If the positioning isn’t correct, turn on V Dir and try
various slider positions for V Dir. Make subtle adjustments by
moving the brush icon.

Sculpting eyebrows

Eyebrows help define how stern or pleasant a face appears.

To sculpt eyebrows for the character

1
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Select the Pull operation. Use the same option settings as for
the eye sockets, including Reflection.
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2 Position the sculpt icons above the eyes and draw horizontal
strokes. If necessary, click positions where you need to build
up the eyebrows. Smooth the eyebrows as necessary.

Sculpting a mouth

With the 30 Sections and 30 Spans specified for the original sphere
in this lesson, the large space between isoparms in the mouth
region makes it impossible to create a subtle shape for the lips.

Too few isoparms
for subtle shape

To overcome this problem, you must insert isoparms in the mouth
region before sculpting.
To insert additional isoparms

1 Right-click Egghead and select Isoparm from the marking
menu.
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2 From the Toolbox, choose the Select Tool.

Rk

3 Click the horizontal isoparm below the nose and shift-click the
next two below it.

4  Select Edit NURBS > Insert Isoparms > (J. In the options
window, turn on Between Selections, enter a value of 2 for #
Isoparms to Insert, then click Insert.

This inserts two extra isoparms between each pair of selected
isoparms, for a total of four extra isoparms. This provides
enough CVs to create subtlety in the mouth.
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You might want to add vertical isoparms at the lips in a
similar way. The extra isoparms would also be useful if you
were to later enhance the shape of the nose. Insert isoparms
only where needed. More isoparms means slower processing
speed.

In any case, do not change the number of isoparms by editing
the original number of Sections and Spans in the
makeNurbSphere history node. This will reshape your
sculpted surface undesirably.

To sculpt a mouth for the character

Select the Sculpt Surfaces Tool again.

2 Select the Push operation. Enter 0.2 for Radius(U). In the
Stroke tab, make sure Reflection is turned on.

3 Starting at the center of the area appropriate for the
indentation between the lips, stroke outward from the center.
It’s best to start the stroke with the dual icons on top of one
another (in other words, only one icon is displayed).

4  Select the Pull operation and set the Radius(U) to 0.3. Using a
similar technique as for the prior step, stroke the upper lip.
Repeat for the lower lip.
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Note It might be easier to push or pull the lips with the Ref.

Vector set to Z Axis. This moves the region you stroke in
the world Z-Axis direction. The default Normal setting
moves the region in a direction normal (perpendicular)
to the surface. Because the normal direction on a lip
might be up, down, or straight out, depending on the
part of the lip you stroke, there’s more possibility of
undesired results when you use the Normal setting.

Sculpting other facial features

You can now optionally add other facial features. Consider these
tips:
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For facial features such as the chin, cheeks, and forehead, use
a Radius(U) larger than 1 and start with a Maximum
Displacement between 0.5 and 1.

Insert isoparms wherever you want to add extra detail with
the Sculpt Surfaces Tool.

To create eyeballs for the sockets, create a sphere and scale it
as necessary to fit the socket. You might want to increase the
eyeball’s Scale X value to make it oblong. To duplicate the
eyeball, and make a mirrored copy of the original you’ll first
need to set the pivot point for the eyeball to be at the origin 0O,
0, 0 using the following steps. With the sphere selected, press
the Insert (Windows, IRIX, and Linux) or Home (Mac OS X)
key so that the sphere’s pivot point is displayed. Next move
the pivot point to the origin using the X hotkey so that the
pivot snaps to the grid at 0, 0, 0. Select Insert (Home) to turn
off the pivot point display. Finally, use Edit > Duplicate > O
and set the Scale setting to -1, 1, 1. This makes the new eyeball
a mirrored duplicate of the original on the opposite side of
Egghead’s face. Position the eyeballs in the sockets. Parent the
eyeballs to Egghead.
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To create simple, unadorned ears, you can create, scale, and
squash a sphere. Create ridges and valleys by pulling CVs or
by using the Sculpt Surfaces Tool. Duplicate the ear by first
setting its pivot point to the origin and with the Scale option
set to -1, 1, 1. Parent the ears to Egghead.

To import existing models into your scene:

If you saved the Eggholder scene in the prior lesson,
you can import the egg holder into this Egghead
scene, then position Egghead into the egg holder.

1

To import the egg holder into the Egghead
scene, use File > Import and select the name of
the scene that contains Eggholder.

Importing a scene imports all objects from that
scene.

Increase (or decrease) the scale of the egg holder
(or Egghead) as necessary for a snug fit.

Beyond the lesson

In this lesson you were introduced to a few basic techniques
related to sculpting surfaces:

The Sculpt Surfaces Tool is indispensable for quickly shaping
a variety of surfaces. As you do your own projects, pay
special attention to the position and density of isoparms
before you begin sculpting.

Isoparms converge at a single point (the pole). Pole regions of
a primitive or surface are hard to sculpt so it’s best to avoid
using the Sculpt Surfaces Tool there. For example, when you
created the original sphere in this lesson, you rotated it 90
degrees around its Z-axis. Because of the rotation, ears for the
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head would need to be modeled via a different technique (for
example, you could model a pair of ears and parent them to
the head.)

The density and orientation of isoparms on a surface affects
the results with the Sculpt Tool. As you gain NURBS
modeling experience, you'll learn how to use the density and
orientation of isoparms to your advantage.

Primitive objects are useful objects for sculpting in many
cases. After you create a primitive, you typically sculpt, scale,
trim, or otherwise alter the object into a more complex shape.
Though most primitives are surfaces rather than curves, they
still derive their shape from curves.
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In general, a sphere makes a convenient foundation for
creating a simple head, but it’s not ideal if you plan to
animate an expressive, talking head. Many 3D artists start
with a cylinder or a lofted surface. The procedures for doing
this are more complex than starting with a sphere and beyond
the scope of this lesson.
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Lofting curves to create a surface

Another method for creating NURBS surfaces is to loft
a series of curves that define the cross section of your
desired surface form. Lofting a surface works like
stretching a skin over each of the cross sections to
create the final surface.

In this lesson, you learn additional NURBS surfacing
techniques by using the Loft tool to create the body of a
salt shaker. You will also create the cap for the salt
shaker by modifying the shape of a primitive sphere.

In this lesson you learn how to:

*  Modify the outline of a circle primitive by editing the position
of its CVs.

e Use the magnet snap feature.

*  Loft cross section curves to create a NURBS surface using the
Loft tool.

* Edit the form of an existing primitive object by moving its
CVs.

e Parent one object to another using the Outliner.

Creating profile curves for a surface

You begin the lesson by creating a pair of profile curves. You then
create several copies of these curves to form the skeletal contours
of the salt shaker’s surface.

To create profile curves for the salt shaker’'s body

1 Make sure you've done the steps in “Preparing for the
lessons” on page 124.
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Select Create > NURBS Primitives > Circle > 0. In the options
window, select Edit > Reset Settings, enter the following
values, then click the Apply button:

e Radius: 4
¢ Number of Sections: 24

The Radius sets the size of the circle in grid units. A value of 4
creates a circle with enough size so that you can use the grid
for convenient size comparison.

The Number of Sections sets the number of CVs in the circle.
By using 24 CVs, you can create a circle with the subtle
contours required in this lesson. Display the CVs of the circle
to see the 24 CVs.

A circle is a curve that loops back on itself. The CVs work the
same way as for any other curve. The more CVs you create for
a curve or surface, the more detail you can give its shape.

The drawback to using many CVs is that you'll have a harder
time making smooth shape changes to broad regions. Also,
more CVs means slower processing time as you work with the
curve. It’s best to make curves with as few CVs as necessary.
With experience, you'll learn how many CVs to use in a
situation.

Create another circle, this time with these options:
* Radius: 2
*  Number of Sections: 24

This creates a smaller circle inside the first circle as shown
below.

Change the scene view so you can see the circles from the top
view.
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| [

5 Right-click the inner circle and select Control Vertex from the
marking menu. Repeat for the outer circle.

6 Turn on Snap to Points (below the menu bar). .

7  As shown in the following figure, move CVs from the outer
circle to the corresponding inner circle positions. As you drag
a CV near its destination, the Snap to Points mode causes the
CV to jump to the exact CV position.
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8 Turn off Snap to Points. Turn off the display of CVs for both
circles by right-clicking on the circles and selecting Object
Mode from the marking menu.
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Duplicating curves

In the next steps, you'll create several copies of the previously
created circles (also called curves) to form the skeletal contours of
the salt shaker’s surface.

To duplicate curves for the lofted surface

1
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Right-click the outer curve and choose Select from the
marking menu.

Select Edit > Duplicate > 0. In the options window, select
Edit > Reset Settings, enter the following values, then click
Duplicate:

e Translate: 0, 3,0
e Scale:0.93,1, 0.93
*  Number of Copies: 4

This creates four copies of the original curve,
each translated three units above the last, and
each scaled smaller than the last.

Select the inner circle and then move it to 0, 13, 0 by entering
these translate values in the Channel Box. Increase its Scale
attributes to 1.33, 1.33, 1.33.

Use Edit > Duplicate > 0O with the following -
options: Ra—

e Translate: 0,2,0
e Scale:1.05,1, 1.05 E
*  Number of Copies: 3 ==

This creates three copies of the circle, each gl—é
translated two units above the last, and each
bigger than the last.
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Lofting a surface

You've created a total of nine curves. In the next steps, you loft
these curves into a surface that matches the contours of their
perimeters. Above the midpoint of the surface, the shape will
change from a flower-shaped perimeter to a circular perimeter.

To loft a surface for the salt shaker’'s body

1 Shift-select all circles, one at a time.

The order of selection is important when shift-selecting for a
loft operation. You must start with the bottom flower-shaped
circle and end with the top circular-shaped circle.
Alternatively, you can drag a selection box around the circles.
The surface to be lofted will be based on the selection order of
the curves.

2 Select Surfaces > Loft.
This creates the salt shaker’s body.
3 Name the surface shakerBody.
4 Press 5 to display the view with smooth shading.

Lofted surface set
to smooth shaded
mode
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Note Many of the surface creation tools also have the option
of creating polygon or subdivision surface versions of a
surface with the same input curves. You do this by
setting the appropriate Output Geometry option for that
particular surface tool.

Modifying a primitive object

To create a simple cap for the salt shaker, you'll create a sphere,
alter its shape, and position it above the body.

To create and modify a sphere for the salt shaker’s
cap

1 Select Create > NURBS Primitives > Sphere > 0. In the
options window, select Edit > Reset Settings, and click the
Create button. Maya puts the sphere at the origin, its display
currently obstructed by the salt shaker body.

Name the sphere Cap.
Move the cap to the top of the body

4 Scale the cap size so that its diameter fits snugly
at the top of the body.

Adjust the cap’s position as desired.

6 Inaside view, make sure that the cap is displayed
as a wireframe.

7 Right-click on the Cap and choose Control Vertex
from the marking menu.

8 GSelect the top row of CVs and drag them down
until the top of the cap is flattened:
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Check that the bottom half of the cap isn’t poking through the
visible surface of the body. You can scale the bottom CVs
inward to avoid this problem.

Using the Outliner to parent objects

The Outliner is an editor that is useful for quickly examining the
structure and components of a scene. You can use the Outliner to
quickly parent objects to create an object hierarchy.

To parent an object using the Outliner

1 From the main menu, select Window >
Outliner.

The Outliner window is displayed. A list of the
scene’s components is listed in the Outliner.

2 In the Outliner, click on the word cap to select
it.

3 Parent the cap to the body by middle-mouse
dragging Cap onto Body in the Outliner.
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By parenting the objects, you can move, rotate, or scale the
cap and the body as a single entity by selecting only the body.

Notice that the salt shaker displays horizontal curves that
wrap around the body. The curves are the original circles you
used to loft the surface. Because these curves are part of the
surface’s construction history, you can alter their shape if you
decide you want to alter the shape of the body and the body
will update based on the construction history.

If you prefer not to see the curves in the scene view, select the
curves and select Display > Hide > Hide Selection. The curves
won’t appear when you render an image of the scene. Maya
displays only surfaces, not curves, in rendered images.

Beyond the lesson

In this lesson you were introduced to the basic techniques related
to lofting curves to create NURBS surfaces:
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You made a salt shaker with two surfaces: a body made from
lofted curves and a cap made from an altered sphere. An
advantage of creating a separate surface for the cap and base
is that you can easily give each a different color or texture, for
example, one chrome and the other marble. Another
advantage of creating a separate cap is that you can animate
the object separately. For example, you could choose to
animate the cap unscrewing from the shakerBody.
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*  You used a Loft operation rather than a Revolve operation to
create the body. The vertical corrugations on the surface
would be impossible to create by revolving a curve.

*  You can alter the position of the profile curves and the shape
of the shaker will update because of the construction history.
If you're certain you won't change the body’s shape by
editing the shape of the lofted curves, you can delete the
body’s construction history to quicken Maya’s processing of
your interaction with the surface. (For a surface as simple as
the salt shaker, deleting the history won’t boost processing
much.)

*  There are many other useful tools for creating and editing

surfaces. For a glimpse of the possibilities, take a look at the
Surfaces menu and the Edit NURBS menu.

If you want to learn more about a particular tool or feature that
has been presented in this lesson, please refer to the Maya Help.
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Subdivision
Surfaces

In Maya, subdivision surfaces possess characteristics of both
polygon and NURBS surface types. This hybrid surface type offers
some features not offered by the other surface types.

Like NURBS surfaces, subdivision surfaces are capable of
producing smooth organic forms and can be shaped using
relatively few control vertices.

Like polygon surfaces, subdivision surfaces allow you to extrude
specific areas and create detail in your surfaces when it is
required. This is accomplished by having the ability to work at
different component levels of detail on the subdivision surface.
You can switch between the different levels of detail as often as
necessary.

With a subdivision surface you can build a smooth organic object
from a single primitive (for example, a four-legged animal or a
human hand) and not be concerned about attaching or stitching
the various surfaces together as you would for a NURBS surface.
There are no seams that can show when you begin to animate.

Preparing for the lesson
To ensure the lesson works as described, do these steps before
beginning:

1 Consider reading Chapter 3, “Polygonal Modeling.” Working
with polygonal modeling tools is essential to becoming
proficient in subdivision surface modeling.

2 Create a new scene.

Select the Modeling menu set. Unless otherwise noted, the
directions in this chapter for making menu selections assume
you've already selected the Modeling menu set.
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Lesson1 Modeling a subdivision surface

In this lesson you learn some of the basic tools for working with
subdivision surfaces as you model a human character's hand.

In this lesson, you learn how to:

*  Convert a polygon surface to a subdivision surface.
*  Work with subdivision surfaces in Polygon Proxy Mode.

e Split subdivision faces to create areas for more detail in a
model.

*  Extrude the split faces to create fingers on the hand.
*  Work with subdivision surfaces in Standard Mode.
e Change the Display Level when working in Standard Mode.

*  Add more detail to subdivision surface models using Refine
Selected Components.

e Create a crease along a vertex edge.

Creating a subdivision surface

You begin the lesson by creating a polygonal cube. You'll convert
this cube to a subdivision surface that will be the foundation of
the hand. The reason for starting with a polygonal surface and
converting it to a subdivision surface is that you can thereafter
edit the object’s shape with more versatility. You can edit with
subdivision surface tools and polygonal tools.
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To create a polygon cube

1 Select Create > Polygon Primitives > Cube > (J. In the options
window, select Edit > Reset Settings. Then enter the following
values and click the Create button.

*  Width: 8
*  Height: 2.5
* Depth: 8

The resulting polygonal cube is roughly proportional to the
palm of a hand.

To convert a polygonal cube to a subdivision surface

1 To convert the polygonal cube to a subdivision surface, select
Modify > Convert > Polygons to Subdiv.

2 Press 3 on your keyboard (to select Display > Subdiv Surface
Smoothness > Fine).
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Also press 5 (to select Shading > Smooth Shade All).

With the Smoothness set to Fine, you can see that the
conversion to a subdivision surface creates a rounded, smooth
shape. By pressing 3, the subdivision surface is displayed
more precisely in the scene view. This gives a closer
approximation of what the surface will look like when you
create a rendered image of the scene.

As an alternative, you could have chosen a rough smoothness
(press 1) so that Maya processes your editing changes in the
scene view more quickly. Regardless of the smoothness in the
scene view, surfaces always are displayed precisely in
rendered images of the scene.

To display a subdivision surface in polygon proxy
mode

1 Select Subdiv Surfaces > Polygon Proxy Mode.
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The wireframe cube looks the same as the original polygonal
cube. The new cube is called a polyToSubd1 for the subdivision
surface as a result of the conversion. Rename it LeftHand. You
can use polygonal modeling tools to edit the shape of the
polygonal proxy, which indirectly alters the shape of the
subdivision surface. Unlike working with an actual polygonal
object, your modifications result in perfectly smooth surface
changes rather than faceted changes.

Splitting a surface in polygon proxy mode

Next, you use polygonal modeling techniques to split a face into
multiple faces to be extruded as fingers.

To split the polygon face into multiple faces

1 With LeftHand still selected, select Edit Polygons > Split
Polygon Tool.

You'll use this tool to split the front face of the proxy into
several faces to be extruded into fingers.

2 In the front view, click the point on the top edge as shown in
the following figure, then click the corresponding point
directly below it on the bottom edge. If the line between the
points isn’t perfectly straight, use the middle mouse to drag
the second point to the correct position. Press Enter
(Windows, IRIX, and Linux) or Return (Mac OS X).

Click these | 55 |
points and press =
Enter (Return).

This splits the face into two faces. You'll extrude the left face
into a finger later.
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3

Repeat the steps
for these points.
Then repeat for the
remaining faces.
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Repeat the preceding two steps as necessary to split the face

as follows:
| I | E | |
EpsEs

Notice how splitting the face into multiple faces alters the
shape of the subdivision surface. The front part of the
subdivision surface now resembles the proxy shape more. If
you were to split the front face several more times, especially
near the outer edges, the subdivision surface would sharpen
and resemble the proxy shape even more. More faces means
finer control, often at the expense of making the surface
harder to work with.

With the added faces, the subdivision surface looks a bit like
the palm of a hand. You'll build upon this shape to create a
left hand with palm facing downward and fingers extruded
outward. You'll extrude the wide faces into fingers, and you’ll
leave the narrow faces as webbing between the fingers.

Fingers will be
extruded
outward
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Extruding polygon faces

Next, you'll extrude faces to create fingers for the hand.

To extrude the polygon faces to create fingers

1

In a perspective view, right-click LeftHand and select Face
from the marking menu.

This lets you select faces.

Select the right-most face by dragging a selection box around
the tiny box at its center. (The subsequent illustration shows
which face to select.)

Select Edit Polygons > Extrude Face.

Drag the blue arrow manipulator outward a little to create the
first segment of the smallest finger.

The blue arrow turns yellow when selected.

Repeat the prior two steps to create the middle segment of the
smallest finger.

Repeat the prior two steps once again to create the top
segment and complete the finger.
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By creating three segments for a finger, you mimic a real
finger’s natural structure. The borders between the segments
have vertices (not displayed currently) that let you reshape
those regions, for instance, to create knuckles.

7 Similarly, extrude the ring, middle, and index fingers from the
appropriate wide faces. Don’t extrude the three small faces
that lie between the wide spaces. Leave them in position to
allow for webbing between the fingers.
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Note Do not be concerned if the hand you create does not
match the lesson’s illustrations. Your goal in this lesson
is to learn the workflow of subdivision surfaces, not to
perfect your modeling technique.

Next, you extrude a thumb using similar techniques as you used
for the fingers. The following steps are abbreviated. See the
preceding pages for details on the described tools, if necessary.

To subdivide and extrude a face for the thumb

1 Select LeftHand.

Make sure it is highlighted in green in the scene view. If it is
not green, select LeftHand in the Outliner.

2 Use Edit Polygons > Split Polygon Tool to split the side face in
the thumb region into three faces.

While splitting, make sure the middle face is larger than the
outer faces as shown below.
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This face must e
be larger than
the faces on
each of its sides.

Extrude the middle face and drag it directly outward.

Click the surrounding blue circle and use the rotate
manipulator to aim it in a direction appropriate for a thumb.

Extrude three times more to create each segment of the
thumb. Use the extrusion manipulator to rotate, move, and
scale each extrusion to create the desired shape of a thumb.
Use the following figure as a guideline. Again, it’s
unnecessary to match the illustration or create a realistic
thumb for this lesson.

The extrusion manipulator is easy to figure out by clicking
and dragging its various elements. If necessary, you can also
use the conventional Move, Scale, and Rotate Tools to reshape
the faces that control the thumb’s shape.
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6 In the scene view, right-click LeftHand and select Vertex from
the marking menu. The purple vertices at the corners of the
faces control the adjacent region of the hand.

7 Make coarse adjustments to various parts of the hand by
repositioning the vertices with the Move, Scale, and Rotate
Tools.

The Move Tool works on individual vertices or groups of
vertices. Rotate and Scale works on two or more vertices.
Undo any changes you don’t like using Ctrl-Z (Windows,
IRIX, and Linux) or Control-z (Mac OS X).
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T

Try to create the approximate thickness, length, and curvature
of a cartoon character’s hand and fingers. There’s no need for
perfection. You'll refine the fingers later. An example hand
follows. (You might be satisfied with a simpler shape.)

Deleting polygon faces

In the next steps, you delete a face in order to create a hole in the
wrist where you might choose to attach an arm. Though you
won't create and attach an arm in this lesson, it’s useful to learn
the technique for future use.

To create a hole at the wrist by deleting a face

1 Select the face at the wrist and press Delete to create a hole
where you could attach an arm.

2 Scale the four vertices that surround the hole and scale them
inward to narrow the wrist region of the hand.
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Subdivision surface levels

Next, you refine the shape of the fingers by working in Standard
Mode. In Standard Mode, you can make edits to mesh vertices,
edges, or faces at different levels of refinement, that are not
possible in Polygon Proxy mode. The different levels of
refinement are referred to as subdivision surface levels.

To refine the fingers using subdivision surface levels

1 Select LeftHand.

2 Select Subdiv Surfaces > Standard Mode. This switches to a
mode that lets you modify the surface at various levels of
detail to suit your needs.

3 In the scene view, right-click LeftHand and select Vertex from
the marking menu.

This displays 0s on the surface in the same positions as the
vertices in Polygon Proxy mode. In fact, the Os are vertices.
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The number 0 refers to the level of detail you are capable of
editing. The 0 level is identical to the coarse control possible
in Polygon Proxy mode by manipulating the vertices. You can
move, rotate, and scale the 0Os to alter the shape of the surface
just as you did for vertices in Polygon Proxy mode.

Right-click the surface and select Display Level > 1.

Though the 1s are displayed in the same regions as the 0Os
were previously, there are many more 1s displayed. The 1s
are also vertices, and their increased presence means you can
refine the shape with more subtlety.

Refine the shape of the fingers, thumb, and hand as desired by
selecting various level 1 vertices and moving, scaling, and
rotating them with the transformation tools. (Scaling and
rotating has effect only if you select two or more vertices.)

It’s essential to tumble the camera from various perspectives
to make sure you've selected only the desired vertices.




5 | Subdivision Surfaces
Lesson 1 > Refining surface components

To return to level 0 to alter the shape with fewer vertices,
right-click the surface and select Display Level > 0. Each level
has advantages. Level 1 allows finer control because there are
more vertices. Level 0 allows control of broader regions, and
it’s often easier to select the desired vertices since there are
fewer of them. It's common to switch back and forth between
levels repeatedly in a work session.

The hand has level 2 vertices at various locations, for instance,
at the webbing between the fingers. You can also work at that
level of detail if desired (select Display Level > 2).

Refining surface components

By default, a subdivision surface displays up to three levels of
detail (0, 1, and possibly 2). The 0 level is the least refined. You
can increase the level of detail for a selected region to at most 13
levels. Though increasing the number of levels allows more
precision, it also slows Maya processing. You'll accomplish most
of your modeling needs at levels 0, 1, and 2.

If you display level 2 vertices on the hand, you'll notice that there
are no level 2 vertices near the fingertips. To create the
indentation of a finger nail, you need more vertices than levels 0
and 1 provide. In the next steps, you'll add level 2 vertices at a
fingertip so you can create a fingernail.

To create more precision in the fingernail region

1 Switch to level 1.

2 Right-click the surface and select Edge from the marking
menu.

3 Shift-click to select the edges that surround the region where
you'll shape a nail.
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Shift-select the edges tha
surround the fingernail
region

4 To increase the amount of detail at the selected edges, select
Subdiv Surfaces > Refine Selected Components. Additional
surface curves appear in the fingernail area, indicating you
can edit with more precision.

Additional curves appear
to allow for more precise
editing.

5 In the scene view, right-click LeftHand and select Vertex from
the marking menu. This displays additional level 2 vertices in
the fingertip region.

6 Select Modify > Transformation Tools > Move Tool > (. In the
Tool Settings window, turn on Normal, then close the
window. You can thereafter use the Move Tool manipulator to
move vertices in a direction normal (perpendicular) to the
surface.

7 Select the vertices in the nail region.
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Selected vertices

8 Drag the Move Tool’s N manipulator down slightly to form
the depression of a fingernail bed.

Drag the N manipulato
downward to create th
depression of a nail
bed.

Creating a crease in a subdivision surface

One of the unique features of subdivision surfaces is that it's easy
to create a crease or ridge on a smooth surface. You’'ll do this in
the next steps.

To crease the edge of the finger nail

1 Switch to Edge selection mode and shift-click the edges
around the nail to select them. (It might be easier to see the
desired edges by first selecting Shading > Wireframe.)
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Selected edges

After you select the edges, select Subdiv Surfaces > Full
Crease Edge/Vertex.

Once you crease an edge, it displays with a dashed line as a
visual reminder that the edge has been creased. If you change
your mind, you can remove the crease using Subdiv Surfaces
> Uncrease Edge/Vertex.

To create a ridge at the edge of the nail, switch to Vertex
selection mode and select the level 2 vertices on the skin at the
perimeter of the previously selected edges. Move them up so
that the skin’s juncture with the nail forms a slight ridge.

Now experiment on your own by moving individual vertices
to shape the nail and surrounding region as desired. A few
suggestions follow:

In Smooth Shade display mode (Shading > Smooth Shade
All), certain vertices might be below the shaded surface and
therefore impossible to select and move. To display and select
such vertices, switch to wireframe shading
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(Shading > Wireframe). After selecting the vertices, return to
Smooth Shade display mode so you will be able to more
easily see the results of moving them.

*  You might get better results using the Move Tool’s default
World setting rather than the Normal setting made in a prior
step. To return to the default setting, select
Modify > Transformation Tools > Move Tool > 0. In the Tool
Settings window, click Reset Tool, and then close the window.

* To extend the front of the nail past the skin with a sharp edge,
add a second crease on the edges below the tip of the nail.
(With the appropriate edges selected, select Subdiv Surfaces >
Full Crease Edge/Vertex.)

You might also want to add an additional level of vertices at
the edges. (With the appropriate vertices selected, select
Subdiv Surfaces > Refine Selected Components.)

After you crease the edges and add the extra vertices, you can
make the nail’s edge overhang the skin below it by dragging
the vertices at the nail tip out and away from the finger. Then
tuck the row of vertices below the overhanging vertices in the
opposite direction.

An example of a completed nail follows:

Completed fingernail

5 If you want more practice, repeat the procedure for the rest of
the nails.

Getting Started with Maya
177



5 | Subdivision Surfaces
Lesson 1 > Beyond the lesson

Getting Started with Maya

178

6 When finished, select Modify > Transformation Tools > Move

Tool > 0. In the Tool Settings window, click Reset Tool, and
then close the window. This returns the Move Tool to its
default settings. This will avoid confusion if you do other
lessons in this book.

Beyond the lesson

In this lesson, you were introduced to some basic techniques
related to subdivision surface modeling:

Modeling with subdivision surfaces is an easy way to create
intricate, smooth objects such as human hands and faces. The
ability to create extrusions, subtle surface alterations, and
sharp edges means there are innumerable types of objects you
can model.

Many of the techniques used in modeling polygonal surfaces
are applicable to subdivision surfaces.

There are many other features related to subdivision surfaces not
covered in this lesson. These include the ability to:

Convert a NURBS surface to subdivision surface.

Convert a subdivision surface to a polygonal or NURBS
surface.

Create subdivision surface primitive shapes from the Create >
Subdiv Primitives menu: Sphere, Cube, Cylinder, Cone, Plane,
and Torus. With these shapes, you can quickly start your
subdivision surface model without converting from polygons
or NURBS surfaces.

Attach two subdivision surfaces to form a single surface, for
instance, to merge a hand and an arm.

Create a mirrored copy of a subdivision surface.

If you want to learn more about a particular tool or feature
that has been presented in this lesson, refer to the Maya Help.



Animation

Maya allows you to bring action to the objects in your 3D scene. In
Maya, when an object or attribute changes in relation to time, it is
referred to as being animated.

Maya provides a large selection of tools to help you animate the
objects in your scene. You may decide to use a combination of
several techniques to achieve your desired results.

In this chapter, you learn some common techniques and features
that highlight Maya’s computer animation technology:

*  “Lesson 1: Keyframing and the Graph Editor” on page 180
e “Lesson 2: Set Driven Key” on page 200

e “Lesson 3: Path Animation” on page 206

*  “Lesson 4: Nonlinear Animation with Trax” on page 228

*  “Lesson 5: Inverse Kinematics” on page 274

Preparing for the lessons

To ensure the lessons work as described, do these steps before
beginning:

1 Select Window > Settings/Preferences > Preferences. Click the
Settings category and set the Time option to Film (24 fps) so
your animation plays at the rate of 24 frames per second. Click
the Save button.

2 Select the Animation menu set. Unless otherwise noted, the
directions in this chapter for making menu selections assume
you've already selected the Animation menu set.
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Lesson 1

Keyframing and the Graph Editor

When you set a keyframe (or key), you assign a value to an object’s
attribute (for example, translate, rotate, scale, color, etc.) at a
specific time.

Most animation systems use the frame as the basic unit of
measurement because each frame is played back in rapid
succession to provide the illusion of motion.

The frame rate (frames per second) that is used to play back an
animation is based on the medium that the animation will be
played back (for example, film, TV, video game, etc.)

When you set several keys at different times with different values,
Maya generates the attribute values between those times as the
scene plays back each frame. The result is the movement or
change over time of those objects and attributes.

In this lesson, you will use simple keyframing techniques to make
a ball fly over a fence and bounce off the ground.

In this lesson, you learn how to:

*  Set keyframes for animatable objects and their attributes.

*  Use the Time and Range slider and Playback Controls to
control the animation playback.

*  Use keyboard shortcuts to set keyframes.
*  Use the Graph Editor to view animation curves.
*  Modify the animation of objects using the Graph Editor.

*  Set preferences to increase the playback quality.
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Setting the playback range

In this lesson, you work with a scene we’ve created for your use.
In the following steps, you open the scene and set how long the
animation will play.

To open the scene

1

Make sure you’'ve done the steps in “Preparing for the
lessons” on page 179.

Open the scene named Keyframing.mb.

You can open the scene named Keyframing.mb from the Maya
Documentation, Lessons, and Extras CD or from the drive where
you copied the Getting Started with Maya data files.

The scene contains a ball object that is currently positioned on
the X-axis near the edge of a ground plane.

To set the playback range for the scene

To animate the ball, you key its position at different times of
the playback range.

The playback range is defined by the Time and Range slider.
The Time and Range slider controls allow you to playback or
scroll through your animation or move to a specific point in
time of your animation so you can set keyframes.
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1

Look over the playback controls, as shown in the figure
below:

Time Slider Playback Controls
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\/ Animation Preferences

Range Slider

The Time Slider displays the playback range and keys you've
set for a selected object. Keys are displayed as red lines. The
box at the right of the Time Slider lets you set the current
frame (time) of the animation.

The Playback Controls control animation playback. You may
recognize the conventional buttons for play and rewind
(return to the start time). The stop button appears only when
the animation is playing. To find out which operation a
button represents, hold the mouse pointer over it.

The Animation Preferences button displays a window for
setting animation preference settings such as the playback
speed.

The Range Slider controls the range of frames that play when
you click the play button.

The above items will have more relevance as you work
through this lesson. After you complete this lesson,
experiment with these items to learn more what they do.
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The playback range is currently set at a range of 1 to 24. Ata
default playback rate of 24 frames per second, the scene can
play for one second. Because you'll animate the ball for a few
more seconds than this, you need to lengthen the playback
range.

In the Playback End Time box (see above), enter 72.

A frame rate of 24 frames per second (fps) is the frame rate
used for motion picture film. For video, the frame rate can be
30 fps (NTSC) or 25 fps (PAL) depending on the format being
used.

With a playback range of 1 to 72, you'll be able to create three
seconds of animation. (72 frames divided by 24 frames per
second = 3 seconds.) This is enough time for the short
animation you'll create in this lesson.

Setting keyframes

In the following steps, you use keyframes to set the starting and
ending positions of the ball’s movement.

To set beginning and ending keyframes

1

Click the rewind button to go to the start of the playback
range. This changes the current frame to 1.

Select the ball, then select Animate > Set Key.
(Keyboard shortcut: s).

This sets a key at frame 1 for all transform attributes of the ball.
Transform attributes are the X, Y, Z move attributes. Although
you animate only the translate X and Y attributes of the ball in
this lesson, keying all transform attributes saves you time
having to choose specific attributes to be keyed.

In the Time Slider, notice the red marker at frame 1, known as
a tick. This tick appeared when you set the key for frame 1.
With the ball selected, ticks in the Time Slider indicate where
you've set keys.
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3  Go to frame 72. A convenient way to do this is to click the
desired position in the Time Slider.

4 With the Move Tool, drag the ball’s X-axis handle to position
the ball at the right edge of the ground as shown in the image
below.

Set a key at frame 72. (Press s.)
6 Go to the start time and play the animation.

From the two keys you've set, Maya creates motion between
the positions. By default, the animation plays in a loop from
frame 1 to 72. The ball travels through the fence at this stage.

7  Press the Stop button on the playback control to stop the
animation after you've watch a few repetitions.

You can drag the mouse back and forth (scrub) in the Time
Slider to see the animation play back and forth at the speed
you drag the mouse.

If you were to display the scene with Panels > Layouts >
Four Panes, only the active panel would show the ball
moving.

To make the ball fly over the fence rather than pass through it,
you need to position the ball above the fence and set a key there.
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To set intermediate keyframes

1

Go to frame 33 or so—at the moment where the ball sits in the
middle of the fence.

With the Move tool, drag the Y-axis handle of the ball until it
sits slightly above the fence.

Tip

Throughout this lesson, tumble the perspective view or
examine a front view to make sure the positioning is
correct.

Set a key. (Press s.)
Play the animation.

The ball now flies off the ground, over the fence, and back to
the ground in a smooth arc between the keyed start, middle,
and end positions.

Press the stop button to end the playback.

In subsequent steps, play the animation after each key you set.
It’s generally useful to check your work in progress after each
key, especially when you are learning.

In the next steps, you'll set keys to bounce the ball in the middle
of the right half of the ground.
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To set keyframes to make the ball bounce

1

2
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Go to frame 50. At this moment, the ball sits in a position
above the middle section of the right half of the ground.

Move the ball so it sits on the ground.

Set a key.
Go to frame 60.

Move the ball up again, but not as high as its peak height
above the fence.

Set a key. When you play the animation, the ball travels over
the fence and bounces on the other side.

If you have a fast computer, you might notice that the
animation plays too fast. By default, Maya plays the
animation as fast as it can be processed. Because this scene is
simple, the animation might play faster than the default film
rate (24 frames per second).
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Do not be concerned that the animation plays with a halting
or jerky motion. When you render all the frames of your
animation for final production, the animation will be smooth.
If you want to preview the animation at the smooth
production speed (or nearly so), use Window > Playblast.

Using the Graph Editor

For a more convincing animation, you need to bounce the ball
more sharply off the ground and speed up the ball’s horizontal
movement. You'll use the Graph Editor to make both
modifications.

The Graph Editor is an editor that graphically represents the
various animated attributes in your scene. The animated attributes
are represented by curves called animation curves. You edit
animation curves in the Graph Editor.

To edit animation curves using the Graph Editor

1 With the ball selected, select Window >
Animation Editors > Graph Editor.
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The Graph Editor displays several animation curves, one for
each keyed attribute of the ball. The animatable attributes for
the ball are listed in the left column. Specifically, it displays
the attributes of the selected transform node of the ball.

Each curve graphs how an attribute changes value during the
animation. The column of numbers at the left represents
attribute values that can be animated, while the row of
numbers at the bottom represents time (frame) values. At each
point on the curve, you can see the value of an attribute at a
particular time. The small black squares on the curves
represent points where you've set keys.

Shift-Select only the Translate X and Translate Y attributes in
the left column of the Graph Editor.

Now only the animation curves for Translate X and Translate
Y appear in the Graph Editor.

This simplifies the display. With too many curves present, it’s
hard to see specific curves. When you use the Graph Editor,
you usually focus on one or a few curves.

To center the display of the animation curves, select

View > Frame Selection (in the Graph Editor window). If you
want to see more detail in the graph, use your mouse to dolly
and track the graph view.
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The green curve represents Translate Y, while the red
represents Translate X. The color of each curve matches its
attribute name. This color scheme is consistent throughout
Maya for X, Y, and Z (red, green, blue) so is easy to
remember.

If you've never used a graph editor before, the relationship
between a curve’s shape and the animation it represents
might be hard to understand. With experience, you’'ll quickly
recognize how curve shape affects animation.

In the above graph, the straight curve of Translate X indicates
that the ball moves horizontally across the ground at a
constant rate over time.

The wavy curve of Translate Y indicates that the ball increases
its height steadily until frame 33, dips more quickly until
frame 50, then rises and dips again until frame 72.

When the ball first bounces off the ground at frame 50, it
seems to float and slip rather than rebound. The shape of the
Translate Y curve illustrates why. Near frame 60, the curve is
soft and rounded. The Translate Y values gradually decrease
to the low point then gradually increase. The transition from
decreasing to increasing values is smooth.

The Graph Editor’s usefulness lies in the fact that you can edit
the shape of the animation curves to edit the animation of any
keyed attribute. To create a sharp bounce, you can edit the
curve so that the transition from decreasing to increasing
values is abrupt at frame 50. Specifically, you'll create a corner
at that key point rather than a rounded curve.

Select the point on the Translate Y (green) curve at frame 50.
This causes a pair of tangent handles to appear at the point.
Each end point of the newly displayed straight line is a
tangent handle. The handles let you control the curvature near
the key point.
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Animation curves have a few control structures for curve
editing. You can do any of these operations:

Use the Move tool and middle mouse button to move a key
point. You can alternatively use your keyboard to enter
precise values for a selected key’s frame and value in the
boxes above the graph area.

Use the Move tool and middle mouse button to drag the
tangent handles and change the adjacent curvature.

(You can shift-drag with the Move tool to constrain a move
operation to a single direction.)

Use the Scale tool and middle mouse button to scale selected
key points closer together or further apart.

Use the Graph Editor’s Tangent menu items to change the
adjacent curvature. This is the operation you'll use in the next
step.

In the Graph Editor, select Tangents > Linear.

This changes the curvature around the key point from
rounded to cornered. Specifically, the setting you select
specifies how the key point tangent handles lie at this key
point. This affects the type of interpolation between key
points.

/\

]
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Play the animation and you’'ll see the ball bounce more
sharply.
To sharpen the bounce more, you need to edit the positioning

of the tangent handles to steepen the curvature approaching
the key point.

Select one of the tangent handles.

Use the Move Tool and the middle mouse button to drag it
upwards a little so you can see the how the curvature at the
key point changes.

By default, when a pair of tangent handles share a key point,
they work as a unit. Move one and you move the other in an
opposing direction. This is often desirable in an animation
curve, because it ensures the curvature at that point stays
symmetrical. Symmetrical curvature often helps prevent
unusual animation shifts.

In this case, however, you want to steepen the curvature’s
approach toward the curve point in the same direction on
both sides. You therefore need to break the symmetrical
interdependency between the two tangents.

Undo your previous move of the tangent handle.
Select the key point at frame 50 (not a tangent handle).
In the Graph Editor, select Keys > Break Tangents.

This lets you move each tangent handle independently.

Select the right tangent handle and use the Move Tool to
move it up a little. Do the same for the left tangent handle. Be
careful not to select the key point.
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This sharpens the bounce to simulate the effect of gravity and
elasticity.

Changing the timing of an attribute

The ball seems to move too slowly in its journey. In the following
steps, you'll use the Graph Editor to hasten its movement.
Specifically, you'll cause the ball’s animation to finish its journey
in two seconds (48 frames) rather than three (72 frames).

To speed up the animation of the ball’'s movement

1
2
3

Drag a selection box around all key points of both curves.
Select the Scale tool.

Click and hold the middle mouse button anywhere in the
graph at frame 1 (slightly to the right of 0).

Notice the question mark icon. The location of this icon
indicates the point from which scaling occurs. (Because you
need to scale the animation inward toward frame 1, you need
to start your drag operation at frame 1.)

Without releasing the mouse button, drag to the left until the
right-most key points on both curves are positioned roughly
at frame 48. (When selected, the right-most key points are
yellow.)
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12 2 36 48 &0

This scales the curves symmetrically towards frame 1. The
animation of the ball now plays from frame 1 to 48 rather than
1 to 72. The ball traverses the scene in less time, which, of
course, means it moves faster.

If you had started your drag operation from the middle of the
frame range, the scale operation would have pulled the curves
toward the middle of the frame range. You can snap the
keypoints to whole values to keep the keyframes on a
consistent timing.

Widen the Graph Editor window as necessary to see the graph
clearly. Also, dolly the view or select View > Frame Selection
(in the Graph Editor window).

Fine tuning an animation

Now you can improvise adjustments to the animation on your
own. For example, you might choose to speed the ball’s horizontal
movement up to the first bounce but not thereafter. You might
also decide to raise the peak height of the ball’s motion so that it
doesn’t seem to hover over the fence unrealistically.

Whatever you choose to do, you'll likely need to edit both the
Translate X and Translate Y curves, not just one of them. Play the
animation after each adjustment.
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The following two figures show examples of curves after
modification.The two graphs are identical, except the curve points
are selected in the second figure. The second graph shows the
position of the tangent handles.
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If you want your curves to match the shape of the curves in the
above figure, here’s what you would need to do:

To adjust the animation curves to match the above
images

1 On the Translate X curve, delete the three key points between
the two key points at the end. (The preceding figures show the
curve after the points were deleted.) To delete the points, drag
a selection box around them and press Delete.
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With fewer key points on the curve, it’s easier to maintain the
curve’s smoothness for larger distances as you edit its shape.
Small kinks in an animation curve can ruin an otherwise
perfect animation, so it’s useful to remove key points that you
aren’t using.

On the Translate X curve, select the left-most key point and
move its right tangent handle down slightly. (Remember to
use the middle mouse button when moving a handle or
point.) Select the right-most key point and move its left
tangent handle up slightly.

Notice that the slope of the Translate X curve increases
slightly in the early part of the animation, then tapers off
toward the end. This causes the ball to accelerate slightly at
the beginning of the animation, then decelerate after its first
bounce.

On the Translate Y curve, remove the key point at frame 22.
(The preceding figures show the curve after the point was
removed.) This point wasn’t essential to the curve shape.

On the Translate Y curve, select the left-most key point and
move its right tangent handle up slightly.

At the key point where the bounce occurs on the Translate Y
curve, move the left tangent handle up a bit. This raises the
high part of the curve left of that key point, which makes the
ball rise higher over the fence.

If you want to change the shape of Translate Y curve but lack
adequate control with the existing key points, you can add a
key point at the position of your choice. (No key points were
added in the prior figures.) To add a key, click the Add Keys
Tool icon, select the curve, and middle-click the desired
position on or off the curve.

Add Keys Tool
yoTool 23

Getting Started with Maya
195



6 | Animation
Lesson 1 > Deleting extra keyframes and static channels

Deleting extra keyframes and static channels

As you set keys, you often create many unintended keys. For
example, when you used the Set Key operation on the ball, Maya
created keys on all transform node attributes of the ball, for
instance Rotate Z, not just the intended Translate X and Translate
Y attributes. The curves representing such attributes have
unchanging values. The attributes are known as static channels.

You can identify static channels by examining animation curves in
the Graph Editor. If a curve is horizontally flat its whole length,
the value of the attribute it represents isn’t changing. The attribute
is a static channel. Static channels slow Maya processing, so it’s
beneficial to remove them in complex scenes.

To delete static channels

1 From the main menu, select Edit > Delete All by Type >
Static Channels.

This deletes all unnecessary keys for all objects in the scene.
Alternatively, you can remove the static channels for a selected
object with Edit > Delete by Type > Static Channels.

In addition to static channels, you'll often create excess keys—
keys that aren’t being used to control the shape of a curve.
Whenever you see three key points that lie in a straight line, the
one in the middle is unnecessary. For example, in this lesson’s
original Translate X curve, there were four redundant keys:
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To delete keys, select the key points and press Delete. When you
remove redundant key points, the shape of the curve doesn’t
change and you speed up Maya processing.

Using Playblast to playback an animation

When you play a scene, you see a rough approximation of the
animation. The playback speed and quality is imprecise as
compared to rendering each frame and playing the frames in
sequence with a playback utility specifically designed for this
purpose. The reason for this is that Maya processes the animation
of each frame before display, while a playback utility simply plays
previously processed and rendered images.

The more detail that Maya needs to process, the slower the
playback. For example, playback will likely be slow for any scene
that has several complex objects displayed with Smooth Shade All
and Hardware Texturing.

To preview the animation with more accurate timing

1 Select Window > Playblast.

For the next several seconds, Maya processes the entire
animation frame by frame. When the process is complete, a
playback window appears.

Click the play button in this window to watch the animation.

Close the Playblast window when you're done.

Beyond the lesson

In this lesson, you learned how to:

*  Set keys for attributes, then use the Graph Editor to refine the
animation and remove unnecessary keys. This is a typical
workflow when keyframing.
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You can animate most any attribute in Maya, not just the
Translate, Rotate, and Scale attributes of a surface. For
example, you can animate the intensity of a light, the
transparency of a surface, the rotation of a camera view, or the
position of CVs.

Work with the Graph Editor to adjust the animation attributes
animation curves directly.

The Graph Editor is the best tool for editing keyed animation
by reshaping animation curves. You can use it to change key
positions, add or remove keys, and alter the fluidity and
symmetry of animation.

Each key point on an animation curve has a Tangent setting
that specifies the curvature leading into that point. The
default Tangent setting (Spline) creates rounded curvature—
useful for animating attributes that change smoothly over
time. The Linear setting creates angular curvature, useful for a
bounce effect or any other abrupt change in attribute value.
Other Tangent settings are available for different animation
effects. For example, a Stepped setting lets you make an
instantaneous leap in value, useful when you want to flash a
light off and on.

Use the Time and Range slider to play back your animation.

Although the Graph Editor is a popular animation tool, you
can also cut, copy, paste, and delete keys directly in the Time
Slider to edit animation. Select a key position in the Time
Slider, then right-click to select the desired operation from a
pop-up menu.

You may find the following techniques useful when keyframing
your animations:

There are alternative object display modes that quicken the
display of animation in the scene view. When you select
Shading > Bounding Box (from the panel menu in the scene
view), Maya displays simple box-shaped geometry in place of
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the actual objects in your scene. The simpler shapes enables
Maya to respond to any camera and object movement faster.
The drawback is that you cannot edit the shape of the objects
in this display mode.

It is generally a recommended practice to animate a parent
(group) node rather than objects themselves. By animating a
parent node, you can avoid problems that occur when the
animation of one object in a hierarchy conflicts with the
animation in another part of the hierarchy.
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Lesson 2

Set Driven Key

With keyframe animation, you key an attribute value to a time in
the Time Slider. You repeat this process with different values at
different times to animate the object.

When you must animate multiple objects or attributes that
interrelate, setting keyframes can quickly become a complex task.
Set Driven Key is a technique for driving one object’s or attribute’s
animation from another attribute.

With driven keys, you relate an attribute value to the value of
another attribute. You repeat this with different values to create a
dependent link between a pair of attributes. A change in the driver
attribute alters the value of the driven attribute. In this way the
animation of the driven attribute doesn’t need to be manually set;
it occurs automatically once the relationship between attributes
has been established. This makes setting up some types of
animations much more efficient. For example, you can use driven
keys to make a door open when a character walks in front of it.

In this lesson, you will learn how to use Set Driven Key in order
to animate a door rising upwards when a ball approaches it.

il
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In this lesson you learn how to:
*  Link the object attribute behavior between two objects which

will link the movement of one keyframed object to another
with no keyframes assigned.

*  Use the Graph Editor to adjust the animation for the driven
object.
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Lesson setup

In the following steps, you set a playback range that’s long
enough to see the animation clearly. You also create the ball and
the door, and position them in the scene view in preparation for
the animation.

1

a A ODN

Make sure you've done the steps in "Preparing for the
lessons” on page 179.

Create a new scene.
Go to the start frame.
Create a polygonal cube and name it Door.

Scale and position it roughly as shown in the previous figure.
Have the bottom edge of the door lie roughly along the X-axis.

With the pointer in the perspective view, press 5 (for
Shading > Smooth Shade All).

Create a small polygonal sphere and name it Ball. Scale and
position it roughly as shown in the prior figure. Have it sit
roughly at 0, 1, 10 (X, Y, Z).

Use the default color for the door and the ball.

Using Set Driven Key to link attributes

The following steps link the door’s movement to the ball’s
movement using Set Driven Key.

To link the door’'s movement to the ball’s movement

1

Select the door and choose Animate > Set Driven Key >
Set > 0.

The Set Driven Key window appears with the door in the
Driven list.
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Click translateY in
the Driven list.

This is the attribute
to be driven by the
ball’s movement.

Select the ball in the
scene view.

In the Set Driven
Key window, click
the Load Driver
button.

The ball appears in
the Driver list.

In the Set Driven
Key window, click
translateZ in the
Driver list.

This is the attribute
that will drive the
door’s movement.

8e0oe

Load Options

Set Driven Key
Select

Key Help

Driver
‘ Ball iaisibilit',r
translateX

translateZ ')

rotateY

rotateZ -

scaleX

Driven

rotateX

rotateY

rotateZ N

scaleX b 1
” Load Driver ” Load Driven ” Close

| | Key

You can set a driven key only after you select an attribute in
the Driver list and in the Driven list.

In the Set Driven Key window, click Key.

This sets a driven key relationship that links the current
Translate Z value of the ball to the current Translate Y value
of the door. Whenever the ball’s Translate Z is at this position,
the door’s Translate Y will be at its current position.

The Time Slider is not involved in a driven key relationship
and displays no red markers for keys.

Move the ball to the door’s position and then move the door

above the ball.
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8 In the Set Driven Key window, click Key.

This sets another driven key that links the current Translate Z
value of the ball to the Translate Y value of the door.

9 Move the ball to the right of the door and then lower the door
to its previous position as shown in the following figure.

10 In the Set Driven Key window, click Key.
This sets another driven key that links the attributes.

You've set three driven keys that link the attribute values at
different positions. Maya interpolates the linked values to
generate the values between the keys.

If you drag the ball toward the door from either side, the door
rises smoothly.
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Playing back the animation from the Time Slider doesn’t
move the ball or the door. Driven keys link one attribute to
another. They don’t link attributes to times in the Time Slider.
However, if you were to animate the movement of the ball,
the door would move based on the driven key relationship
that has been set.

Viewing the results in the Graph Editor

In the next steps you'll examine the animation curve resulting
from the driven keys you've set. If you are unfamiliar with
animation curves and the Graph Editor, see “Lesson 1:
Keyframing and the Graph Editor” on page 180.

To view the set driven key results in the Graph Editor

1 Select the door. To display the animation curve for a driven
key in the Graph Editor, you must select the object containing
the driven attribute, not the object containing the driving
attribute.

2 Select Window > Animation Editors > Graph Editor.

From the Graph Editor, select View > Frame All. The Graph
Editor shows the driven keys that link the door’s TranslateY
value to the ball’s Translate Z value. An example follows:

I

Ball transkted
4b 1
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The column of numbers on the left lists the driven attribute
values. The row at the bottom lists driver attribute values. The
animation curve shows the relationship between the values—
the door’s Translate Y value rises as the ball’s Translate Z
value approaches 0.

You can use the Graph Editor to edit the shape of the curve to
make the door rise faster, slower, and higher as the ball
approaches it.

Beyond the lesson

In this lesson you learned how to:

Set driven keys to link one attribute’s values to another.

A driven attribute is not directly affected when you play the
animation. It is linked to a driving attribute’s value, not
animation time. However, you can use regular animation
keys, expressions, motion paths, or other techniques to
animate the driving attributes. This indirectly animates the
driven attribute.

You may find the following notes helpful when using Set Driven
Key:

You can set driven keys to control a driven attribute with
multiple driving attributes. For instance, you can have a
muscle bulge when an elbow rotates, and have the bulge
increase when the wrist rotates.
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Lesson 3 Path Animation

Model created by: Ted Charlton

Path animation allows you to animate an object along a path
specified by a curve. In this way, the curve controls the motion of
the object. With keyframe animation, Maya calculates the motion
of the object for the animation based on the positions that were set
at the keyframes. With path animation the motion for the object is
defined by its location along the path curve.

Path animation is useful for animating objects such as trains,
boats, airplanes, and moving cameras whose motion follows a set
path. To animate an object to do this type of motion smoothly
with keyframe animation would require you to laboriously create
and edit many keys for the motion. By having the object move
along a curve, you can easily adjust the object’s path by editing
the curve.

In this lesson, you make an aircraft follow a motion path so it
appears to fly and bank while it changes trajectory. We provide a
scene for your use in the lesson.
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In this lesson, you learn how to:

*  Set an object to animate along a motion path using a NURBS
curve as the path.

*  Modify the timing and rotation of an object along a motion
path.

*  Blend between keyframe and motion path animation.

Open the scene for the lesson
In this lesson, you work with a scene we created for your use.

1 Make sure you've done the steps in “Preparing for the
lessons” on page 179.

2 Open the scene named PathAnim.mb.

You can open the scene named PathAnim.mb from the Maya
Documentation, Lessons, and Extras CD or from the drive where
you copied the Getting Started with Maya data files.

The scene contains two objects named Aircraft and
PathCurve. When the aircraft travels on the path curve it
loops back to where it began.

3 In the Time Slider, set the Playback End Time to 240.
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The path animation occurs between frames 60 and 240 (180 frames
in total). Between frames 1 and 60, you keyframe the aircraft’s
motion so it rises from the ground plane. You then blend between
the two animation types.

Animating an object along a motion path

To animate the aircraft along the path curve, first select the
aircraft and the path curve and then set appropriate options for
the motion path animation. In the options window, you need to
set the required time range for the path animation. You also need
to ensure that the aircraft is oriented facing towards the direction
of travel. The Follow, Front, and Up axis option settings
determine the aircraft’s orientation along the path.

To attach the aircraft to the motion path

1 Set the Time Slider to frame 1.

|1.un | ]

Select the aircraft and then shift-select the path curve.

In the main menu, select Animate > Paths >
Attach to Motion Path > (3.

The Attach to Motion Path Options window appears.

4 In the options window, set the following options and then
click Attach.

* Time Range: Start/End
e Start Time: 60
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* End Time: 240

* Follow: On

* Front Axis: X

e UpAxis: Y

*  World Up Type: Scene Up
* Leave all other settings off

i} Attach to Motion Path Options M= E3
Edit Help

Time Range € Time Slider " Start o :Start.-"

Start Timne IBD.DDDD
End Time |24D.DDDD

Parametric Length
Follow [

Front &siz % 3 T
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™ Inverse Up
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Bank Scale [1.0000 — |

Aftach | Apply | Cloze |
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The aircraft is repositioned to the start of the curve, and
oriented towards the direction of travel.
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The Start and End Times set the time duration the aircraft
travels along the path curve (240 - 60 = 180 frames). The start
and end times are displayed at the ends of the curve.

5 Click play on the Timeslider playback controls to play back
the animation.

The aircraft travels along the path. Observe that it begin its
motion at frame 60.

Changing the timing of an object along a
motion path

When you first assign an object to a motion path, by default, the
object travels along the path at a constant speed. In this lesson,
you want the aircraft to initially travel along the path slowly,
accelerate, and then finally move more slowly when it nears the
end of the motion path.

You can change the rate of travel for the aircraft by keyframing
attributes that affect where the aircraft is positioned on the curve
at a given time.

To view the attributes for the motion path

1 Set the Time Slider to frame 1.
2 Select the aircraft.
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3 Open the Channel Box by clicking the Show/Hide Channel
Box icon on the Status Line.

B 6 38 | o E A E)

4 In the Channel Box, click on the word motionPath1 that
appears in the Aircraft’s Inputs list.

The attributes for motionPath1 appear at the bottom of the
Inputs list. (Scroll the Channel Box window if the
MotionPath1 attributes are not fully visible)

INPUTS

upTwist O
sideTwist 0 LI

The Uvalue attribute controls where the aircraft gets positioned
along the curve. The Uvalue refers to the curves parameterization.
Parameterization is a method used by Maya to divide a curve into
increments of known amounts so that a location along the curve
can be determined.

Uvalue 0 05 1.0
Frame 60 150 240

By default, the parameterization of a path curve is set between
zero and one. At frame 60, the aircraft is at the beginning of the
curve where the parameterization value is zero. When the aircraft
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is at the end of the curve (frame 240) the parameterization value
for the curve is one. When the aircraft is halfway through the path
animation (frame 150), it is located along the curve at a Uvalue of
0.5.

By setting the frame number and Uvalue and then setting a key,
you change the timing for the aircraft’s motion along the path.

To change the timing for the aircraft along the path

1 Ensure the aircraft is selected so its attributes display in the
Channel Box.

2 In the Time Slider, drag the current time indicator to frame
120 using the middle mouse button.

Middle-dragging the current time indicator, instead of using
the left mouse button, changes the current time without
repositioning the aircraft along the path.

3 In the Channel Box, set the Uvalue for MotionPathl1 to 0.1.

The aircraft is repositioned along the curve near the first bend.
When you set the Uvalue to 0.1, the aircraft is positioned at a
point that is a distance of 10 percent from the beginning of the
curve (that is, the aircraft has completed 10 percent of the
distance along the path).

4 In the Channel Box, select the Uvalue channel by clicking on

its name so it becomes highlighted.
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upTwist O
sideTwist 0

5 Right-click on the selected name.
A drop-down list appears.
6 From the drop-down list, choose Key Selected.

A position marker appears on the path curve indicating that a
key frame has been set. The position marker is useful for
determining where the aircraft is at a given time. Position
markers do not appear when you render the animation. Using
Key Selected ensures that a keyframe is set only for the item
selected and nothing else.

7 In the Time Slider, middle-drag the current time indicator to
frame 180.

8 In the Channel Box, set the Uvalue for MotionPath1 to 0.9.

The aircraft is repositioned along the curve near the last bend.
When you set the Uvalue to 0.9, the aircraft is positioned at a
point that is a distance of 90 percent from the beginning of the
curve. (that is, the aircraft has completed 90 percent of the
distance along the path)

9 In the Channel Box, select the Uvalue channel by clicking on
its name so it becomes highlighted.

10 Right-click on the selected name and choose Key Selected.
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A position marker appears on the path curve.

11 Click play on the Time Slider’s playback control to play back
the animation.

The motion of the aircraft is not smooth as it travels along the
path. It initially moves forwards and backwards a bit at the
beginning and end of the path. This indicates that some
adjustment of the animation is required. You adjust the
animation using the Graph Editor.

To view the Graph Editor

1 From the main menu, select Windows > Animation Editors >
Graph Editor.

The Graph Editor appears.
2 In the Graph Editor, select View > Frame AlL

The Graph Editor updates to display the animation curve for
the motion path animation.
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The shape of the animation curve provides some clues as to why
the motion of the aircraft is not smooth. Between frames 60 and 84
the curve rises and then drops slightly. Because the animation
curve represents translation along the curve, a drop in the curve
indicates that the object travels backwards. A similar occurrence
happens at the end of the curve as well. To correct this, you need
to modify the tangents for the keys in the Graph Editor.

To edit the tangents for the keys in the Graph Editor

1 In the Graph Editor, press the shift key, then double click on
the animation curve to select the four keys (frames 60, 120, 180
& 240)

2 In the Graph Editor menu, select Tangents > Linear.

The animation curve updates so that the keys connect via
straight lines. This eliminates the dips in the curve that caused
the aircraft to travel backwards.

Next, you modify the tangents for keys 120 and 180 so the aircraft
accelerates and decelerates near those points on the path curve.

3 In the Graph Editor, shift-select only the two keys for frames
120 and 180.
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10

11
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In the Graph Editor menu, select Keys > Break Tangents.

Breaking the tangent for the keys allows you to modify the
shape of the curve as it enters or leaves a key.

Select only the key for frame 120.

A pair of tangent handles appear on either side of the key.
The handles let you edit the curvature of the animation curve
near the key point.

Select the tangent handle to the right of the key.
The handle highlights in a yellow color.
From the Toolbox, select the move tool.

Using the middle mouse button, drag the handle so the curve
has a gentle curvature as it leaves the key as shown below.

Modifying the tangent in this manner changes how the
motion transitions as the curve changes direction as it passes
through the key. The aircraft will accelerate smoothly instead
of immediately travelling at a different rate of speed.

Before Modification After Modification

Select the key for frame 180.
Select the handle to the left of the key.
The handle highlights in blue.

Using the middle mouse button, drag the handle so the curve
has a gentle curvature as it enters the key as shown below.

Modifying this tangent for this key will cause the aircraft to
decelerate smoothly near the end of its travel.
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Before Modification After Modification

The modified animation curve appears as shown below.

12 Close the Graph Editor.

13 Click play on the Time Slider’s playback control to play back
the animation.

The backwards and forwards motion that previously occurred
is corrected. The aircraft travels slowly towards the first bend
in the path curve, then accelerates and travels at a constant
speed around the curve until it nears the end of the path
where it decelerates and then slowly moves towards the end
of the curve.
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Rotating an object along a motion path

As the aircraft travels along the motion path, its orientation
remains the same throughout the animation. A real aircraft rolls to
one side (banks) as it flies in an arc. To make the aircraft roll to
one side as it travels along the path you set keyframes for the
Twist attributes in the Channel Box.

To animate the roll of the aircraft along the path

1
2
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Ensure the aircraft is selected.
Set the Time Slider to frame 120.
The aircraft is repositioned along the curve near the first bend.

In the Inputs section of the Channel Box, click on motionPath1
to view its attributes.

Ensure the FrontTwist value for motionPath1 is set to 0.
In the Channel Box, select the FrontTwist channel by clicking
on its name.

INFUTS
layer_scoutCommander
motionPathl

sideTwist 0

Right-click on the selected name.
A drop-down list appears.
From the drop-down list, choose Key Selected.

To set the remaining keyframes for the rotation of the aircraft,
use the table below as a guide, keeping in mind that you set
the keyframes in the following order:

¢ Set the frame in the Timeslider

e Set the values for FrontTwist in the Channel Box.
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*  Select the FrontTwist channel by clicking its name. Right-
click on the selected name and choose Key Selected.

Frame | Select | Setchannel attribute | Choose

130 Aircraft | FrontTwist: -15 key selected
135 Aircraft | FrontTwist: -45 key selected
150 Aircraft | FrontTwist: -70 key selected
165 Aircraft | FrontTwist: -45 key selected
170 Aircraft | FrontTwist: -15 key selected
180 Aircraft | FrontTwist: 0 key selected

9 Click play on the Time Slider playback controls to play back
the animation.

The aircraft rolls to one side (banks) as it travels along the

motion path.
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Blending keyframe and motion path
animation

Blending between motion path and keyframe animation types is
possible in Maya. Blending between the two animation types
allows you to take advantage of the characteristics each animation
type can provide without having to expend a lot of effort in
determining where the change between the two types must occur.

In the steps that follow, you keyframe the aircraft to rise vertically
from the floor surface and then travel along the motion path by
blending between the two animation types. To accomplish this,
you do the following;:

*  Move the motion path up above the ground plane.

e Keyframe the aircraft so it rises vertically above the ground
plane.

*  Blend between the keyframe and motion path animations.

To move the motion path

1 In the scene view, select only the path curve.
2 In the Channel Box, set Translate Y to 5 for PathCurve.

The path curve is repositioned above the ground plane in the
scene view. The aircraft moves with the path curve because it
is attached to the motion path.
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To keyframe the motion for the aircraft

1 Select only the aircraft.
2 Set the Timeslider to frame 1.
3 In the Channel Box, set the following for the aircraft:
* Translate Y: 0
The aircraft is repositioned so it rests on the ground plane.

4 Select the Translate X, Y, and Z channels as well as the Rotate
X, Y, and Z channels by click-dragging on their names so they
become highlighted.

scaler’ 1

5 Right-click on any of the highlighted names, and choose Key
Selected from the drop down list that appears.

Keys are set for the selected channels. Keyframing these
channels establishes a blending connection that will be
discussed in subsequent steps.

6 In the Channel Box, set the following:
* RotateY: -90

The aircraft is rotated 90 degrees from its motion path
position.

7 Select the Rotate Y channel by clicking on its name so it
becomes highlighted.

8 Right-click on the name, and choose Key Selected from the
drop down list that appears.

A keyframe is set for the aircraft.
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Additional channels have appeared in the Channel Box. When a
keyframe is set for an object that already has motion path
animation, the software automatically creates a connection to
blend between the two animation types. These new channels are
used to control the blend between the keyframe and motion path
animation types. They control the blend for the Translation and
Rotation attributes.

Aircraft

translate -0.008

translate’ 0

translates -0.608
rataterd 180
ratate’’ -0
rotates 179983
scale 1
scaler 1
scales 1
wigibility on
portFw 3

starboardPw 3

portRw 5

blendddD oublelinear] 0
blendtationPathl 0

AircraftShape
INFUTS

panBlendl
panBlend2

9 To set the remaining keyframes for the keyframe motion of
the aircraft, use the table below as a guide, keeping in mind
that you set the keyframes in the following order:

¢ Set the frame in the Time Slider.

¢ Set the Translate and Rotate values in the Channel Box.

*  Select only the channels for those values. Right-click on
the selected name and choose Key Selected.
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Frame | Select Set channel attribute | Choose

20 Aircraft Translate Y: 1 key selected
30 Aircraft Translate Y: 2 key selected
30 Aircraft Rotate Z: 170 key selected
40 Aircraft Translate Y: 3 key selected
40 Aircraft Rotate Z: 170 key selected

10 Click play on the Timeslider playback controls to play back
the animation.

The aircraft rises above the ground plane and then stops at
frame 40.

The animation stops because the motion path animation was shut
off when the blend attribute was automatically created when you
set the first keyframe. The blend attribute values are set to zero by
default. When the blend values are set to zero, the keyframe
animation has full influence on the object, and the path animation
is shut off. When the blend values are set to one, the motion path
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has full influence on the object and the keyframing is shut off.
When the blend values are between zero and one, the aircraft’s
motion is blended between the keyframe and motion path
animation.

In the next steps, you keyframe the blending attributes so the
blending begins at frame 30 and ends at frame 70. This blends the
two animation types together over a period of 40 frames.

To blend between the two animation types

1
2
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Set the Timeslider to frame 30.

In the Channel Box, ensure the blend values are set as follows:
* blendAddDoubleLinear: 0

*  blendMotionPath: 0

Select the blend AddDoubleLinear1 and blendMotionPath1
channels by click-dragging on their names so they become
highlighted.

portRw 5

Right-click on one of the names, and choose Key Selected from
the drop down list that appears.

A key is set for the blend starting point for the aircraft. At
frame 30 the two animation types will begin to blend together.

Set the Timeslider to frame 70.

In the Channel Box, set the following:
*  blendAddDoubleLinearl: 1

*  blendMotionPathl: 1

Right-click on one of the names, and choose Key Selected from
the drop down list that appears.



6 | Animation
Lesson 3 > Blending keyframe and motion path animation

portFw 5

A key is set for the blend ending point for the aircraft. At
frame 70 the motion path animation will have full influence.

8 Click play on the Timeslider playback controls to play back
the animation.

The two animation types are combined but the motion does
not appear correct. The aircraft rotation flips upward
momentarily when it begins to travel along the motion path.

The interpolation type for the rotations during the blending is
not set correctly.

Setting the pairBlend rotInterpolation setting to Quaternions
changes how the rotations are interpolated during the blend. In
this example, Quaternions provides a better interpolation type
when blending between the keyframe and motion path animation.
For more information see quaternion rotation in the Maya Help.

To edit the rotation interpolation type for blending

1 In the Channel Box, click on the pairBlend1 channel.
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Scroll the Channel Box so you can view the Attributes for
pairBlend1.

Set the Rot_Interpolation setting to Quaternions by clicking on
the Euler angles name with the left mouse button.

INFUTS
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painBlend2

motionPathl
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translatexbode Blend Inputs
tranzlatetode Blend Inputs
tranzlatestode Blend Inputs

Hrterpalation | Euler angle
Qo)
Click on the pairBlend2 channel.

Click on the Euler angles name in the Rot_Interpolation
attribute and choose Quaternions.

Click play on the Timeslider playback controls to play back
the animation.

The animation plays back smoothly. Observe how the
blending also takes into account the rotation of the aircraft so
it meets up with the motion path smoothly.

Using Playblast to playback an animation

Playblast allows you to preview an animation by calculating the
separate frames and playing them back in a multimedia player
window based on the Playblast options. Playblast provides a more
accurately timed playback than using the Timeslider.

To playback the animation using Playblast

1

2
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Select the path curve, and then select Display > Hide > Hide
Selection to hide the curve while you Playblast.

Select Window > Playblast.
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Playblast calculates the frames for the animation and then
plays them back in the player window.

You have completed this lesson.

Beyond the lesson

In this lesson you learned how to:

Create a motion path animation using a NURBS curve as the
motion path.

When you draw your own curves remember that a curve has
a defined start and an end point based on how you create it. If
your object is initially positioned at the wrong end of the
curve, you can reverse the direction of the curve by setting the
Menu Set to Modeling and then selecting Edit Curves >
Reverse Curve Direction.

If your objects are not oriented correctly on the path initially,
you can change the options in the Attach to Motion Path
Options window. See Animate > Motion Path >

Attach to Motion Path in the Maya Help.

Adjust the timing and rotation of an object when it travels
along the motion path.

In this lesson you were shown how to keyframe the roll
(bank) of the aircraft. The Attach to Motion Path Options
window provides an option called Bank. The Bank option
rotates an object as it travels around curved portions of a
motion path. It is useful for simple motion path animation.

Blend between keyframe and motion path animation types on
the same object.

For more information on how this works, see pairBlend in the
Maya Help.
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Lesson 4 Nonlinear Animation with Trax
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Nonlinear animation allows you to create and edit an animation
sequence by arranging smaller animation sequences (known as
clips) on a timeline. A clip is a time-independent sequence of
animation that you create from an existing animation (keyframe
animation, expressions, constraints, and motion capture data -
except motion path animation).

Nonlinear animation tools in Maya give you the ability to
experiment with your animation sequences and character
animations without having to redo all of your work when you
want to modify or construct a different animation.

Nonlinear animation is a non-destructive process. You can modify
a particular clip’s attributes without affecting the source
animation: the source material remains untouched. This makes
nonlinear animation useful when you want to experiment, iterate,
or change a particular animation sequence.
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The primary tool for working with nonlinear animation is the
Trax Editor. You can also store your clips for future use by
creating a library of clips.

In this lesson you learn how to:

Key animation sequences for use as nonlinear clips in Trax.

Create clips from your animation sequences for use in the
Trax Editor.

Use the Trax editor to position, modify, and arrange clips in
order to create and modify animation sequences in the scene.

Scale clips to modify the timing of an animation sequence.
Trim clips to remove unwanted motion.

Cycle clips to create motion that repeats.

Use the Graph Editor to modify the animation of a clip.
Use the Trax Editor to work with motion capture data.

Reuse clips using the Outliner and the Visor.

Open the first scene for the lesson

This lesson is presented in two parts. You work with two separate
scene files we’ve created for your use. In the first part of this
lesson, you learn some of the fundamental techniques for working
with clips in the Trax Editor by animating an aircraft taking off
and landing.

1

Make sure you've done the steps in "Preparing for the
lessons” on page 179.

Open the scene named Trax Lessonl.mb.

You can open the scene named Trax Lessonl.mb from the
Maya Documentation, Lessons, and Extras CD or from the drive
where you copied the Getting Started files.
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The scene contains a model of an aircraft. For the first part of
this lesson, you create and work with animation clips to
control the motion of the aircraft.

3 In the Time Slider, set the Playback range as follows:
* Playback Start Time: 1
* Playback End Time: 240
To work more efficiently with the scene and the Trax Editor, you
need to set a panel layout.
To set a panel layout for use with the Trax Editor

1 From the perspective view’s menu, select Panels >
Saved Layouts > Persp/Trax/Outliner.
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Outliner Trax Editor

The panel layout updates to display the Perspective view,
Outliner, and Trax Editor simultaneously. This allows you to
easily work with these windows without having to open and
close them repeatedly.

Next, set the Outliner so it displays clips. The Outliner allows you
to manage the various clips that get created with Trax.

To set the Outliner to display clips

1 In the Outliner menu, select Display > DAG Objects Only to
uncheck the DAG option.

2 In the Outliner menu, select Show > Objects > Clips.
The Outliner displays an empty list until you create your first
clip.

Creating clips with Trax

A clip is a time-independent sequence of animation data for one
or more animated attributes that you create from existing
animation (keyframe animation, expressions, constraints, motion
capture data, and so on). A clip is time independent, allowing you
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to position, scale, and cycle a clip independently of other
animatable attributes or other clips. This means you can arrange
the clips into a particular sequence, and then play it back to see
the results. You can adjust the timing, length, and rearrange or
edit the same clips in a different order to modify the motion
sequence.

Most commonly-used clips are reusable sequences of animation
that are easy to sequence or blend with other clips. For example,
suppose you create three clips: a karate punch, tumble, and kick.
You can run the clips in any order, and you can repeat clips or
blend the motion between them. You can scale or cycle clips to
alter the time frame over which the animation occurs. You can
either return the clip to its original state or reload a duplicate of
the original source clip and begin again. In this way, the Trax
Editor allows you to experiment with animation sequences on a
character.

In the steps that follow, you key some animation for the aircraft
and then create clips from the keyed animation for use in the Trax
Editor.

To create keyframe animation for the aircraft

1 From the perspective view’s panel menu, select Panels >
Orthographic > front.

The panel updates to display the aircraft’s side from the front
view.

In the front view, click on the aircraft to select it.
In the Channel Box, set the following;:
e Translate X: -25

The aircraft is repositioned at -25 along the X axis. The aircraft
disappears from the front view because it has been
repositioned outside of the viewing area.

Getting Started with Maya
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4 Dolly and track the front view until the aircraft appears on the
lower left hand side of the front view as shown below.

5 Press s to set a keyframe.

In the Channel Box, the channels display in a different color.
The color change indicates that the channels now have
animation applied to them.

Note If you normally use the Auto Keyframe function, you
must shut it off for this lesson. For more information see
Auto Key in the Maya Help.

6 In the Time Slider, set the current time indicator to frame 240.
7 In the Channel Box, set the following:
e Translate X: 25

The aircraft is repositioned at 25 along the X axis (the right
hand side of the current front view).

8 In the Channel Box, select the Translate X channel by clicking
on the name.

The Translate X name becomes highlighted.
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Aircraft -
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Tranzlate ¥ 0

Trakslate 2 0
Rotate» O

9 Right-click on the selected name and choose Key Selected
from the drop-down list that appears.

Key Selected sets a keyframe for only the selected attribute.

Confirm that the animation sequence works as expected in the
steps that follow.

To playback the animation using the playback controls

1 Click play on the Time Slider’s playback control to play back
the animation.

ERIRIE O JLED

The aircraft travels from left to right in the front view.

2 Click stop on the Time Slider’s playback control.

Now that you have keyframed an animation sequence and
confirmed that it works, you can create an animation clip.

To create an animation clip of the keyframe animation

1 In the Trax Editor menu, with the aircraft still selected, select
Create > Clip > 0.
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In the Create Clip Options window, select Edit >
Reset Settings, and then click on the Create Clip button.

The Outliner updates and lists two items: clipl and
cliplSource. If the clips do not display refer to “To set the
Outliner to display clips” on page 231

Display Show Panels
(Tl
]

clipl
cliplSource

When you created the clip, two clips were generated: a reqular
clip and a source clip. The source clip contains the animation
curves for the character (based on the keyed attributes that the
clip was created from). The source clip is stored with the file
and can only be accessed from the Visor or Outliner. Maya
saves the source clip outside of the Trax Editor to protect the
original animation curves from being accidentally modified
and ensures you have an unmodified clip to revert back to.

A regular clip (referred to simply as a clip) contains the same
information as the source clip, and is placed in a track in the
Trax timeline. It is this regular clip that you work with and
modify in Trax.

A clip does not yet appear in the track area of Trax Editor
because the character set associated with the clip (the aircraft)
has not been loaded to display.

In the Trax menu, with the aircraft selected, click the Load
Selected Characters icon.

SR =[EHL-Y @) Eebeh E &
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4

The clip appears as a blue rectangular box in a track in the
Trax Editor. A track is an area in the Trax Editor to place and
work with one or more non-overlapping clips in relation to
the animation timeline. Tracks allow you to work with your
clips in a nonlinear manner by allowing you to reposition and
scale clips in time or juxtapose them with other clips. You can
work with multiple tracks in the Trax Editor.

File Edit Yiew Modify Create Lbrary List Panels I

e B e £

= =
1 239 240
clip1
1 1 00% 240
]
Track

&l ] =2l

|
Clip
In the Trax menu, select View > Frame All.
The Trax Editor updates to show the beginning and end point
for all of the items displayed in the Trax Editor. (In this case
the new clip.) The clip represents the Translate X animation

for the aircraft going from -25 to 25, for a time range of 1 to
240 frames.

Anatomy of a clip

Every clip contains interaction controls that relate to information

about the clip:
Sour(,;e In Dura|1tion Sour(,;e Out
1 2I_ée: 240
1 ,—1%3% 240
l
Framle In Scale Clip Name Framtle Out
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Frame In and Frame Out indicates the current start and end
frame numbers for the clip in relation to its position on the
timeline.

Source In and Source Out indicates the range of frames from
the original source clip.
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Duration indicates the length (duration) of the original source
clip in frames.

Clip Name...the name of the clip. A default clip name is
assigned to the clip, unless you specify it from the Create Clip
Options window when you first create the clip.

Scale indicates the scale percentage for the clip. The scale
percentage is the multiplier on the length of the original clip.
For example, if you scale a clip fifty percent longer than its
original length, the scale value would read 150%.

Each area on the clip has a hot spot which you can either double-
click on for numeric values, and in some cases, click-drag to
modify the related attribute. For example, you can double-click on
the hot spot for the clip name to edit the name. For more
information about clips and tracks, see Track view area in the Maya
Help.

To edit the name of the clip in the Trax Editor

1

In the Trax Editor, double-click on the clip1l name on the clip.

The clip highlights in yellow to indicate it is selected and the
clipl name becomes highlighted.

Type Travel_Forward and then press Enter.

The clip is renamed to Travel_Forward. The clip and the
source clip’s name are updated in the Outliner to reflect the
change.

Display  Show Panels

1
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Travel Forward
Travel_ForwardSource
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If you play this clip in Trax, the animation is played back from the
clip data, not the keyframe data that you set previously in the
scene. When you created the clip, the source of the animation for
the aircraft was changed to come from the clip instead of the
keyframes.

When you create a clip, Maya creates a character set to contain the
clip. A character set is the parent of the hierarchy of clips and
tracks for a particular animated object. A clip’s animation resides
under the character set node and additional clips are placed under
that node unless you specify otherwise.

For more information see Nonlinear animation components in Trax in
the Maya Help.

Now that you have created your first animation clip and renamed
it using the Trax Editor, you need to create a few more clips by
setting additional keys and creating clips of the sequences. You
need to create separate clips of the aircraft taking off and landing.

To create an animation clip of the aircraft taking off

1 In the scene view, select the aircraft.
2 In the Channel Box, set the following:
e Translate Y: 0

3 In the Channel Box, select the Translate Y name so it becomes
highlighted.

Rotate s 0

4 Right-click on the name and choose Key Selected to set a
keyframe for this position.

Key Selected sets a keyframe for only the selected attribute.
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In the Time Slider, drag the current time indicator to frame 60.

In the Channel Box, set the following:

e Translate Y: 7.0

In the Channel Box, select the Translate Y name so it becomes

highlighted.

Aircraft

| v

Translate » -12.657

Translate ' I

Translate 2 0
Rotate s 0

Right-click on the name and choose Key Selected to set a
keyframe for this position.

In the Trax Editor menu, with the aircraft selected, select
Create > Clip (or click the Create Clip icon on the Toolbar)

OBl

ERIEER TS

The Trax Editor updates to create an additional track and
places the new clip on the new track. The Outliner updates to
list the new clip and source clip.

&l | 2]

In the Trax Editor, double-click on the new clip and rename it
to Aircraft_Rise.

240
230 240
Travel_ Forward
100% 240

1

al S

1

Click play on the Time Slider’s playback control to play back

the animation.
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12

To

Getting Started with Maya
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The aircraft rises as it travels forward.

Click stop on the Time Slider’s playback control.

create an animation clip of the aircraft landing

In the Timeslider, set the current time indicator to frame 180.

In the Channel Box, with the aircraft still selected, set
Translate Y to 7.

In the Channel Box, select the Translate Y name so it becomes
highlighted.

Right-click on the name and choose Key Selected to set a
keyframe for this position.

In the Time Slider, set the current time indicator to frame 240.
In the Channel Box, set the Translate Y to 0.

In the Channel Box, select the Translate Y name so it becomes
highlighted.

Right-click on the name and choose Key Selected to set a
keyframe for this position.

Click play on the Time Slider playback controls to play back
the animation.
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The aircraft travels forward and then lands as it nears the end
of its travel.

10 Click stop on the Time Slider’s playback control.

11 In the Trax Editor menu, with the aircraft selected, select
Create > Clip.

The Trax Editor and Outliner update to show the new clip.

12 In the Trax Editor, double-click on the new clip and rename it
to Aircraft_Lower.

180 B0 240
Aircraft_Lower ’

180 100% 240

Changing the position of clips with Trax

It's easy to alter the start time of clips to synchronize the action
between clips. For example, the aircraft rises as it travels forward
because the Travel_Forward and Aircraft_Rise clips overlap in
time. If you position the clips on their respective tracks so that one
clip’s action occurs in the Trax timeline before or after the other,
the motion occurs separately.

In this section, you learn how to reposition the clips so that the
aircraft takes off before it travels forward in X, and then have the
aircraft land at the end of the sequence.
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To change the position of a clip in a track

1 In the Trax Editor, move the mouse cursor over top of the
Travel Forward clip.

When the mouse cursor is over top of a clip in the Trax Editor,
the cursor icon changes to a pointer indicating that you can
drag the clip to either side or up and down between tracks.

@

Move Cursor

2 (Click-drag the Travel_Forward clip horizontally to the right in
its track until the Frame In reads 60 as shown below.

239
_> Travel_Forward
100%

3 C(lick play on the Time Slider playback controls to play back
the animation.

The aircraft takes off vertically, then travels to the right, and
lands while it is still travelling to the right. Because the two
clips (Travel_Forward and Aircraft_Rise) are positioned one
after the other, the actions occur in a series versus
simultaneously.

4  Click stop on the Time Slider’s playback control.

Getting Started with Maya
242



5

6 | Animation
Lesson 4 > Changing the position of clips with Trax

Click-drag the Aircraft_Lower clip horizontally to the right
until the beginning of the clip matches the end of the
Travel_Forward clip on the track above it. (Frame In = 240)

If the view of the clips appears limited, select View >
Frame All in the Trax Editor to resize the view to encompass
the clips.

You also need to modify the Playback End Time because the
animation timeline is longer as a result of repositioning the clips.

6

7

In the Time Slider, edit the Playback range as follows:
* Playback End Time: 360

Click play on the Time Slider playback controls to play back
the animation.

8

The aircraft takes off vertically, then travels to the right, and
then lands vertically once the Travel_Forward clip’s motion is
complete. Because the three clips are positioned end to end in
relation to the timeline, the animation occur as a series of
separate events.

Click stop on the Time Slider’s playback control.
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Editing the animation of clips

You can modify the animation of a clip using the Graph Editor in
the same way that you would modify any other type of
animation. Because you are working with the clip, and not the
original animation, you won’t change the original source clip
animation.

In this section, you use the Graph Editor to modify the animation
for each clip so the aircraft’s motion accelerates and decelerates at
the beginning and end of each clip.

To use the Graph Editor to modify a clip in Trax

1

Click on the Aircraft_Rise clip to select it.

The selected clip highlights in yellow.

From the Trax menu, select View > Graph Anim Curves.
The Graph Editor appears.

In the Graph Editor, shift-select the two keys on the animation
curve as shown below.

In the Graph Editor, select Tangents > Flat.
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The shape of the animation curve updates to a gentle S-shape.
Setting the tangents for the animation curve in this manner
modifies the clip’s animation to cause the aircraft to accelerate
when it first rises, and decelerate when it nears the end of its
vertical travel.

Repeat steps 1 through 4 to set the animation curve tangents
in a similar manner for the two remaining clips:
Travel Forward and Aircraft Lower.

The shape of the animation curve for Aircraft Lower will be
reversed from the other clip curves because the motion is
occurring in the opposite direction.

Close the Graph Editor window.
Set the Time Slider’s current time indicator to frame 1.

Click play on the Time Slider’s playback control to play back
the animation.

The motion accelerates and decelerates at the beginning and
end of each clip. As a result, the motion appears more natural.
It’s important to note that the modified tangents for each clip
are independent from the other animation clips and do not
affect any other motion.

Click stop on the Time Slider’s playback control.

Reusing clips within Trax

You can save and reuse clips for future use. You can key specific
types of motion or attribute effects, save them as clips, and reuse
the clips for other characters.

When you reuse a clip created for one character and apply it to
another, the clip attributes must be mapped to correspond
between the two characters. For more information see What is
Character Mapping? in the Maya Help.
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In this lesson, you work with clips created for this aircraft
animation. The clips contain animation to make the aircraft shift
to the left and right and bank left and right.

To load a clip from disk

1

From the Trax menu, select File > Import Clip.

The File Browser appears. When importing a clip, the File
Browser defaults to the clip directory of your current project.

You can open the clip Bank Left.ma from the Maya
Documentation, Lessons, and Extras CD or from the drive where
you copied the Getting Started files. The file will be found in
the clip sub-directory.

Select the file named Bank_Left.ma and click the Import
button.

The clip is imported and appears in the Outliner named as
Bank_ LeftSource to indicate it is a source clip.

Repeat steps 1 and 2 to import the clips Bank_Right, Shift_Left
and Shift_Right.

When you have finished, four new clips appear in the
Outliner as source clips. In the steps that follow, you place
and position the clips on tracks in the Trax Editor.

Note When you import clips they also appear in, and can be

accessed from, the Visor (Window > General Editors >
Visor). The Visor is a graphical interface that allows you
to import items that reside on disk or in your current file
(files, textures, clips poses, etc.). Clips that are assigned
to a character in Trax will appear listed under the
Character Clips tab in the Visor. Clips that have not yet
been placed on a track will appear listed in the Visor
under the Unused Clips tab.
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To place clips into a track from the Outliner

1

In the Outliner, drag the clip named Bank_LeftSource into the
same track as the Rise and Lower clips using the middle
mouse button. Ensure you drag into an open area on the track
that the clip will fit into.

Display Show  Panels
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2 Position the Bank_Left clip on the track so its Frame In
number matches the Frame Out number on the Aircraft_Rise
clip, as shown below.

Drag the clip named Bank_RightSource from the Outliner into
the same track as the Rise and Lower clips using the middle
mouse button. Ensure you drag into an open area on the track
that the clip will fit into.

Position the Bank_Right clip on the track so its Frame In
number matches the Frame Out number on the Bank_Left clip,
as shown below.

1 59 B0
Bank_Right
120 178
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You can also drag clips from the Outliner or Visor into the Trax
Editor and create a new track for them to be placed in.

5 Drag the clip named Shift_Left1Source from the Outliner
using the middle mouse button, but this time, drag to the
narrow blue area above the tracks before releasing your
middle mouse button.

Display Show Panels
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Shift_RightSource
Bank_Left
Bank_LeftSourcel —I
Bank_Right
Bank_RightSource

A new track appears in the Trax Editor and the clip is placed
on the new track.

The narrow blue box is the summary track for the character set
(in this case the Aircraft) The summary track represents all of
the clips under a character, subcharacter, or group. When you
import a clip onto the summary area by dragging it from the
Outliner or Visor, the Trax Editor creates a new track for the
clip.

6 Click-drag the Shift_Left clip so it lies directly below the
Bank_Left clip on the track above it.
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Because the Shift_Left clip is positioned directly below the
Bank_Left clip, the actions will occur simultaneously when
the animation is played back.

7 Drag the clip named Shift_RightlSource from the Outliner
into the same track as the Shift_Left clip using the middle
mouse button. Ensure you drag into an open area on the track.

8 Position the Shift_Right clip on the track so its Frame In
number matches the Frame Out number on the Shift_Left clip,
as shown below.

9 In the front view menu, select Panels > Perspective > persp.

The view updates to display the aircraft from a perspective
view.

10 Dolly and track the view so you can fully see the area the
aircraft will travel within.

11 Click play on the Time Slider’s playback control to play back
the animation.
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After the aircraft rises, it travels forwards as before but now it
shifts sideways to the left while one wing tips downwards,
and then shifts sideways to the right, while the opposite wing
tips downwards.

12 Click stop on the Time Slider’s playback control.

Soloing and muting tracks

Soloing a track allows you to see a track play back in isolation
from other tracks. When a track is soloed, the other tracks are
disabled and do not play back. Soloing is useful when you want
to review the effect a specific track will have on a character.

To solo a track
1 In the Trax control area, click the Solo button for the track that
contains the Aircraft Rise and Bank_Left clips.

The other tracks dim to indicate that they will be disabled
when the animation is played back.

180 B0 240

PAircraft_Lower

293

Solo button
2 C(lick play on the Time Slider’s playback control to play back
the animation.

The aircraft rises, tilts left and right, and then lowers, without
moving forward. Because the other tracks have been shut off
temporarily, the aircraft’s motion is controlled by only one
track.

3 Click stop on the Time Slider’s playback control.
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4 Click the Solo button again to enable all the tracks.

The dimmed tracks become active again.

Muting a track disables only the selected track so it does not play
back. Muting is useful when you want to review the animation on
one or more tracks together without specific tracks being
activated. You can mute one or more tracks.

To mute a track

1 In the Trax control area, click the Mute button for the track
that contains the Shift_Left and Shift_Right clips.

The muted track dims to indicate it is disabled.

1 239 240
Trawel_Fonward
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PAircraft_Lower
3

Mute button

2 C(lick play on the Time Slider’s playback control to play back
the animation.

The aircraft rises and tilts left and right as it travels forward,
and then lowers. Because the Shift_Left and Shift Right track
is temporarily muted, only the two remaining tracks affect the
animation playback.

3 Click stop on the Time Slider’s playback control.

Unmute the track by clicking its mute button before
proceeding to the next section.
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Scaling clips within Trax

You can scale single or multiple clips within the Trax Editor.
Scaling a clip either compresses or expands the animation of a clip
so it occurs over a shorter or longer period of time. The resulting
animation occurs faster or slower as a result.

In the next steps, you select the four clips you imported to Trax,
and scale them together so they occur over the same time frame as
the Travel_Forward clip.

To scale multiple clips in the Trax Editor

1 In the Trax Editor, shift-click on the clips: Bank_Left,
Bank_Right, Shift_Leftl, and Shift Rightl.

The clip Manipulator appears. The clip manipulator appears as
a white box that encompasses the four clips with handles
(triangles) on either end and a circle handle in the center. The
clip manipulator allows you to move or scale multiple clips.

2 Using the clip manipulator, click-drag the right-hand scale
handle to the right until the Frame Out numbers on the
Bank_Right and Shift_Right clips match the Travel_Forward
clip (Frame 299).
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3 C(lick play on the Time Slider playback controls to play back
the animation.
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When the aircraft travels, the sideways and banking motions
occur over the entire length of the Travel_Forward clip.

4  Click the stop button on the playback controls to stop the
playback.

This completes the first half of the Trax lesson. In the second half
of this lesson you work with motion capture data in Trax.

Open the second scene for the lesson

In this second half of this lesson, you work with a second scene
file that contains motion capture data applied to a skeleton.

Motion capture data is produced by capturing the movement of a
real human or animal and digitizing it so it can be applied to a 3D
animation character. Motion capture data contains keyframe
animation. Motion capture data is useful because it can capture
the subtle nuances of motion and gesture that make a character’s
actions appear life-like. Motion capture data can substantially
reduce the work related to posing and keyframing your
characters.

1 Open the scene named Trax_Lesson2.mb.

You can open the scene named Trax Lesson2.mb from the
Maya Documentation, Lessons, and Extras CD or from the drive
where you copied the Getting Started files.
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Motion Capture Data courtesy of:
House of Moves Motion Capture Studios

The skeleton appears in the Maya scene in the standard

da Vinci pose. In this pose, the character stands straight with
its arms extended out to either side. This pose is useful when
you need to skin a character, retarget animation from one
skeleton to another, or set a rest pose for the skeleton.

In this half of the lesson you learn how to use the Trax Editor
to work with motion capture data.

Note If you are beginning the lesson from this point, you must
first set your panel layouts and display settings for the
Trax Editor and Outliner. Refer to “To set a panel layout
for use with the Trax Editor” on page 230 and "To set the
Outliner to display clips” on page 231.

If your skeleton doesn’t appear as shown, you will need to
increase the size of the skeleton’s joints.

To resize the joints on the skeleton

1 From the main menu, select Display > Joint Size > Custom.
The Joint Display Scale window appears.

2 Set the Joint Display Scale to 10.

3 Close the Joint Display Scale window.
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To preview the motion capture animation

1 Click play on the Time Slider playback controls to play back
the animation.

The skeleton is repositioned and then walks from left to right,
stops, and then sits.

2 Press stop on the Time Slider’s playback control.

Creating clips from motion capture data

When creating a clip from motion capture, it is a good practice to
begin by creating a source clip from the entire motion sequence
that excludes the Da Vinci pose. You can create the clip and save
it to the Visor or Outliner directly without loading it onto a track.
You can later revert back to the source clip and load it into a track
if necessary.

To create a source clip of the motion capture data

1 In the Time Slider, set the Playback Start Time to 1.

'|u 20 40 60 80 100
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2 Press the Go to Start of playback range button to return to
frame 1 in the Time Slider.

@ ZERISEEE

The skeleton is repositioned at frame 1 where the walking
motion begins.

3 In the persp view, select the skeleton by click-dragging a
bounding box around the skeleton.
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The skeleton is highlighted. When the skeleton is selected,

many red ticks appear in the Time Slider. The red ticks
represent keyframes from the motion capture data.

4 In the Trax Editor menu, select Create > Clip > 0.
The Create Clip Options window appears.

5 In the Create Clip Options window, click Edit > Reset Settings

to set the tool to its default settings, and then set the
following:

* Typewalksit in the Name field.

* Keys - Leave Keys in Timeline: On
*  PutClip in Visor Only: On

*  Click Create Clip.

gy}, Create Clip Options [_ O] ]
Edit Help

Nae [w/alkSit
Keys I Leave keys in Timeline:
Clip @ Put Clip in Yisor Onlp

Time Range T Selected
 Time Slider
& Apimation Curve
" Start/End

Start Time ID noon
End Time I'IEI 0oog

Subcharacters ¥ Include Subcharacters in Clip
Timewarp [ Create Time Warp Curve

Include I Hierarchy

‘_ Create Clip ) Apply | Close |

The source clip appears in the Outliner named as

WalkSitSource. (If you use the Visor, the clip appears under

the Character Clips tab.)
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Extending the length of motion capture data

You often need more animation of a motion sequence than is
provided in the motion capture data. For example, you may need
to have a walk cycle that is substantially longer than what was
provided in the original file. You can use the Trax Editor to edit
the motion capture data and create clips that can be cycled to make
longer animation sequences. When you cycle a clip, the clip is
extended in length with duplicate animation from the original clip
over a defined interval of time.

If you want to cycle a clip, you must first determine areas within
the animation sequence where the clip repeats seamlessly. For
example, if you want to create a walk cycle from the motion
capture data, you need to determine the time (frame) where the
right foot is planted on the ground, and then move forward in the
Time Slider, frame by frame, until you find the next frame where
the right foot is planted on the ground in exactly the same (or
very similar) manner, and then create a clip. The resulting clip
will contain two steps of the walking motion. The clip can then be
cycled to produce a motion that repeats. How seamlessly it cycles
depends on the original motion capture data.

In the steps that follow you create a walk cycle from the motion
capture data by:

e Creating a clip from the walking portion of the motion
capture sequence that can be repeated.

*  Cycle the clip to create a longer walk sequence.

To create a clip that can be cycled

1 In the Time Slider, drag the current time indicator to frame 6.

The skeleton updates in the scene to a walking pose where the
right foot is planted on the ground.

2 Drag the current time indicator forward in the Time Slider
until you reach frame 45.
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At frame 45, the skeleton is posed in a similar manner as it
appeared at frame 6. If you use this range of frames (6 to 45),

you can create a clip that can be cycled.
3 In the persp view ensure the skeleton is selected.
In the Trax Editor menu, select Create > Clip > 0.

The Create Clip Options window appears.

5 In the Create Clip Options window, click Edit > Reset Settings

to set the tool to its default settings, and then set the
following:

* TypewalkCycle in the Name field.

*  Put Clip in Trax Editor and Visor: On
* Time Range: Start/End

e  Start Time: 6

* End Time: 45

*  Click Create Clip

gyl Create Clip Options M=l E3
Edit  Help
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= Put Clip in Trax Editor and Yisar

Time Range

m
" Time Slider

* StanyEnd

Start Time IB

SeNeTs toe Sutcnaracters in Clip
Timewarp [~ Create Time Warp Curve

Include I Hierarchy

Create Clip | Apply | Close |

Two clips appear in the Outliner named WalkCycle and

WalkCycleSource.
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6 In the Trax Editor, with the skeleton selected, click the Load
Selected Characters icon.

=[iErH IR

The clip named WalkCycle appears in a new track. Loading
the Character displays any tracks associated with the
character; in this case the WalkCycle clip.

File Edit View Modify Create Library List Panels

FEeToRTE

In the Time Slider, set the current time indicator to frame 1.

8 Click play on the Time Slider playback controls to play back
the clip.

The skeleton takes two steps and stops.

Step 1 Step 2

9 Press stop on the playback controls to stop the playback and
reset the current time indicator to frame 1.
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10 In the Trax Editor, drag the clip to the left in its track until the

Frame In number reads 1.
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This sets the clip to begin at frame 1 in the Time Slider.

In the steps that follow, you cycle the clip to extend the animation
so the skeleton repeats the two step motion and travels farther in
the scene.

To cycle the motion for the walk clip

1
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In the Trax Editor, shift-drag the lower right corner of the
Walk clip to the right until a C2.0 number appears in the new
region of the clip.

When you shift-drag over the Frame Out area, the mouse
cursor changes to a circular pointing arrow to indicate you are
cycling the clip.

Double-click on the cycled clip in the C2 region.

The region is highlighted to indicate you can edit the values in
the region. The number will likely not be exactly 2.0. This
means that the cycle will not repeat exactly twice.

Type 2.0 to modify the clip so it cycles exactly twice.
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With the clip selected in the Trax Editor, open the Channel
Box and ensure that the WalkCycle clip’s Offset channel is set
to Relative.
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WalkCycle

Enable on
[l = =} "

Absolute Rotations on

Setting the Offset attribute for the clip to Relative ensures that
each cycle begins at the position where the last sequence left
off. This ensures that the skeleton doesn’t jump back to its
start point after each cycle.

5 Click play on the Time Slider playback controls to play back
the clip.

The skeleton takes six steps and then stops.

When the clip is cycled twice, the two-step walking motion
occurs three times in total.

6 Press stop on the playback controls to stop the playback and
reset the current time indicator to frame 1.

Redirecting the motion within a clip

Motion capture data can be used in a variety of ways. You can
redirect the motion of a character using the same motion capture
data. The Redirect tool allows you to alter the original animation
for a character by modifying its path or orientation at any time
during its animation. The Redirect tool does this by offsetting the
translation and rotation attributes for the selected character.
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For example, you can change the start or end point of a character’s
animation by redirecting the character’s starting position or by
redirecting its motion during the animation. You can redirect a
character in an existing animation sequence in the scene or a
character associated with a clip within the Trax Editor.

In the steps that follow, you redirect the skeleton to turn to the
right while walking. The workflow for the redirection is as
follows:

e Scrub forward in the animation to determine a location in the
clip where you want the character to turn. A realistic choice is
where the ball of the skeleton’s right foot is planted on the
ground plane because this accurately simulates how a real
person might turn.

*  Select the entire skeleton. In this example, selecting the entire
skeleton selects it at the root joint (the top node of the
skeleton’s hierarchy) Selecting at the root joint ensures that
the entire skeleton gets redirected when the redirection
control is applied.

e Create and position a rotation redirection control using the
Redirect tool.

*  Keyframe an initial starting rotation for the redirection
control.

¢ Rotate the redirection control so the skeleton faces the new
direction of travel.

*  Keyframe the second rotation for the redirection control.

To create a redirection control for the skeleton

1 In the Time Slider, drag the current time indicator to frame 36.

This frame is where the ball of the skeleton’s right foot is
planted on the ground plane. Use this frame as the location
where the skeleton will turn to the right.
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Select the skeleton in the scene view by click-dragging a
bounding box around it.

In the main menu, select Character > Redirect > (J.

In the Redirect Options Window set the Redirection Type to
Rotation only and then click the Redirect button.

il Character Redirection Options
Edit Help

Beadi
F

Type

Fedirect | Apply | Cloze |

A Rotation redirection control appears between the hips of the
skeleton, where the root joint for the skeleton’s hierarchy is.

You want the skeleton to pivot (rotate) while standing on the ball
of its right foot. To do this, you need to move the redirection
control to the ball of the right foot of the skeleton.
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To move the redirection control to the ball of the foot

1

From the Toolbox, select the Move tool.

The Move tool manipulator appears on the redirect
manipulator.

Press the v key and click-drag the redirection control until it is
located on the ball of the right foot as shown below.

Pressing the v key while using the Move Tool momentarily
enables the Snap to Points tool.

The redirection control is now positioned to redirect the skeleton’s
walking motion. To complete the redirection process, you need to
set keyframes while setting the redirection control so the
redirection of the skeleton can occur.

To keyframe the redirection control

1

2
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With the redirection control selected, press s to set a keyframe.

A red tick appears in the Time Slider at frame 36 indicating
the keyframe. Setting a keyframe establishes the starting
rotation for the redirection rotation of the skeleton.

In the Time Slider, drag the current time indicator to frame 57.
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The skeleton updates to a position where its left foot is
planted on the ground plane. This is the location where you
want the skeleton to be rotated to its new direction of travel.

3 In the Channel Box, with the redirection control still selected,
set the Rotate Y attribute to -45.

4 Rotate the redirection control approximately -45 degrees
about the Y axis until the skeleton is facing in the direction
shown below. (You can use the Channel Box values as a
guide.)

5 With the redirection control still selected, press s to set a
keyframe.

Setting a second keyframe establishes when the redirection
rotation for the skeleton ends.

Set the current time indicator to frame 1.

7 Click anywhere in the perspective view to deselect any items
in the scene.
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8 Click play on the Time Slider playback controls to play back
the clip.

The skeleton takes two steps and then turns to its right after it
reaches the redirection control, and continues walking in the
new direction of travel and stops when it completes its walk
cycle.

Redirect occurs

9 Press stop on the playback controls to stop the playback and
reset the current time indicator to frame 1.

Note When redirecting motion within Trax, you may want to
consider creating a clip that contains the redirection
animation to make it possible to reposition the redirect
animation as a clip.

Now that you've redirected the character to a different direction
of travel during the walk cycle, you can reuse some of the motion
from the original source clip you created earlier in the lesson and
saved to the Outliner/Visor.
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You insert the source clip from the clip Library in Trax. The clip
Library keeps track of the source clips and poses for the current
character set. When the source clip is inserted from the Library, a
copy of the source clip is created in a new track.

Once you import the source clip and make a copy of it, you trim
the duplicate clip to make the character stop walking and then sit
in a different location than the original motion capture.

To insert the source clip

1

In the Trax Editor, select Library > Insert Clip. Choose
WalkSitSource from the drop-down list.

A duplicate copy of the WalkSitSource clip is created, and
inserted onto a new track.

In the Trax Editor, select View > Frame All.

The track view area updates to display all clips in their
entirety.

In the Trax control area, click the Mute button for the track
that contains the WalkCycle clip.

# 0

The muted track dims to indicate it is inactive. When the walk
cycle track is muted, the character updates to appear in the Da
Vinci pose at the origin based on the original source clip.

Drag the current time indicator to frame 98.

The skeleton updates in the view and the redirection that was
applied also occurs. Remember that the redirection occurs for
the character, and not the clip.

Click on the WalkSit clip in the track to select it.
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6 In the Trax tool bar, click the Trim Clip Before Current Time
icon to trim the section of the clip that occurs before frame 98.

=B ] w o T (D

The WalkSit clip is trimmed and the portion of the clip before
frame 98 is discarded.

7  Click the Mute button again for the track containing the
WalkCycle clip to reactivate the track.

The dimmed track becomes active again. The skeleton
however has updated to an incorrect pose near its previous
position. This occurs because the two active clips overlap, and
the character is receiving conflicting positional information as
a result. (that is, double translation and rotation information)

8 Drag the WalkSit clip to the right in its track until its Frame In
number matches the Frame Out for the WalkCycle clip.

The pose for the skeleton is updated to the correct position.
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9 Reset the current time indicator to frame 1.

10 Click play on the Time Slider playback controls to play back
the animation.

The skeleton takes two steps and then turns to its right after it
reaches the redirection control, and continues walking in the
new direction of travel, stops, and then sits.
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11 Press stop on the playback controls to stop the playback and
reset the current time indicator to frame 1.

A small jump cut occurs during the transition between the two
clips. The jump cut occurs because the poses for the skeleton do
not match from the end of the first clip and the beginning of the
second. In your own work, try to anticipate how motion will
blend between clips when working in Trax. You can correct the
jump cut in this particular example by extending the WalkCycle
clip.

To extend the WalkCycle clip to correct the jump cut

1 In the Trax Editor, double-click on the WalkCycle clip in the
C2 region.

The number becomes highlighted indicating you can edit the
number.

2 Type 2.2 to edit the clip so it cycles 2.2 times.

The new Frame Out number for the WalkCycle clip becomes
126. It now overlaps in time with the WalkSit clip.
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3 Drag the WalkSit clip to the right until its Frame In number
becomes 126.

4 Click play on the Time Slider’s playback control to play back
the animation.

The jump cut is less noticeable than before.

5 Press stop on the Time Slider’s playback control.

You have completed this lesson. Before leaving this lesson,
reset the joint size back to its default setting.
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To reset the joint size

1

3

From the main menu, select Display > Joint Size > Custom.
The Joint Display Scale window appears.

Set the Joint Display Scale to 1.

Close the Joint Display Scale window.

Beyond the lesson

In this lesson, you learned some fundamental techniques for using
the nonlinear animation tools in Trax. You learned how to:

Key animation sequences for use as nonlinear clips in Trax.

Clips can contain minimal or many animated attributes. You
can create clips from existing animation or key animation
specifically for use in clips. You should consider what
attributes you need represented in a clip when you key the
animation before you decide to use nonlinear animation in
your work. In this way, a clip can be used to control a specific
attribute.

Create clips from your animation sequences for use in the
Trax Editor.

When you create a clip, a character set is created if one does
not already exist. You can load and work with multiple
character sets in the Trax Editor. To select different character
sets when working in Trax you can use the Select Current
Character drop-down menu. Clips can also be arranged,
scaled, and moved as groups. For more information see
Arrange clips and Track view area in the Maya Help.

Use the Trax editor to position, re-arrange, cycle, and scale
clips in order to create and modify animation sequences in the
scene.

If a character animates or scales in a manner you had not
expected when working in Trax, you may want to check to see
if the clips overlap or are arranged in a manner that doesn’t
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provide the expected results. In addition, a clip containing
motion that is intended to be appended to another clip’s
motion must have its Offset attribute set to Relative, and
Absolute Rotations set to On (in most instances). There are
many other tasks you can perform with clips in the Trax
Editor that are beyond the scope of this lesson. For more
information see Nonlinear animation components in Maya in the
Maya Help.

*  Use the Trax Editor to work with motion capture data.

The Trax Editor is useful when working with motion capture
data. Since motion capture data usually contains a lot of
keyframe information, the Trax Editor can be useful for
creating, modify, and extending the motion data provided.
Cycling and redirecting motion are two methods that can be
used to get more from your motion capture data. For more
information see the section on Motion Capture Animation in
the Maya Help.

*  Redirect the motion for a character using the Redirect tool.

You can use redirection controls to redirect any type of
motion in Maya (Keyframe, motion capture, expressions,
dynamics, and so on) For more information and additional
examples on redirection see How do I redirect the motion of an
animated character? in the Maya Help.

e Trim clips in the Trax Editor.

You can trim a clip either before or after the current time
indicator discarding the remainder of the clip in the process.
You can also split a clip into two parts. The original source
clip is not affected. For more information see Split clips in the
Maya Help.

Blending clips

You can blend the animation between clips. Blends allow you to
create smooth transitions and mixes between different motions. A
blend can be applied between any two clips that overlap entirely,
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partially, or not at all. The best results are obtained when blending
between similar motions. In some situations, a blend can be used
to correct jump cuts. For more information see Create and edit
blends in the Maya Help.

Key into clip

You can set keyframes to alter the animation within a clip. This
process is called Keying into a clip. When you key into a clip,
keyframes are placed at the current time on all the animation
curves in the selected clip. For more information see Key into Clip
in the Maya Help.

Time Warps

Time Warps let you change the timing of a clip without modifying
the clip's animation curves. You modify the Time Warp by editing
the animation curve that controls the warp. Time Warps can also
be used to reverse the animation in a clip. For more information
see Create and edit time warps in the Maya Help.

Visor and Outliner

Both the Visor and Outliner can be used to access clips. The Visor
provides a graphical interface to access other resources (clips,
poses, shaders, textures, brushes etc.) in your scene. The Outliner
displays clips in a textual manner, and is a bit more compact.

Audio clips

You can display and play multiple audio files in Trax allowing
you to synchronize your motion clips to specific audio events
(sound effects, musical notes, drum beats etc.) in the audio file.
Once you import an audio file into Trax, you can then move and
rename the audio clip. For more information see Work with sound
in the Maya Help.
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Lesson 5 Inverse Kinematics

Model created by Rob Ormond

Inverse Kinematics (IK) allows you to efficiently pose your
models and characters for animation. You pose the skeleton by
positioning IK handles, usually located at the end of an IK joint
chain (for example at the hand). The rotations for the other joints
are calculated automatically by an IK solver. An IK solver
calculates the rotations of each joint back up the hierarchy of the
joint chain based on the position of the IK handle. See "Creating a
skeleton hierarchy” on page 280 for more information on
skeletons and joints.

By contrast, Forward Kinematics (FK) requires you to rotate each
joint in turn until you have the desired pose for a keyframe. This
can be a tedious process when posing a complex skeleton. When
using Inverse Kinematics, it’s faster to pose a character because
the joint rotations further up the hierarchy are calculated
automatically based on the placement of the IK Handle. Using
both FK and IK techniques on the same skeleton is called FK/IK
blending.
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IK is obviously useful for posing animated characters that have a
skeleton (two-legged, four-legged etc.) and has others
applications, such as posing skeletons within mechanical-like
models.

The goal of this lesson is to animate a mechanical arm so that it
extends into a position over a cargo box, picks up and moves the
cargo box to another location, and then sets it down.

As you work through the lesson, you’ll learn about many of the
basic features related to skeleton hierarchies, IK, and parent
constraints. Some initial setup of the model and IK is required so
that it can be posed and keyframed to provide a convincing
animation.

In this lesson you learn how to:

*  Create and use hierarchies to define logical relationships
between animatable objects.

*  Combine the components of a 3D mechanical arm model into
a hierarchical grouping.

¢ Construct a skeleton for use with IK.

e Combine the skeleton with the mechanical arm model by
parenting the components into a hierarchy.

*  Create an IK system to allow the skeleton hierarchy to be
posed.

e Create a control object to manipulate the IK system.

*  Use constraints to control the position and orientation of
components within the IK system.

*  Limit the range of movement on the IK system.
* Pose and set keyframes for the IK system.

* Animate an object by constraining its motion to two or more
objects.
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Open the scene for the lesson

In this lesson, you work with a scene we created for your use. In
the first steps of this lesson, you open the scene and view the
various elements that have been created for your use.

1 Make sure you've done the steps in “Preparing for the
lessons” on page 179.

2 Open the scene named IK MechArm.mb.

You can open the scene named IK MechArm.mb from the Maya
Documentation, Lessons, and Extras CD or from the drive where
you copied the Getting Started files.

The scene contains a model of a mechanical arm and a cargo
box to be moved by the arm. The components of the
mechanical arm include:

* A cargo magnet cup on the end
*  Three arm segments

¢ A base for the arm to swivel about

* A four-legged base for the assembly

Cargo Magnet

Arm Segments
Swivel Base

Cargo Box

Base

To work with this model using IK you must create a hierarchy for
it.
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Understanding hierarchies

Inverse Kinematics relies on hierarchical relationships between
the components of a model and the IK system to pose and
animate the components. Before using Inverse Kinematics it is
important to understand hierarchies in Maya.

A hierarchy is composed of a series of nodes that are combined
for some purposeful relationship. Individual nodes may represent
the surfaces of a model, a network of textures that describe a
shading material, or series of joints in a skeleton. Hierarchies are
structured in a top-down manner, with one node at the top (the
parent node or root node) and other nodes (child nodes or leaf nodes)
attached and interconnected beneath the top node.

% Parent_node

R Child_node |

&> Child_node2 |

Selecting the parent node at the top of the hierarchy also selects
the items contained in the hierarchy below. Selecting a child node
lower in the hierarchy selects any child nodes that are lower in the
hierarchy.

Hierarchies allow you to create complex structures with
relationships between components. For example, when you
animate a hierarchical model, you simply need to select and move
the parent node of the hierarchy and the rest of the model (child
nodes) also moves.

Regardless of whether you decide to animate the mechanical arm
using FK or IK, or a combination of both methods on the same
model, the best approach involves making the mechanical arm
model into a hierarchical structure.
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Creating a hierarchy for the mechanical arm ensures that:

Components of the hierarchy can be rotated as if they were
one unit. A common pivot point is created at the parent node
level. This allows the separate components to rotate as one
unit based on their membership in the hierarchy. For example,
if the mechanical arm’s base (parent node) is rotated, anything
lower down the hierarchy, for example, the mechanical arm
which is constructed of child nodes, will also rotate because of
its membership and position in the hierarchy.

When a particular segment of the model is posed and
keyframed, the components that are lower in the hierarchy are
also posed and keyframed.

Viewing hierarchies using the Hypergraph

In the following steps, you use the Hypergraph to view the

hierarchy for the mechanical arm. The Hypergraph is a scene
management editor that presents a graphical view of the scene
hierarchy. It allows you to more easily create, understand, and
manage the hierarchy of objects and nodes in your scene.

To view hierarchies using the Hypergraph

1 From the perspective view’s panel menu, select Panel >
Layouts > Two Panes Stacked.

The workspace displays two panels stacked on top of each
other with an identical perspective view of the scene.

2 In the lower panel, select Panel > Panel > Hypergraph.
The lower panel displays the Hypergraph.
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In the Hypergraph menu, select Graph > Scene Hierarchy.

If the menu item appears dimmed, it indicates that the
Hypergraph is already displaying the scene hierarchy

The Hypergraph displays with a black background by default.
In order to see the relationships between the items, the
background has been modified for the images in this lesson.

In the Hypergraph menu, select View > Frame All to see all
the components of your scene.

The boxes represent the nodes for the various items in the scene.
Some items in the scene have already been parented into a
hierarchy. This is indicated by the lines connecting some of the
nodes. Selecting the nodes in the Hypergraph also selects the item
in the scene view.

To select an item using the Hypergraph

In the Hypergraph, click each of the separate items in the
hierarchy at the parent level to select them. At the same time,
observe which objects become highlighted on the model in the
perspective view.
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Hierarchies combine the various objects into discrete components
for the mechanical arm, that is, the base, lower arm, middle arm,
upper arm, etc. If you select and rotate any of the parent nodes in
the hierarchies, none of the other arm components follow because
they are not combined into one unified hierarchy.

Creating a skeleton hierarchy

Joints

o

Bones

To link the various components of the mechanical arm into a
hierarchy that can be posed, you need to create a skeleton. A
skeleton is a hierarchy of joints that are connected together with
bones.

In the scene, a joint represents a special type of node that gets
created in a skeleton hierarchy. A joint acts as the parent node for
any other joints that occur in the hierarchy below it. Each joint has
a rotational pivot point associated with it. A bone is the visual
representation used in the scene view to connect the joints and
help visualize the joint chain.
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A skeleton is similar to a skeleton in the real world in that acts as
the underlying structure for the surfaces to be attached. While you
can view the skeleton with its bones and joints in the scene view,
it does not appear in your rendered images. Its purpose is to assist
you in setting up and posing your models and characters and to
visualize the motion you want to achieve.

Skeletons are integral to the animation of any character or
hierarchical model. Examples of characters that use skeletons are
two and four legged animals. Skeletons are also useful for
animating other organic components such as the tail of an animal,
a tentacle of an octopus, or a snake.

In the following steps, you create a simple skeleton consisting of
four joints that you combine with the mechanical arm model into
a skeleton hierarchy, allowing you to pose and animate the model.

To create a skeleton for the mechanical arm

1 In the perspective view menu, select Panels > Orthographic >
side.

The view updates to display the side view.

You need to view the components of the mechanical arm fully
in the side view so you can draw the joints for the skeleton.
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2 Resize the side view to a larger size by dragging the border
between the side and Hypergraph panel views downwards.

3 In the side view menu, select Shading > Wireframe (Hotkey 4)

4 From the main menu, select Skeleton > Joint Tool > (3.

The Tool Settings window for the Joint Tool appears. The
Joint Tool is used to create the joints and bones for a skeleton.

5 In the Joint Tool settings window, do the following:
*  Click Reset Tool to set the tool to its default settings.
Gw ResetTod

LI Joint Settings
Degrees of Freedom W % W ¥z

Orientation | =pz

-
-

‘world Axiz Orient | +y

V¥ Scale Compenzate
™ Auto Jaint Limits
[T Create Ik Handle

_>| IK Handle Settings

* Hide the Tool Settings window by clicking the right-
pointing arrow that is located in the upper left corner of
the Tool Settings window.

6 In the side view, starting from the base of the mechanical arm,
do the following:
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*  Click in the center of each pivot pin on the mechanical
arm to place four joints as shown in the image below.

Try to click as close to the center of each pivot pin as you can,
as the rotation of the joints on the model will be based on the
location of the joints on the skeleton. As you place the joints, a
bone appears, connecting each joint. (Because the model lies
along the YZ plane, the joints are created close to the center of
each corresponding joint on the mechanical arm model.)

*  After you place the fourth joint, press Enter to indicate
that the last joint has been placed.

Click 4

Click 3
Click 2

Click 1

In the Hypergraph, dolly the view to see the skeleton node
hierarchy you just created. (It appears at the right side of the
view.)

In the Hypergraph, select the jointl node.
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The entire skeleton becomes selected. Any rotations on this
node also affect anything lower down the hierarchy.

9 Select joint2 (You can also press the down arrow on your
keyboard to select further down the hierarchy)

&, joint1 n
&, jon2 B B
LS 3
=

Select joint2 node

[}
1k

Skeleton is selected
at the second joint e

The skeleton is selected from joint2 downwards in the
hierarchy. Any rotations that you make on this node affect
only joint2 and nodes below joint2.

Once a skeletal hierarchy is created, the various surface
components can be added to the hierarchy.

Parenting a model into a skeleton hierarchy

Parenting is the term used when placing a node beneath another in
a hierarchy so it becomes the child of the node above it (its parent)
in the hierarchy.

In the following steps, you add the surfaces of the mechanical arm
model into the skeleton hierarchy. This process links the models’
surfaces to the skeleton hierarchy making it possible to pose and
animate the model like a real mechanical arm. Using the
Hypergraph to select the nodes allows you to better visualize the
process and the hierarchical relationships that result.
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Note

The following parenting procedure works well for the
mechanical arm (no organic bending or deformation
occurs) and provides one technique for adding modeled
objects to a skeletal hierarchy.

A more common technique for combining a character
model into a skeleton hierarchy is referred to as skinning
or binding. The Bind Skin tool combines the surface
components and joints together into a hierarchy and also
takes into account any deformations that may occur
when a character bends or flexes (knees, waist, neck,
elbows etc.). Maya provides a few methods for skinning.
For more information see Skeletons and skinning in the
Maya Help. For a tutorial on skinning see “Smooth
skinning” on page 344.

To parent the mechanical arm into the skeleton

1 In the Hypergraph menu, select View > Frame All.

The Hypergraph displays all the nodes for the scene.

2 Inthe Hypergraph, select the node named ArmEnd and then
shift-select the node named joint4.

The order of selection is important. You want to select the
child node first, and then shift-select the item that will become
the parent node second.

3 In the main menu, select Edit > Parent (Hotkey p).

In the Hypergraph, joint4 is now the parent node for the
Arm_end node in the skeleton hierarchy.

4 Repeat the parenting process for the following items:

pin3 is parented under joint3
pin2 is parented under joint2

pinl is parented under jointl
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Your new hierarchy should appear as shown in the diagram
below.

In the next steps, SwivelBase becomes the parent node for the
new hierarchy so that the entire arm assembly swivels about
the center of the base component.

In the Hypergraph, select the node named jointl and then
shift-select the node named SwivelBase.

In the main menu, select Edit > Parent (Hotkey p).

Change the panel display to a layout that allows you to view
the hierarchy in the Hypergraph.

In the side view menu, select Panels > Layouts >
Two panes side by side.

The panels display in a side by side configuration.

Dolly the Hypergraph view as required to view the new
hierarchy.
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In the Hypergraph, select the node named Swivel_base.

In the side view, observe that both the mechanical arm model
and the skeleton are selected. Swivel_base is the parent or root
node for the hierarchy. If you rotate SwivelBase, everything
else below that node (the entire arm with skeleton) rotates.

Select the node named joint3.

Observe that the last two components of the mechanical arm
are selected. If you rotate joint3, only the components below
that node in the hierarchy will be affected.

Select the node named pin2.

Observe that only one isolated segment of the model is
selected. No other components or joints are selected when
pin2 node is selected. If you rotate the model at pin2, only the
component at pin2 will rotate in isolation from the rest of the
hierarchy because it is located lower in the hierarchy.

It is now possible to select and rotate the skeleton joints to pose
the mechanical arm as a unit, and then set keyframes to animate
it. Posing a character using joint rotations is referred to as
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Forward Kinematics (FK). FK allows for precise control when
setting up a pose, but it can be a time consuming process to select
and rotate each joint into the desired position.

When an animation is more focused on the goal of placing the end
joint in a hierarchy in a particular position, (for example, a hand
or a foot), it is more efficient to use Inverse Kinematics to pose the
skeleton. For more information on forward and inverse
kinematics, see Posing skeletons in the Maya Help.

Note It’s not a simple matter to state that one technique or
another is the only approach to achieving a desired
result when animating in Maya. You must decide
whether a particular technique works for a particular
scenario based on the options it provides. A combination
of animation techniques can be creatively used in a
variety of ways.

Applying IK to a skeleton hierarchy

IK allows you to control the joint rotations in a skeleton using an
IK handle. You pose the skeleton by positioning the IK handle
(usually located at the end extremity of the skeleton) and having
the rotations for the other joints calculated automatically by the IK
solver. In the steps that follow, you apply IK to the skeletal
hierarchy.

To create an IK handle for the mechanical arm

1 From the main menu, select Skeleton > IK Handle Tool > 0.

The IK Handle Tool Settings window for the Joint Tool
appears. When the mouse pointer is in the orthographic view
its appearance changes to the tool's cross hair cursor.

Getting Started with Maya
288



6 | Animation
Lesson 5 > Applying IK to a skeleton hierarchy

2 In the IK Handle Tool settings window, do the following:
*  Click Reset Tool to set the tool to its default settings.
*  Set the IK Handle Settings: Current Solver - ikSCsolver.

Reset Tool '

Y
%ndle Tool

IK Handle Settings

Current Solver | ikSCsolver =

LIOPTOnGy
¥ Solver Enable
V¥ Snap Enable
I™ Sticky

Friority [T L
Weight [Too00 f—————————
POWeight |1 0000 |

* Hide the Tool Settings window by clicking the right-
pointing arrow that is located in the upper left corner of
the Tool Settings window.

The ikSCsolver setting selects the IK Single Chain Solver. This
solver ensures that the joints in the skeleton will lie along a
single plane. This solver is well suited for the mechanical arm,
because the arm doesn’t need to twist unlike a real arm.

3 Working in the side view, starting from the base of the
mechanical arm, do the following:
*  Click on the skeleton joint at the base of the mechanical
arm.

*  Click on the skeleton joint at the tip of the mechanical
arm. (The IK Tool is designed to attach to the joints closest

to your selection point.)
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Click 2

Click 1

In the side view, the IK handle is drawn as a line from the
start and end joints of the IK chain.

4 In the Hypergraph menu, select View > Frame AlL

In the Hypergraph, two new nodes appear in the hierarchy
that represent the IK chain: an IK Handle node and an end
effector node.

5 In the Hypergraph, select the node named ikHandlel.

The IK Handle (in combination with the end effector) is used
by the IK solver to calculate the rotation of the joints in the IK
chain. By default, the IK Handle is located at the last joint of
the IK chain in the scene view.
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6 Select the Move Tool from the Toolbox, and drag the Move
Tool’s X axis manipulator (blue arrow) to reposition the
mechanical arm.

When you drag the manipulator, the skeleton and mechanical
arm model are repositioned.

7 Reset the mechanical arm to its previous position by selecting
Edit > Undo until the mechanical arm is positioned into its
previous orientation.

Note When using the Undo feature, do not undo so many
times you inadvertently undo the IK handle you've just
created.

The next steps describe how to manipulate the IK Handle using a
control object.

Creating a control object for an IK system

Using the IK Handle to pose an IK chain is generally not a good
practice. The IK Handle can be challenging to select in the scene
view, especially when it’s grouped into a hierarchy that includes a
skeleton and other surface components. A better practice is to
create a control object.

You create a control object to select and manipulate an IK system
instead of directly using the IK Handle. You can create a control
object with a curve or a locator, which are often used because they
don’t appear in the rendered image.

The control object controls the movement of the IK Handle using
a constraint. You can constrain the position, orientation, or scale of
an object to other objects using constraints.

To create a control object:

e Create and position the control object in the scene view.
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*  Name the node for the control object in the Hypergraph.

*  Freeze transformations for the control object.

Label the control object in the scene view.

e Constrain the IK Handle to the control object.

To create a control object using a locator

1 From the main menu, select Create > Locator.

A three-dimensional cross is created at the origin in the scene
view.

2 Select the Move Tool from the Toolbox.

3 In the side view, reposition the locator slightly above and in
front of the end of the mechanical arm as shown in the image
below.

To easily identify the locator as a control object in the
Hypergraph, rename the locator.

To rename the control object using the Hypergraph

1 In the Hypergraph, right-click the node named locatorl.
Choose Rename from the pop-up menu that appears.

The locatorl name is highlighted on the node.
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2 Type the name ArmControl and press Enter to save the name
for the locator.

&, ikHandle1 ‘ A o | ‘

Before you constrain the IK handle to the control object, you need
to freeze the transformations for the control object. Freeze
Transformations zeros the transformations for an object without
changing the position of the object. This is another good practice;
If it becomes necessary to reset the arm to its default position, you
can set the transformation on the control object to zero, and the
arm will be return to this default pose.

To freeze the transformations for the control object

1 In the Hypergraph, select the node named ArmControl.
The control object is selected in the scene view.

2 In the main menu, select Modify > Freeze Transformations >
a.

3 In the Freeze Transformation Options window do the

following:
*  Select Edit > Reset Settings to set the tool to its default
settings.

e (lick the Freeze Transform button.

“Mr.eze Transformations Options

;1]
Fieeze ¥ Translatd ¥ Rotate W Scale ™ Joint Orient

I

| 2l
Freezs Transform Apply Close |

e
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The transformations for ArmControl are set to zero. From this
point onwards, you can reset its position to this location by
zeroing its translations in the Channel Box.

To easily identify the locator as the control object in the scene
view, label the control object using an annotation. An annotation is
a text label that can be set to point at the labeled item.
Annotations are useful because they always face the viewer,
regardless of the orientation of the model in the scene view.

To label the control object in the scene view

1 In the Hypergraph, select the ArmControl node.

2 In the main menu, select Create > Annotation.
A input window appears.

3 Type ArmControl and click OK.

In the scene view, the word ArmControl appears near the
locator /control object. In the Hypergraph, two new nodes
appear in a hierarchy beneath ArmControl.

* ArmContral
* annotationLocator] ‘

Emf annotation? )

4 With the annotation still selected, select the Move Tool.

5 In the side view, drag only the annotation so it appears
slightly offset from the locator object as shown below.

The annotation displays in any scene view so you can easily
identify the control object for selection.
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To simplify the display of the Arm Control node

1 In the Hypergraph, right-click the ArmControl node. Choose
Collapse from the pop-up menu. (You can also double-click a
node to collapse or expand the hierarchy below it.)

The ArmControl node appears as a single node instead of the
previous three node hierarchy. The small arrowhead on the
lower left-hand corner of the node indicates that the node is

collapsed.
é ArmContral

The control object must be linked to the IK Handle to control the
IK Handle.

Constraining an IK system

You can constrain the IK Handle to the control object
(ArmControl) using a point constraint. A point constraint allows
the transformation attributes of one object to be controlled by the
transformations of another object. For example, you select and
position ArmControl without having to touch the IK Handle. You
also set the constraint so ArmControl maintains the current
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distance (offset) from the IK Handle. The offset ensures that the
constrained IK handle doesn’t move to the same position as the
control object.

To constrain the IK Handle to the control object

1 In the Hypergraph, select the ArmControl node and then shift
select the ikHandlel node.

The order of selection when applying a constraint is
important: you must select the constraining object first, and
the item to be constrained second.

2 In the main menu, select Constrain > Point > (7.
The Point Constraint Options window appears.
3 In the Point Constraint Options window, do the following:

*  Select Edit > Reset Settings to set the tool to its default
settings.

*  Turn on the Maintain Offset setting.
*  Click the Add button.

iy}, Point Constraint Options
Edit Hslp

Maintain Offset 2 1}

00 A0 k ikHandle! ‘
Constraint &xes I All
Cx ey rz
weight [1.0000 — ' \kHand\etpothonstralﬂ
4] E - > 4

Add | Apply | Clase

The IK handle is constrained to the control object. In the
Hypergraph, a constraint node is created beneath the
ikHandlel node.

4 In the Hypergraph, select only the ArmControl node.
5 In the Toolbox, select the Move Tool.
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6 In the side view, drag the manipulator to reposition the
control object. (Experiment with a few different positions in
the side view only.)

When you drag the manipulator, the control object moves,
which in turn moves the IKHandle. Because the IK handle
controls the skeleton and the mechanical arm model, they also
move. The offset between the control object and the IK Handle
is maintained.

The Cargo Magnet does not continuously point downwards when
rotated. Its orientation is based on the original rotation it had in its
original position.

The mechanical arm will be easier to pose if you set Cargo Magnet
to be oriented downwards towards the floor of the scene
regardless of the orientation of the other components of the arm.

Incorrect Correct
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You make CargoMagnet point downwards using an orient
constraint. An orient constraint constrains the orientation
(rotation) of the X, Y, and Z axes of one object to match those of
the constraining (target) object.

In the next steps, you reset the position of the mechanical arm to
its default position, and then apply an orient constraint to the last
joint in the IK system so that its orientation matches the control
object. The effect is that CargoMagnet points downwards
regardless of any other movement in the scene.

To set the IK system to its default position

1 In the Hypergraph, select the ArmControl node.
2 Open the Channel Box by clicking the Show/Hide Channel

Box icon.
& @ 8 | B

3 In the Channel Box, set the X, Y, and Z transformations for
ArmControl to 0.

Zeroing the transformations on ArmControl resets the
mechanical arm to its home position because of the freeze
transformations step you performed in the previous section.

4 Close the Channel Box by clicking the Show /Hide Channel
Box icon.

To apply an orient constraint for the IK system

1 Inthe Hypergraph menu, select View > Frame All.
The Hypergraph displays all the nodes in the scene.

2 In the Hypergraph, select ArmControl and then shift-select
the node named joint4. (You may need to dolly and track the
Hypergraph view to view these nodes.)

3 In the Main Menu bar, select Constrain > Orient > (J.
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4  In the Orient Constraint Options window, do the following;:

*  Select Edit > Reset Settings to set the tool to the default
settings.

¢  (Click the Add button.

Joint4 is constrained to have the same orientation as the
control object. In the Hypergraph, the constraint node is
created below the joint4 node in the hierarchy.

F

5 With only the ArmControl node selected, use the Move Tool
to reposition ArmControl in the side view.

CargoMagnet maintains an orientation facing the floor of the
scene regardless of how the mechanical arm is positioned in
the side view.

In the next section, you learn how to limit the range of movement
for the IK system.
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Limiting the range of motion of an IK system

It’s possible to move ArmControl so that the mechanical arm fully
extends to a straight position or orients itself to other positions
that you don’t necessarily want.

You can limit the range of motion of the arm to ensure that the IK
system poses in a predictable manner. In the following section,
you limit the motion for the IK system as follows:

Lock the translation of the control object (ArmControl) so that
it can only move in Y and Z. By locking the X channel so it
cannot be selected or modified, the arm will not be able to
move from side to side.

Lock the rotations on the swiveling base for the arm so it only
rotates about its Y axis, and not about its X or Z axes.

Limit the translations for the Arm Control so the mechanical
arm cannot fully extend to a straightened position.

To lock the Translate X channel for ArmControl
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In the Hypergraph, select the ArmControl node.

Open the Channel Box to view the transform channels for
ArmControl.

Set all Translate or Rotate channels to 0, if they are not
already.

In the Channel Box, select the Translate X channel by clicking
on its name.

Channels Ohject

ArmControl

Translate " 0
Translate 2 0
Rotate s 0

Right click on the word Translate X.

A drop-down menu appears.
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From the drop-down menu, choose Lock Selected.

Channels Object

Translate 2 0
Rotate s 0

The numerical field for Translate X is dimmed indicating that
the channel is locked. If you try to move ArmControl in X, it
will not be possible unless you unlock the Translate X
channel.

lock the Rotate X and Z channels for SwivelBase

In the Hypergraph, select only the SwivelBase node.

Open the Channel Box to view the rotation channels for
SwivelBase.

Set all Translate or Rotate channels to 0, if they are not
already.

In the Channel Box, select the Rotate X and Rotate Z channels
by control-clicking on their names.

Right click on either of the selected names.
A drop-down menu appears.

From the drop-down menu, select Lock Selected.

Channels Ohject

SwivelBase
Translate & 0
Translate ' 0
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To confirm that the Rotate X & Z channels are locked

1

In the Hypergraph, ensure only the SwivelBase node is
selected.

In the view, select Panels > Orthographic > top.
In the view, select Shading > Smooth Shade All.

Dolly the top view so you can fully view the mechanical arm
as shown below.

Using the ChannelBox, rotate SwivelBase by typing 45 in the
Rotate Y channel and pressing Enter.

P02
.o‘ 0 !f O

Rotated like this Expected it to rotate Iik]e this

SwivelBase rotates in the view but the mechanical arm does
not rotate. You first might think something is wrong because
SwivelBase and all of the arm’s skeletons and surfaces are
parented into the same hierarchy.

Note  You may sometimes discover that something doesn’t

work in the manner you originally anticipated when
setting up an IK system. When this occurs, it’s useful to
stop and diagnose why something is working the way it
is (or not working the way it should). In that way you
can retrace your actions to determine where the problem
resides.
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% CargoBox

& Platform & ikHandlet | 4 A Control
A

L ¥ ikHandiel_po

ArmControl and IK Handle are not parented into the SwivelBase
hierarchy. Because ArmControl and IK Handle control the
movements of the mechanical arm, they must be parented into the
SwivelBase hierarchy in order for the arm to rotate when
SwivelBase is rotated.

To parent the IK Handle into the skeleton hierarchy
1 Inthe Hypergraph, select the SwivelBase node.

2 In the ChannelBox, reset the Rotate Y channel for SwivelBase
to 0.

Setting any previous transformations to zero is necessary
before parenting the IK Handle beneath SwivelBase in the
hierarchy.

3 Inthe Hypergraph menu, select View > Frame All.
The Hypergraph displays all the nodes for the scene.

4 In the Hypergraph, shift-select the nodes named ikHandlel,
ArmControl, and SwivelBase.

The order of selection is important. You want to shift-select
the items that will be the child nodes first, and then shift-
select the item that will be the parent node last.

5 In the main menu, select Edit > Parent (Hotkey p).

In the Hypergraph, IKHandle and ArmControl are now child
nodes for the SwivelBase node in the skeleton hierarchy.
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6 In the Hypergraph, select only SwivelBase.
7 Using the ChannelBox, set Rotate Y for SwivelBase to 45.

A+

When SwivelBase is rotated, the mechanical arm rotates
because of its relationship within the hierarchy.

8 Reset the Rotate Y value for SwivelBase back to 0.

Finally, you want to limit how far Arm Control can translate away
from the base of the model so the arm does not extend to a fully
straightened position.

To determine the settings for the translation limits you need to
examine the position of the mechanical arm in various positions
while simultaneously viewing the translation values in the
ChannelBox.
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To determine translation limits for the Arm Control

o A~ W

In the Hypergraph, select ArmControl.

Ensure the Channel Box is open so you can view the translate
channels for ArmControl.

In the view, select Panels > Orthographic > side.
Dolly the side view so you can fully view the mechanical arm.
Select the Move Tool.

In the side view, press the middle mouse button and drag the
mouse diagonally until the mechanical arm is fully extended
as shown below.

In the Channel Box, observe the number that displays in the
Translate Y and Z channels.

When the arm is diagonally articulated above the cargo box, it
is almost fully extended when the translation values are
roughly as follows:

e Translate Y: 7.5
e Translate Z: 1

In the side view, press the middle mouse button and drag the
mouse in a diagonally until the mechanical arm is almost fully
compressed as shown below.

Getting Started with Maya
305



6 | Animation
Lesson 5 > Limiting the range of motion of an IK system

9 In the Channel Box, observe the numbers that display in the
Translate Y and Z channels.

When the arm is articulated to a compressed pose, the
translation values are roughly as follows:

e TranslateY: -13
¢ Translate Z: -13

These minimum and maximum values will be used in the
steps that follow as the minimum and maximum translation
limits for the ArmControl.

To set translation limits for the Arm Control

In the Hypergraph, select the ArmControl node.

2 Open the Attribute Editor (Window > Attribute Editor or click
on the Show/Hide Attribute Editor icon on the Status Line).

ﬁﬁgswss

The Attribute Editor displays the nodes associated with Arm
Control.

3 In the Attribute Editor, click the ArmControl tab.

If the ArmControl tab is not visible, use the left and right
scrolls arrows to scroll the view sideways to view it.
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3

List Selected Focus Attributes Help
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4 In the Attribute Editor, expand the Limit Information
attributes, and then the Translate attributes.

||_>| Transform Attributes

Limit Information

~ | Translate

Trars Limit ' [ I"I-DD

Trars Limit 2 [ I"I-DD

<
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5 In the Translate attributes, click the Trans Limit Y and Z check
boxes to undim the numerical boxes and then set the

following values:

e Trans Limit Y (Min): -13
e Trans Limit Y (Max): 7.5
e Trans Limit Z (Min): -13

e Trans Limit Z (Max): 1

Trans Limit % [~ I-'I.UD
Trans Limit v [V |-13.UU
Trans Limit 2 |-13.DU

6 Hide the Attribute Editor.

7 Select ArmControl.

Current fdax
< |Jo.oo [foo
< |-1.00 (750
< |[-1.00 o0 =
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8 In the side view, move ArmControl to test the range of
movement for the IK system.

The mechanical arm moves with a limited range of motion.

Simplifying the display of a hierarchy

The number of nodes in the IK system’s hierarchy at this point
may appear a bit overwhelming, but it allows the posing of the
mechanical arm to be efficient and effective. You can simplify the
display of the nodes by collapsing portions of the hierarchy.

To collapse the display of the hierarchy
1 In the Hypergraph, right-click on joint1, and choose Collapse
from the pop-up menu.

The child nodes below jointl disappear simplifying the
display of the hierarchy. The small arrowhead on the corner
of the jointl node indicates that a hierarchy exists below
jointl. If you later need to view or select these nodes you can
expand them again.

2 Collapse the ArmControl and IKHandle nodes.
The display of the hierarchy is simplified as shown below.

- AmBase | #e SwivelBase | e CargoBox | i Platform |

E{.joiml

& ikHandle1
. A Contrel

The IK system is now rigged and ready for animation.

Applying parent constraints on an IK system

To animate the cargo box so that it is picked up by the mechanical
arm you need a method of constraining the cargo box to the
mechanical arm so that it moves with the arm at specific times in
the animation. This is accomplished using a parent constraint.
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Lesson 5 > Applying parent constraints on an IK system

When a parent constraint is applied to an object, the constrained
object behaves as if it were a child node of the constraining object.

An object can have multiple constraints applied to it. The
influence each constraint has on the object can be changed by
modifying the weight attribute for the parent constraint. The
weight attribute is an animatable parameter and can be set to be
on or off at specific frames.

In this lesson, the cargo box is constrained to both the ArmControl
and the Platform on the floor. By animating the weight attributes
for these two parent constraints, the cargo box will move from one
location to another depending on which constraint is influencing
it at specific times in the animation.

To set up the parent constraints you need to position the
constrained object at the locations where the influence will begin
or end, and then set the parent constraints.

To set parent constraints for the cargo box

1 In the side view menu, select Shading > Smooth Shade All.
2 In the side view menu, select Panels > Perspective > persp.
3 Inthe Hypergraph, select ArmControl.
4

In the ChannelBox, set the Translate Y and Z values as
follows:

e Translate Y: -9
* TranslateZ: 0
The arm is repositioned so that the cargo magnet is directly above

the cargo box as shown below. Track, tumble, or dolly the view if
required so you can see the mechanical arm unobstructed.
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Lesson 5 > Applying parent constraints on an IK system
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ArmControl
Translate & [0
Translate v -9
Translate 2 0

In the Hypergraph, with ArmControl still selected, shift-select
the CargoBox node.

The order of selection is important when you apply
constraints. You must select the constraining object first, and
the item to be constrained second.

In the main menu, select Constrain > Parent > .
In the Parent Constraint Options window, do the following:

*  Select Edit > Reset Settings to set the tool to its default
settings.

¢ (Click the Add button.

CargoBox is constrained to ControlArm. A new constraint
node has been created below the CargoBox node in the
Hypergraph. If you reposition the mechanical arm, CargoBox
moves with it because of the constraint that is now applied.

® CargoBox ‘

( ! CargoBox_parentCons ’

In the Hypergraph, select only SwivelBase.

In the ChannelBox, set the Rotate Y value for SwivelBase as
follows:

e Rotate Y: -100
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The mechanical arm and the cargo box are positioned as
shown below.

SwivelBase
Translate s 0
Translate " 0
Translate 2 0
Fotate x5 0
Rotate

Rotate Z 10

10 In the Hypergraph, select Platform and then shift-select the
CargoBox node.

11 In the main menu, select Constrain > Parent.

CargoBox is constrained to Platform. This is the second
constraint for the CargoBox.

12 In the Hypergraph, select only CargoBox.

13 In the ChannelBox, view the parent constraints for CargoBox.

Channels Ohject

CargoBox
Translate & -25.186
Translate v 3.161
Translate £ -4.441
Rotate s 0
Fotate " 260
Fotate 2 0
Scale® 8.059
Scaley 8.059
Scale 2 8.059
Wisibility_on
SHAPES
CargoBoxShape
CargoBox_parentConstra
Mode State Mormal

Arm Contral W0 1
‘ Platform ‘w1 1
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Lesson 5 > Applying parent constraints on an IK system

CargoBox has two parent constraints applied to it: Arm
Control and Platform. In the ChannelBox, the numerical
settings beside ArmControl W0 and Platform W1 represent
the influence weight each parent constraint has on CargoBox.
At this point, each influence weight is set to a value of 1. If
you move the mechanical arm, the cargo box will move
somewhere between its first and second position. This occurs
because each constraint has equal influence on the cargo box
at this point.

Before you can animate the objects in the scene, you also need to
reset the default weight values for each constraint, so that one
parent constraint has full influence on CargoBox when the other
does not.

To set the weighting for the parent constraints

1
2
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In the Hypergraph, select only CargoBox.

In the ChannelBox, set the following:

* Platform W1: 0

Select only SwivelBase.

In the ChannelBox, set the Rotate Y value to 0.

The mechanical arm and cargo box are rotated back.
In the Hypergraph, select only CargoBox.

In the main menu, select Constrain > Set Rest Position.

Setting a rest position for CargoBox sets a position for the
cargo box when no constraints are acting upon it. If the rest
position is not set, CargoBox will be repositioned to the
second constraint position.

In the ChannelBox, set the following:

e ArmControl W0: 0
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Lesson 5 > Planning an animation for an IK system

At this point, both parent constraints are set to have no
influence on the cargo box because their weight attributes are
set to zero. When you animate the components in the scene,
the weight attributes for the parent constraints will be set and
keyframed depending on which constraining object (Arm or
Platform) is required to have full influence.

In the next steps, you plan the action for animation of the IK
system.

Planning an animation for an IK system

Now that the mechanical arm and cargo box are fully set up for
animation it’s a simple matter to pose the arm and set keyframes.
Prior to setting any keyframes you should take a few moments to
plan the action for the scene.

Planning the action usually involves sketching a simple
storyboard, and writing out a brief timeline for the action for each
component. In this lesson we’ve provided a simple version for
you. The basic premise for the action is as follows:

*  The cargo box is positioned directly in front of the mechanical
arm.
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Lesson 5 > Planning an animation for an IK system

*  The mechanical arm extends, and positions the cargo magnet
to be directly touching the top of the cargo box.

*  The mechanical arm extends upwards, lifting the cargo box,
and rotates to the side.

*  The mechanical arm lowers the box, placing it in a new
position.
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Lesson 5 > Planning an animation for an IK system

e The mechanical arm extends upwards, leaves the cargo box in
the new location, and rotates back to its original position.

The table below breaks down the action indicating what action
occurs for each object at the specified keyframes.

Frame | Mechanical Arm Cargo Box

1 Collapsed position Initial position

30 Vertically extended Initial position
position

60 Vertically lowered so that Initial position
cargo magnet is positioned
on top of cargo box

80 Vertically lifted to extended | Cargo box lifted with
position with cargo box mechanical arm

100 SwivelBase rotated along Cargoboxrepositioned

with arm to side

along with mechanical
arm
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Lesson 5 > Animating an IK system

Frame | Mechanical Arm Cargo Box

120 Vertically lowered along Cargo box is lowered
with cargo box to second along with mechanical
position above surface arm to second position

140 Vertically lifted to extended | Second position
position

160 SwivelBase rotated with Second position
arm to original position

180 Collapsed position Second position

To pose the mechanical arm you select either the ArmControl or
SwivelBase nodes and set a keyframe depending on which
component you want to pose:

¢ ArmControl controls the movement of the mechanical arm.
e SwivelBase controls the rotation of the arm.

* CargoBox’s position is based on the parent constraint weights.

Animating an IK system

The animation sequence occurs over a 180 frame period. Before
you begin to set keyframes you set the playback range in the
Animation Timeline/Slider.

To set the playback range in the Time Sl