
UW Card Sort Analyzer User Manual    Katherine Deibel 

 
Page 1 

UW Card Sort Analyzer: Version 1.0 

1. Introduction 
This manual contains an introduction to the use of the UW Card Sort Analyzer and the various 
tools it provides. This application is designed for quantitative analysis of results from card 
sorting experiments [3].  The core of its analysis method is the edit distance metric described in 
the work by Anderson, Anderson, and Deibel [1].  While the metric was developed for analyzing 
the results of the Bootstrapping experiment [2], this application is designed to handle card sorts 
from any experiment that used this knowledge elicitation technique. 

2. Loading and Closing Card Sorts 
Figure 1 shows the analyzer when initially started.  One window is auto-created and present: the 
Card Sort Manager.  The manager is in charge of loading card sorts and the selection of sorts for 
use by the analysis tools (see Section 3 for more on selecting). 

2.1. The Card Sort Loader 
To load card sorts, the user has four options: 
 

1. Pressing the Load Sorts button found on 
the manager 

2. Pressing the  button on the toolbar 
3. Selecting ‘Load Sorts’ from the File Menu 
4. Pressing  Ctrl-L 

 

Upon doing this, the Card Sort Loader window 
will appear (see Figure 2).  The loader contains 
three tabs for the loading of card sorts, card 
descriptions, and probe sorts (probe sorts are not 
currently implemented in this version).   

2.1.1. The Card Sorts Tab 

Figure 2 shows the card sorts tab.  Three format 
options are available on the left.  Each of these 
indicated if the files contain Sorter IDs, pile 
labels, and/or sort criterion (the overarching 
theme for a sort).  The number of cards is also 
adjusted here.   
 
To select the files to load from, the user presses 
the ‘Add Files’ button.  This opens up a file 
browser dialog that allows multiple file selection.  

 

Figure 1. The Analyzer on startup 

 

Figure 2. The Card Sort Loader Window 
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Once the user returns from the dialog, the selected files appear in the list box.  The user can 
choose to add more files or remove any of the chosen files.  To remove one or several files, 
select them and then press ‘Remove Files.’  The ‘Clear’ Button will remove all files listed. 

2.1.2. The Card Details Tab 

Figure 3 shows the card details tab.  The use of this 
tab is optional, but it does enhance the use of two 
tools: the Key Tool and the Information Tool (see 
Sections 5.1 and 5.2).  The card description/details 
are a mapping of the card numbers to descriptions 
of the cards. Choosing a details file (see Section 6.2 
for details on the file format) is done through a 
simple file browser. 

2.1.3. The Probe Sorts Tab 

This tab is used for loading sorts that are specifically for the probing analysis method described 
in [1].  Currently, the probing tool is not fully implemented, so this tab can be ignored for now. 

2.1.4. Exiting the Card Sort Loader 

Only upon pressing the ‘OK’ button will the card sorts and card descriptions actually be loaded.  
If you choose to not load any cards, you may press the ‘Cancel’ button or the close window 
button on the loader.  Note that there might be a small delay when loading many card sort files. 

2.2. Closing Card Sorts 
There are effectively two ways of closing card sorts.  The first is to use the card sort loader and 
remove various files from being loaded.  This is the only way to close only a few files.  To close 
all the loaded sorts, there are three options: 
 

1. Pressing the ‘Close Sorts’ button on the manager. 

2. Pressing the  button on the toolbar.  
3. Selecting ‘Close Sorts’ from the File Menu. 

 

It should be noted that closing and/or changing what sorts are loaded effectively disables all 
analysis tools that are currently open.  See Sections 4 and 5 for more details on this. 

3. Selecting Card Sorts 
Figure 4 shows a card sort manager that has been loaded with several card sorts.  Five of these 
sorts have been selected already.  Notice that more of the toolbar buttons are now activated.  The 
act of selection is what enables the use of the various analysis tools. 

 

Figure 3. The Card Details Tab 
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3.1. Selecting With the Mouse 
Selecting with the mouse is the simplest way of selecting 
sorts.  The selection method works just like other multi-
selection interfaces found in other Windows applications.  
Pressing down the left mouse button and dragging the 
cursor selects large swaths of sorts.  To select sorts that 
are discontinuous from each other, press the control 
button while clicking the mouse button.   
 
To unselect a sort, press the control key and click on a 
selected sort.  If multiple sorts are selected, clicking on 
any sort will unselect all but the clicked on sort. 

3.2. Select All Command 
The ‘select all’ aid automatically selects every card sort that has been loaded into the manager.  It 
is operable through three means: 
 

1. Pressing the ‘Select All’ button on the manager. 

2. Pressing the  button on the toolbar. 
3. Selecting the ‘Select All’ menu item in the Edit Menu. 

3.3. Invert Selection Command 
The invert selection flips the selection currently in the manager.  Card sorts that were selected 
are unselected and vice versa.  As with all selection aids, this command can be executed through 
three means: 
 

1. Pressing the ‘Invert Selection’ button on the manager. 

2. Pressing the  button on the toolbar. 
3. Selecting the ‘Invert Selection’ menu item in the Edit Menu. 

3.4. Selection by Pile Counts Command 
One common selection method in card sort analysis is to only look at card sorts with certain 
numbers of piles.  The user can select the minimum and maximum number of piles through the 
‘Pile Filter’ interface found on the card sort manager (see Figure 5). 

 
Once the minimum and maximum number of piles has been inputted, the 
user can then select the sorts that meet this restriction by: 
 

1. Pressing the ‘Select Filtered’ button on the manager. 

2. Pressing the  button on the toolbar. 
3. Selecting the ‘Select Filtered by Piles’ menu item in the Edit Menu. 

 
 

Figure 4. A loaded card sort manager 

 
 

Figure 5.  Pile tool 
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4. Exploration Tools 
In the Analyzer application, there are several types of tools.  This section looks at the exploration 
type of tools.  These tools, as the name implies, allows the researcher to discover and examine 
the relationships between different card sorts through the use of the edit distance metric.  These 
tools include the methods described in [1]. 

4.1. How Exploratory Tools Work 
When card sorts are selected in the manager window, this 
enables the user to spawn various tools.  This allows the 
researcher to have multiple tool windows open at any time.  
Moreover, each tool can work with its own non-empty subset of 
the sorts contained in the card sort manager.  One tool window 
might be a comparer tool looking at all the sorts produced by 
sorter MS86, while a clique-finder tool is working on sorts 
containing only three piles.   
 

This multi-tasking approach does create a few issues.  If a tool is open and the selection changes 
in the manager, the tool is made aware of the change (see Figure 6).  However, its local copy of 
the sorts is not changed.  The tool will continue to function normally.  If the user so desires, the 
local set of card sorts can be updated to be the manager’s current selection (by pressing the 
update button in Figure 6). 
 
However, if the user changes the sorts that are loaded, the exploratory will become disabled due 
to changes in the distance calculation engine.  Although the tools functions are disabled, the 
tool’s calculation results remain available for perusal and saving (once saving is implemented).   

4.2. Comparer Tool 
The comparer tool, shown in Figure 7, is used for 
calculating the edit distance between two or more 
card sorts.  It is currently working with three card 
sorts, two of which have been selected and compared.   
 
The top scroll region contains the local set of card 
sorts for this tool.  When two or more sorts are 
selected, the ‘Compare’ button gets enabled.  When 
pressed, the distance between the selected sorts is 
computed and displayed in the bottom scroll bar 
region.  The size of both the top and bottom regions 
can be adjusted through the use of the dark gray 
splitter just above the results text box. 

 
Figure 6. A Comparer Tool after a 
selection change in  the manager 

 

Figure 7. The Comparer Tool 
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The comparer tool provides one option for the display of results. When ‘Show Matchings’ is 
selected, the tool displays the maximum weighted matching used to calculate the edit distance.  
Shown in a two column format, each column is made up of the piles that make up one card sort, 
while the rows represent the piles that were matched up between the two card sorts. 
 

1. The comparer tool can be spawned through two means: 

2. Press the  button on the toolbar. 
3. Select the ‘Comparer Tool’ item in the Tools menu. 

4.3. Neighborhood Tool 
The Neighborhood Tool shown in Figure 8 is used 
to discover the set of card sorts that are within a 
threshold distance of ∆ (delta) from a selected 
sort.  Even more generally, this tool gives a list, in 
increasing distance, of how far all sorts are from a 
specific sort. 
 
Like with the Comparer Tool, the Neighborhood 
tool consists of two regions: a selection box and a 
results box.  The relative sizes of these two can be 
shaped by a similar splitter.  However, the ‘Find 
Neighborhood’ is only activated when exactly one 
sort is selected. 
 
Two options are provided for the user.  The first is the ‘Maximum Distance’ checkbox and 
number box.  If the checkbox is checked, the tool will only display sorts that are within that 
distance (inclusive) from the selected sort.  The other option is the ‘Neighborhood Size’ 
checkbox and number box.  When the check box is checked, the result box will only display the 
N closest sorts to the selected sort, where N is the number in the number box. 
 
The neighborhood tool can be spawned through two means: 

1. Press the  button on the toolbar. 
2. Select the ‘Neighborhood Tool’ item in the Tools menu. 

4.4. Clique Finder Tool 
The Clique-Finder Tool is shown in Figure 9.  As described in [1], the Clique-Finder Tool is 
used for finding sets of sorts such that the mutual distance between all of them is less than or 
equal to some specified threshold distance.  In this tool, a single card sort is selected as the 
‘center’ of the clique.   
 

Figure 8. The Neighborhood Tool 
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Like with the other exploration tools, the Clique-
Finder tool consists of two regions: a selection box 
and a results box.  The relative sizes of these two can 
be shaped by a splitter as with the other tools. 
 
The clique finder provides multiple options.  The first 
and most important is the ‘Maximum Distance’ 
number box that determines the threshold distance.  
The other two options allow the user to fine tune the 
approximation algorithm that finds the cliques.  The 
drop-down list allows the user to choose which 
heuristic the clique-finding algorithm uses.  When 
finding a clique, the algorithm continually chooses a 
vertex (i.e. card sort) to add to the clique until there 
are no more to choose.  Currently, the clique-finder 
tool provides four heuristics for choosing the vertex: 
 

1. “Pick Vertex with Highest Degree in Reduced Graph (D)”: 
The vertex chosen is the one with the highest degree in the graph being looked at.  If 
there are ties, the algorithm chooses a vertex in a deterministic fashion. 
 

2. “Pick Vertex with Highest Degree in Reduced Graph (R)”: 
This heuristic is the same as the first except that ties are broken in a randomized fashion. 
 

3. “Pick with Uniform Probability (R)”: 
In this heuristic, the vertices are selected at random using a uniform probability 
distribution. 
 

4. “Pick with Degree-Weighted Probabilities (R)”: 
Vertices are assigned probabilities based on the degrees in the graph, and then one is 
randomly selected for inclusion in the clique. 

 

The ‘Iterations’ number box becomes activated whenever a randomized heuristic (those ending 
with ‘(R)’) is chosen.  The number in this box indicates how many times the algorithm will run.  
All results will be displayed. 
 
The clique-finder tool can be spawned through two means: 

1. Press the  button on the toolbar. 
2. Select the ‘Clique-Finder Tool’ item in the Tools menu. 

5. Information Tools 
Another sort of tool provided in the Analyzer are the information tools.  Information tools 
perform automatic operations that help the user understand individual card sorts. 

 

Figure 9. The Clique-Finder Tool 
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5.1. Key Tool 
The Key Tool is shown in Figure 10.  When a card sort description file is loaded, the key tool 
becomes enabled.  This tool simply contains the mapping of card numbers to card descriptions. 

 
The key tool is immune to selection changes in the card sort 
manager, but it will be deactivated if the card sort description file 
changes. 
 
The key tool can be spawned through two means: 

1. Press the  button on the toolbar. 
2. Select the ‘Key Tool’ item in the Tools menu. 

 

5.2. Information Tool 
In contrast to the Key Tool, the Information Tool provides considerably more information.  
Shown in Figure 11, the information tool consists of two regions: the selection box/find region at 
the top and the sort information/distance information/card piles region at the bottom. 

 
The selection box in the upper-left corner contains all 
the card sorts currently loaded into the card sort 
manager.  Each time a sort is selected, the lower region 
is updated.  The ‘Sort Information’ region gives 
general details about the card sort.  To help the 
research understand the distance properties of the 
selected sort, the ‘Distance Information’ region 
displays some distance statistics.  Finally, the ‘Card 
Piles’ region displays the card piles in a more human-
readable format.  If a card description file has been 
loaded, the card descriptions are also shown. 
 

One final region is the ‘Find Card Sort’ region in the upper-right.  This region provides three 
search options for exploring the loaded card sorts: 
 

1. Index Find:  
This find lets you quickly select any card sort index. 
 

2. Sorter ID Find:  
This find will select the first card sort created by the desired sorter. 
 

3. Text Find: 
This find performs a general text search of the loaded card sorts.  After initially searching 
for a specific text, the search can be repeated to move on to the next sort containing that 
text. 

 
 

Figure 10. The Key Tool 

Figure 11. The Information Tool 
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The information operates independently of the selection in the manager.  However, changes to 
the set of load card sorts will disable the tool. 
 
The information tool can be spawned through two means: 

1. Press the  button on the toolbar. 
2. Select the ‘Information Tool’ item in the Tools menu. 

6. File Formats 
Although the Analyzer is fairly flexible in terms of input, there is a general structure to its input 
files that should be maintained.   

6.1. Card Sort File Format 
A card sort file may contain multiple sorts, but it is presumed that all sorts to be analyzed are in 
the same format.  The four key format properties are number of cards, sorter IDs, sort criterion, 
and pile labels.  Figures 12 and 13 show two example card sort files.  Note that in both figures, 
individual sorts are separated by a blank line and that individual lines list the cards found in a 
pile. While a comma is required, it is permissible to have spaces after the comma. 
 
Figure 12 is a file that uses only pile labels.  The syntax for 
a pile label is the label followed by a colon.   
 
Figure 13 uses both a sorter ID and sort criterions.  The 
sorter ID is the first line of the file and must be followed by 
a blank line.  Sort criterions, a.k.a. descriptions of the sorts, 
are the first lines of each individual sort.  The next lines 
after a criterion are that sort’s piles. 
 
In many cases, the loader will humbly ignore a malformed 
file entry.  For example, if a sort does not contain all the 
cards, that sort will not be loaded.  Do not rely on this 
behavior, though.  There is no guarantee that malformed 
input will load in a clean or sensible way.  Remember: 
garbage in, garbage out. 

6.2. Description File Format 
The description file is the file that maps card numbers to 
card descriptions.  This file has a strict format but is overall 
very simple.  Figure 14 shows an example file.  As one can 
see, the format is the card number, a hyphen, and the card 
description.  The card numbering is assumed to start at 1. 

A: 1,2,3 
B: 5,6,7 
C: 4,8 
 
Pile 1: 1,5,7 
Pile 2: 3,4,6,8 

 

Figure 12. An example card sort file 

ME 
 
My first sort 
1,2,3 
5,6,7 
4,8 
 
My second sort 
1,5,7 
3,4,6,8 

 

Figure 13. An example card sort file 

1-function  
2-method 
3-procedure 
4-class dependency 
5-object 
6-decomposition 

 

Figure 14.  An example description 
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